Java Developer Package

mackay

Aktives Mitglied
Thread Starter
Mitglied seit
05.01.2003
Beiträge
2.513
Hallo, brauche Eure Hilfe!

Die OS X 10.2 beiliegende Developer CD hatte ich Vorgestern installiert (Stand Juni 2002).

Habe mir gerade das Update für Java 1.4.1 Developer vom Dezember 2002 gesaugt.

Beim Installieren bekomme ich jetzt die Meldung:

Zielvolumen auswählen: ! Sie können diese Software nicht auf diesem Volumen installieren. 21

Ich hab ein iBook 500 die Anzeige spricht von freien 5,9GB.

Was hab ich falsch gemacht, bzw. was bedeutet diese 21?

Kann mir jemand helfen?
Danke im Voraus!

Kay
;)
 

Vevelt

Aktives Mitglied
Mitglied seit
01.09.2001
Beiträge
1.634
Wenn...

...ich mich nicht irre, dann benötigst du auch neuere Developer-Tools... :confused:

Gruß, Vevelt.
 

mackay

Aktives Mitglied
Thread Starter
Mitglied seit
05.01.2003
Beiträge
2.513
Hallo Vevelt,

die Developer Tools-CD liegt dem OS X 10.2.2 bei. Diese hab ich dann installiert und es funktioniert ja auch alles (was ich bis jetzt ausprobiert habe) nun nehme ich an einem Lehrgang teil zum Java-Programmierer (und das auf meine alten Tage) ;)
Und da ich Handcoder bin hatte ich an den Project Builder gedacht.

In anderen threads hier wurde auf das Update der Developer Tools hingewiesen und so habe ich mir die geladen. Auch weil Java 1.4.1 ja gerade erst upgedatet wurde.

Oder brauch ich das alles nicht?

Kay
 

mj

Aktives Mitglied
Mitglied seit
19.11.2002
Beiträge
8.743
Die Developer Tools von Juni 2002 sind nicht die aktuellen, die aktuellen findest du auf http://connect.apple.com nachdem du dich als ADC-Member registriert hast. Die Registrierung ist kostenlos und als OS X Programmierer würde ich es dir auch empfehlen.

Soweit ich weiß kannst du das JAVA Update ohne weiteres installieren wenn du überhaupt keine Developer Tools installiert hast, sind diese jedoch drauf, müssen es die neuesten sein. Aktueller Stand ist derzeit soweit ich weiß Dezember 02
 

mackay

Aktives Mitglied
Thread Starter
Mitglied seit
05.01.2003
Beiträge
2.513
Jau D'Espice,

das hatte ich schon oben geschrieben. Angemeldet habe ich mich auch :) sonst hätte ich das Update vom Dezember ja nicht bekommen!

Das Problem liegt darin - dass weder bei meinem iBook noch bei einem der mir zur Verfügung stehenden 8 iMac's sich die Tools installieren lassen :mad:

Bei allen kommt die Meldung: Sie können diese Software nicht auf diesem Volumen installieren. 21

So, und nun kommst du!


Kay ;)
 

Vevelt

Aktives Mitglied
Mitglied seit
01.09.2001
Beiträge
1.634
Du...

...kennst Eclipse? Solltest du dir in Bezug auf Java mal ansehen... :D
So könntest du auch das Problem um gehen, wenn du Eclipse anstatt Project-Builder nutzt, solange dir niemand mit dem Fehler 21 weiterhelfen kann.

Lieben Gruß, Vevelt.
 

mackay

Aktives Mitglied
Thread Starter
Mitglied seit
05.01.2003
Beiträge
2.513
Ja danke Vevelt,
das hattest du schon in einem früheren Thread empfohlen.

Nur löst das ja das Problem nicht!

Vielleicht habt ihr ja noch eine Adresse, an die man sich in
solchen Fällen wenden kann? ;)

Kay ;)
 

Vevelt

Aktives Mitglied
Mitglied seit
01.09.2001
Beiträge
1.634
Die...

...Apple-Support Foren wären da noch eine sichere Anlaufstelle... :D

Gruß, Vevelt.
 

mackay

Aktives Mitglied
Thread Starter
Mitglied seit
05.01.2003
Beiträge
2.513
Das ist doch ein Wort!


Kenn ich noch nicht, hast du eine Adresse? Oder muss ich mich so auf die Google machen :D

Kay ;)
 

kurare

Aktives Mitglied
Mitglied seit
06.06.2003
Beiträge
1.176
Thread-Lösung ?!

Original geschrieben von mackay
Das Problem liegt darin - dass weder bei meinem iBook noch bei einem der mir zur Verfügung stehenden 8 iMac's sich die Tools installieren lassen :mad:

Bei allen kommt die Meldung: Sie können diese Software nicht auf diesem Volumen installieren. 21
 

Ich hatte den Fehler auch immer gehabt, und da bin ich auf diesen Thread bei meiner Suche gestoßen, leider fehlte auch hier die Lösung. :(

Ich für meine Teil habe aber mein Problem gelöst. Das Java Developer Package lässt sich nur installieren, wenn man den Xcode Developer und Java schon installiert hat.
Nachdem ich Xcode 1.1 installiert hatte, konnte ich auch den Java Developer 1.4.2 installieren. Das stand ja eigentlich auch bei den Anforderungen, die der Java Developer beim Aufruf der Installation (jedenfalls unter Panther) auflistet... ;)