Java-Cocoa-Applikationen auf IntelMacs

  1. Jan-Michael

    Jan-Michael Thread StarterMacUser Mitglied

    Mitglied seit:
    28.02.2005
    Beiträge:
    391
    Zustimmungen:
    0
    Hallo Leute,

    erstmal eine relativ generelle Frage zu den neuen IntelMacs. Werden Cocoa-Java-Programme auch ohne neues Kompilieren auf den IntelMacs laufen, wenn sie auf einem PPC compiliert wurden?
     
    Jan-Michael, 12.01.2006
  2. Gremlin

    GremlinMacUser Mitglied

    Mitglied seit:
    11.01.2006
    Beiträge:
    742
    Zustimmungen:
    3
    Solange sie keine weiteren nativen (JNI) Bibliotheken einsetzen, ja. JNI-Bibliotheken müssen als Universal Binaries kompiliert sein, damit sei auf einem Intel-Mac verwendbar sind. Ein Java-Programm das PowerPC JNI-Bibliotheken einsetzt, läuft nicht auf Intel-Macs - auch nicht unter Rosetta.

    Gremlin
     
    Gremlin, 12.01.2006
  3. Jan-Michael

    Jan-Michael Thread StarterMacUser Mitglied

    Mitglied seit:
    28.02.2005
    Beiträge:
    391
    Zustimmungen:
    0
    Danke für deine schnelle Antwort :D.
     
    Jan-Michael, 12.01.2006
  4. xero

    xeroMacUser Mitglied

    Mitglied seit:
    29.05.2005
    Beiträge:
    679
    Zustimmungen:
    1
    Werden die Intel Macs eigentlich mit Java 1.5 bzw. 5.0 ausgeliefert?
     
    xero, 12.01.2006
  5. Jan-Michael

    Jan-Michael Thread StarterMacUser Mitglied

    Mitglied seit:
    28.02.2005
    Beiträge:
    391
    Zustimmungen:
    0
    @xero: k.a., denke aber schon. Schließlich läuft auf denen doch OS X 10.4.4 . Da ist Java 5.0 doch mit drin, oder?
     
    Jan-Michael, 15.01.2006
  6. Gremlin

    GremlinMacUser Mitglied

    Mitglied seit:
    11.01.2006
    Beiträge:
    742
    Zustimmungen:
    3
    Nein, Standard ist immer noch 1.4.2 - ziemlich peinlich, dass Apple dabei immer noch ihre ach so tolle Java-Unterstützung anpreist. Java 1.5 muss man separat downloaden und installieren. Das nächste Update von Java 1.5 wird sich als Standard-JVM installieren, aber die gibt es bis jetzt nur als Developer Preview nur für PPCs.
    Von daher glaube ich nicht, dass die Intel-Macs standardmässig mit Java 1.5 kommen. Ich habe aber (noch) keinen hier stehen, deswegen kann ich es nicht sicher sagen.

    Gremlin
     
    Gremlin, 15.01.2006
Die Seite wird geladen...
Ähnliche Themen - Java Cocoa Applikationen
  1. NOcTua
    Antworten:
    17
    Aufrufe:
    957
  2. ChrisR
    Antworten:
    1
    Aufrufe:
    680
  3. sepplmuetze
    Antworten:
    5
    Aufrufe:
    1.098
    sepplmuetze
    09.11.2005
  4. Jan-Michael
    Antworten:
    0
    Aufrufe:
    554
    Jan-Michael
    22.09.2005
  5. Bl4cKbIrD
    Antworten:
    1
    Aufrufe:
    534
    Bl4cKbIrD
    20.10.2004