internet explorer/css a:link etc.

  1. culture

    culture Thread StarterMacUser Mitglied

    Mitglied seit:
    30.01.2004
    Beiträge:
    21
    Zustimmungen:
    0
    hallo web-designer!

    ich beschäftige mich im rahmen eines projektes erstmals ernsthaft mit css und habe ein eigenartiges problem:

    der internet explorer verarbeitet die css-formatierungen für a:link, a:hover etc. nicht sauber. dies sowohl auf dem mac (os x 10.3.2 ie 5.2.3) als auch auf den windows-kisten (nt4sp5 mit ie 6, bzw. xp pro mit ie 6). das verhalten ist jedoch nicht einheitlich, d. h. entweder funktioniert die formatierung a:link, dafür die anderen a:-formate nicht oder es funktioniert a:hover, dafür alle anderen a:-formate nicht.

    opera auf win nt4 und safari stellen die a:-formate richtig dar (dafür stimmt bei diesen browsern die position von layern nicht...).

    kennt jemand das phänomen mit den a:-formatierungen und weiss eine lösung (wenn's geht, nicht mit rollover und bilddateien).

    und: ja, leider muss ich die site für den ie programmieren, da dieser browser unternehmensstandard ist, ich darauf keinen einfluss habe und mit meinem mac sowieso ein exot bin :rolleyes:

    bin für jeden tipp dankbar!
     
    culture, 07.02.2004
  2. xlqr

    xlqrMacUser Mitglied

    Mitglied seit:
    08.09.2003
    Beiträge:
    1.942
    Zustimmungen:
    15
    es bleibt dir nichts anderes übrig als mindestens 2 *.css (win.css und netscape.css) zu schreiben und dann vermittels browserabfrage jeweils richtig einzuspeisen.

    wg. dem explorer ist schon ok. jeder der möchte, dass seine sites gekuckt werden, richtet sich zumindest ein bisschen nach ihm. (sind es in dt nicht ca.96% die ie nutzen?)
     
    xlqr, 07.02.2004
  3. etienne

    etienne

    Das Einhalten der Reihenfolge der Pseudoformate ist wichtig, damit es richtig funktioniert:
    a:link, a:visited, a:hover, a:active.

    Ansonsten wäre es vielleicht sinnvoll die Seite zu sehen, um gezieltere Hilfestellungen geben zu können...
     
    etienne, 07.02.2004
  4. culture

    culture Thread StarterMacUser Mitglied

    Mitglied seit:
    30.01.2004
    Beiträge:
    21
    Zustimmungen:
    0
    danke, das werde ich berücksichtigen, wenn ich mal eine site "für die grosse weite welt" programmiere. im moment stellt sich diese frage aber nicht. abgesehen davon verarbeitet auch netscape 4.6 (auf win nt4) die css-formatierungen für a:.... nicht (obwohl er eigentlich sollte).

    culture

    :music
     
    culture, 07.02.2004
  5. culture

    culture Thread StarterMacUser Mitglied

    Mitglied seit:
    30.01.2004
    Beiträge:
    21
    Zustimmungen:
    0
    hey etienne, vielen dank, genau das war's! javascript:smilie('clap')

    culture
     
    culture, 07.02.2004
  6. stegoe

    stegoeMacUser Mitglied

    Mitglied seit:
    25.01.2004
    Beiträge:
    24
    Zustimmungen:
    0
     Netscape 4 weis aber nichts mit der Pseudoklasse a:hover anzufangen.
     
    stegoe, 08.02.2004
Die Seite wird geladen...