IE Box-Modell-Bug?

Dieses Thema im Forum "Web Page Design" wurde erstellt von Chuonrad, 14.02.2005.

  1. Chuonrad

    Chuonrad Thread Starter MacUser Mitglied

    Beiträge:
    360
    Zustimmungen:
    97
    Mitglied seit:
    27.08.2004
    Hallo Community,

    ich habe die Aufgabe, einen Fehler in einer meiner HP ausbügeln zu müssen.

    Die Situation:

    link zur testseite

    das kleine Rolloverbildchen (BIOGRAFIE) ist ein gif. transparent eingestellt ist die Schrift. der entsprechende Layer hat eine hintergrundfarbe. beim rollover ändert sich die HG- Farbe. Siehe Testlink. Das funktioniert auch toll in Safari, FF, Mac-IE. Nur im PC-IE steht unter dem bildchen noch ein stück layer über, das dementsprechend die Farbe des Layers hat und somit als Balken oder dicker Unterstrich unter dem Wort erscheint.

    das dazugehörige style-sheet findet sich hier.

    Ich habe jetzt einige Zeit darauf verschwendet, mein Style-Sheet zu überarbeiten leider ergebnislos.

    Hat jemand eine Ahnung, warum der PC-IE hier wieder aus der Reihe tanzt und wie ich das abstellen kann?

    Diese Lösung hat sich aus dem Arbeitsprozeß ergeben - wenn nix anderes klappt, muss ich eben wieder "normal" arbeiten und die Schrift entsprechend einfärben.
     
  2. Difool

    Difool Frontend Admin

    Beiträge:
    8.211
    Medien:
    30
    Zustimmungen:
    1.054
    Mitglied seit:
    18.03.2004
    Hi,

    ich hab jetzt zwar keine Lösung parat, weiß aber, daß der IE bei Layern rumzickt. Wieso?
    K.A. – der IE/Mac verhält sich auch anders als der IE/WIN und umgedreht.
    Ich hab da schon mehrmals die "große Steinkugel" den U-Berg raufgerollt...

    Gruß Difool
     
  3. Chuonrad

    Chuonrad Thread Starter MacUser Mitglied

    Beiträge:
    360
    Zustimmungen:
    97
    Mitglied seit:
    27.08.2004
    ähä!?

    wo zickt denn der IE nicht rum?

    mittlerweile habe ich rausbekommen, dass es "offenbar" am "background-image" liegt. Ein Layer mit ähnlichen styles - ohne background-image - mit <img>-tag, mit dem selben bild befüllt, zeigt alles korrekt an.

    bloß - was hilft mir das jetzt? :(
     
Die Seite wird geladen...

Diese Seite empfehlen