.htaccess auf dem Apache-Server von OS X

  1. Doboune

    Doboune Thread Starter MacUser Mitglied

    Mitglied seit:
    19.11.2003
    Beiträge:
    77
    Zustimmungen:
    0
    Hi,

    ich bin gerade dabei, lokal eine Seite zu erstellen, für die ich das PHP-CMS brauche. (www.phpcms.de) Dieses CMS arbeitet mit einer Parser-Funktion (/parser/parser.php?file=....). Um diesen unnötigen Parameter zu verhindern wird eine .htaccess-Datei erstellt, die ein ständiges Parsen von Dateien mit bestimmten Endungen (in diesem Falle .htm) bewirkt.

    Ich will das ganze auf dem vorinstallierten Apache-Server von OS X zum laufen bringen, dazu muss die ganze Geschichte erstmal in den Document-Root-Ordner (also /Liberary/WebServer/Documents) verschieben – dort wird es später wieder herausegenommen, ich will die ganze Sache erstmal zum Laufen bringen. Allerdings lässt mich OS X ja keine Dateien erstellen, die mit einem Punkt beginnen. Also versuche ich es hintenrum über UNIX und dem Terminal-Dienstprogramm. Ich habe jetzt die .htaccess im Document-Root erstellt. Jetzt sollte diese ganze Parser-Geschichte laufen. Aber – HAHA, sonst wäre ich ja nicht hier – das tut sie nicht. (<- Überraschung!!) Warum nicht? Unterstützt der vorinstallierte Server keine .htaccess vielleicht? Weil ja auch die Rechte-Vergabe von Dateien per Betriebssytem selbst läuft (also über das Informations-Dialogfeld z. B.) oder über Unix "chmod". Kann mir einer helfen?

    Liebe Grüße
    Timo
     
    Doboune, 04.01.2005
    #1
  2. lupusoft

    lupusoft MacUser Mitglied

    Mitglied seit:
    05.01.2004
    Beiträge:
    250
    Zustimmungen:
    4
    Moin, doch tut er, allerdings musst du die httpd.conf Datei in /etc/httpd/ ein wenig ummodeln, damit die Authorisierung über .htaccess greift. Ist schon wieder ein paar Tage her, dass ich das gemacht habe, aber es ist alles Standard. Such dir eine Beschreibung der Einstellungsmöglichkeiten in der httpd.conf Datei und es wird klappen.

    Gruss, Lupus
     
    lupusoft, 05.01.2005
    #2
  3. Hilarious

    Hilarious MacUser Mitglied

    Mitglied seit:
    25.11.2004
    Beiträge:
    2.161
    Zustimmungen:
    5
    Du suchst in der Datei /etc/httpd/httpd.conf nach diesen Zeilen:
    Code:
    #
    # This should be changed to whatever you set DocumentRoot to.
    #
    <Directory "/Library/WebServer/Documents">
    
    #
    # This may also be "None", "All", or any combination of "Indexes",
    # "Includes", "FollowSymLinks", "ExecCGI", or "MultiViews".
    #
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    #
        Options Indexes FollowSymLinks MultiViews
    
    # 
    # This controls which options the .htaccess files in directories can
    # override. Can also be "All", or any combination of "Options", "FileInfo",
    # "AuthConfig", and "Limit"
    #
        AllowOverride None
    
    und änderst die letzte in

    Code:
        AllowOverride All
    
    Änderung speichern. Achtung, die oben genannte Freigabe erlaubt allen Benutzern des Servers die Konfiguration mit Hilfe von .htaccess-Dateien zu ändern.

    Server neu starten (per apachectl oder Systemsteuerung), fertig. Zur Not kannst Du die Direktiven aus der .htaccess-Datei auch in der httpd.conf selbst "fest" eintragen.
     
    Hilarious, 05.01.2005
    #3
  4. Doboune

    Doboune Thread Starter MacUser Mitglied

    Mitglied seit:
    19.11.2003
    Beiträge:
    77
    Zustimmungen:
    0
    dankeschön :)
     
    Doboune, 05.01.2005
    #4
  5. maceis

    maceis MacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Also eigentlich is es dann vornerum.
    (Sorry, das konnt ich mir jetzt nicht verkneifen ;))
     
    maceis, 11.01.2005
    #5
Die Seite wird geladen...
Ähnliche Themen - htaccess auf dem
  1. cusquito
    Antworten:
    4
    Aufrufe:
    391
    cusquito
    27.10.2015
  2. max@hismac
    Antworten:
    2
    Aufrufe:
    764
    max@hismac
    30.10.2014
  3. e-dude
    Antworten:
    5
    Aufrufe:
    858
    Dizzy.w3
    18.12.2010
  4. StephanSch
    Antworten:
    13
    Aufrufe:
    3.031
    StephanSch
    05.10.2009
  5. Bastian
    Antworten:
    2
    Aufrufe:
    1.863
    Bastian
    27.09.2007