Hilfe! immer diese Umlaute

  1. ctopfel2

    ctopfel2 Thread StarterMacUser Mitglied

    Mitglied seit:
    29.07.2004
    Beiträge:
    206
    Zustimmungen:
    6
    Ich habe ein Form, in welches ein User seinen Namen eingibt.. möglicherweise aber mit Umlauten.

    mein php Skript soll daraus einen Usernamen ohne umlaute generieren.

    Naja, denken vielleicht einige, mit preg_match kein Problem.. nun grundsätzlich beherrsche ich preg_match etc gut, aber ich habe immer Krieg mit diesen verschiedenen Encodings.

    ich möchte nun also z.B ein Ö durch ein oe ersetzen:

    $st = preg_replace("/Ö/","oe",$st);

    sollte ja funktionieren.. tut es aber nicht immer, weil wenn ich das php file in Textwrangler abspeichere, und später wieder öffne, dann das Ö plötzlich ein ^ geworden ist (oder ähnlich).

    Weiss jemand eine NARRENSICHERE Einstellungen im TextWrangler, oder besser eine andere methode, zb mit hexdarstellung oder was auch immer, wie ich das in den griff kriegen kann? Es sollte eine saubere Lösung sein, kein Hack.

    Normalerweise speichere ich alles direkt in die DB, und habe nichts mehr mit preg_replace zu tun, aber hier müssen die umlaute direkt ins php file..

    danke für alle tips
     
    ctopfel2, 31.03.2006
  2. b.legt210

    b.legt210MacUser Mitglied

    Mitglied seit:
    01.03.2006
    Beiträge:
    81
    Zustimmungen:
    4
    Hallo ctofel,

    ich kenne zwar Textwrangler nicht, dafür aber aus der PHP Doku:
    Ansonsten liegt dein Problem wohl an der Art der Zeichenkodierung mit dem Textwrangler die Dateien abspeichert. In BBEdit kannst du das z.B. einfach einstellen.

    Stephan
     
    b.legt210, 31.03.2006
  3. master_p

    master_pMacUser Mitglied

    Mitglied seit:
    31.01.2005
    Beiträge:
    1.063
    Zustimmungen:
    23
    Offtopic:
    Ist ein wenig offtopic, aber ein einfaches str_replace() ist deutlich schneller bei solchen, einfachen Ersetzungen. Erst bei "wirklichen" Regulären-Ausdrücken bringt ein preg_match() oder ereg_replace() etwas.
     
    master_p, 31.03.2006
  4. SilentBob

    SilentBobMacUser Mitglied

    Mitglied seit:
    01.02.2005
    Beiträge:
    360
    Zustimmungen:
    0
    Ich denke auch, dass das mit der Zeichenkodierung zusammen hängt, in der Textwrangler abspeichert. Musst Du mal im Programm suchen, ob man dort etwas einstellen kann (evtl. Stichwort: "encoding"). Am besten wäre iso-8859-1 oder utf-8.
     
    SilentBob, 03.04.2006
  5. Jakob

    JakobMacUser Mitglied

    Mitglied seit:
    05.01.2004
    Beiträge:
    1.067
    Zustimmungen:
    21
    Ersetze doch einfach das „^“ :D

    *duck*

    Zum Thema: Im Sichern-Dialog kannst Du unter „Options…“ andere Kodierungen auswählen. Ist ISO Latin 1 (=8859-1) nicht da, kannst Du die in den Preferences -> Text encoding aktivieren.
     
    Jakob, 03.04.2006
Die Seite wird geladen...
Ähnliche Themen - Hilfe immer diese
  1. dayto
    Antworten:
    11
    Aufrufe:
    2.241
  2. Lerak
    Antworten:
    7
    Aufrufe:
    1.821
  3. Kenjin
    Antworten:
    9
    Aufrufe:
    1.832
    oneOeight
    01.07.2013
  4. WolfgangK
    Antworten:
    2
    Aufrufe:
    678
    WolfgangK
    31.07.2012
  5. Drop-Apollo
    Antworten:
    3
    Aufrufe:
    1.106
    Drop-Apollo
    09.12.2009