Hilfe für JSP, Tomcat, Java 6 gesucht

krustelbaer

Mitglied
Thread Starter
Mitglied seit
28.06.2007
Beiträge
99
hallo liebe Gemeinde,

ich habe folgendes Problem.

Ich möchte ein Projekt auf meinem Mac Entwickeln, welches die folgenden Komponenten benutzen muss:

- Apache Tomcat v6.0
- JSP
- Eclipse mit Webtools
- Java 1.6
- svnclient

leider bekomme ich das nicht zum laufen, sodass es ständig fehler und probleme mit java 6 gibt. Hat jemand eine Ahnung ob die Sachen zusammen unter leopard funktionieren?!
Möchte nicht meine Windowsmaschine dafür nutzen...

Vielen Dank für eure Hilfe
 

wegus

Moderator
Mitglied seit
13.09.2004
Beiträge
17.375
Ja das läuft Alles! Allerdings ist Java 1.6 64Bit-only unter Leopard und allein darin kann ein Problem liegen. Warum muß es denn für EE schon Java 1.6 sein? 1.5 tut es doch auch, gerade für EE brauchst Du doch nicht mehr!

Was den Rest angeht, was läuft denn ( welche Eclispe Version vor allem) und ab wo konkret beginnen denn die Probleme?

Als SVN-Client habe ich den hier im Einsatz: http://subclipse.tigris.org/
 

krustelbaer

Mitglied
Thread Starter
Mitglied seit
28.06.2007
Beiträge
99
zum Thema 1.6: ja es muss möglich sein, da mein Chef meinte, dass es bereits 1.6er Methoden verwendet werden...

was heißt 64bit version?!
Ich habe ein MacBook mit 2,16ghz

Gibt es ein spezielles Leopard 64bit?
Das ist Java 6 funktioniert unter Leopard mit Eclipse schon, nur nicht in diesem Projekt. Wenn ich das Serverprojekt starten will, kommt die Fehlermeldung:

"Projekt Facet Java 6.0 not supported"

Kann das am Tomcat liegen?!

danke schonmal für die Hilfe
 

wegus

Moderator
Mitglied seit
13.09.2004
Beiträge
17.375
krustelbaer schrieb:
da mein Chef meinte, dass es bereits 1.6er Methoden verwendet werden...
für Java EE5!? Naja wird wohl so sein.

krustelbaer schrieb:
was heißt 64bit version?!
das es Java 6 für Leopard nur als 64-Bit VM gibt und nicht als 32Bit! Das gefällt mir auch nicht, ist aber so. Man kann somit Java6-Projekte in Eclipse erstellen. Eclipse selbst aber z.B. nur mit Java5 starten. Auch können die Webbrowser aus dem gleichen Grund zwar Java 1.5 verwenden, 1.6 jedoch nicht.

krustelbaer schrieb:
"Projekt Facet Java 6.0 not supported"

Kann das am Tomcat liegen?!
Nein Tomcat kann explizit Java6. Ein Projekt-Facet gehört zum WPT. Beim Anlegen des Web-Projektes gibst Du sowas wie einen Zielserver an, die JSP-Version, ob Du JSF verwendest und eben auch die Java-Version. Du hast beim Erstellen des Projektes eine 1.5 VM angegeben und daher funktioniert das ganze so nicht. Man kann Facets in den Projekt-Properties nachträglich ändern, ich habe das aber stabil nie geschafft. Es war einfacher ein neues Dynamic-Webprojekt zu erzeugen.
 

krustelbaer

Mitglied
Thread Starter
Mitglied seit
28.06.2007
Beiträge
99
Es war einfacher ein neues Dynamic-Webprojekt zu erzeugen.
das ist für mich leider keine Lösung, da das Projekt bereits besteht und mehrere Leute daran entwickeln.

ich werde jetzt mal auf meiner Win-Maschine das Projekt mit java 5 testen und schauen, ob die für mich relevanten Themen damit funktionieren...
 

wegus

Moderator
Mitglied seit
13.09.2004
Beiträge
17.375
krustelbaer schrieb:
das ist für mich leider keine Lösung, da das Projekt bereits besteht und mehrere Leute daran entwickeln.
Du hattest doch nach SVN gefragt!?
Also checkst Du doch ein SVN-Projekt aus in ein lokales Eclipse-Projekt und das kann man doch auch nachträglich in jedes beliebige Projekt ( und Facet) tun!?
 
Oben