hdapm "FAILED: APM not supported"

MacPippo

Mitglied
Thread Starter
Mitglied seit
30.10.2007
Beiträge
331
Hallo liebe Community,

ja ich weiß zu diesem Thema gibt es schon hundert tausend Threads wie diesen hier:
https://www.macuser.de/forum/f10/idle-klick-meiner-315459/index34.html

ABER...

ich habe mir eine neue Festplatte gekauft (Samsung HM500JI) das System 10.6 neuinstalliert, ein update auf 10.6.7 durchgeführt und meine alten Benutzer per Migrations-Assistent übertragen. ... Alles perfekt, bis auf das klicken.

Also habe ich hdapm bemüht mit der folgenden Fehlermeldung:
Code:
disk0: SAMSUNG HM500JI                         
Setting APM level to 0xfe: FAILED: APM not supported
Ich habe mir eine Ubuntu LiveCD gebrannt und im Terminal also root:
Code:
hdparm -B 254 /dev/sda
ausgeführt, mit korrekter Rückmeldung. Danach habe ich wieder Os X gebootet und hdapm ausgeführt. Diesmal mir Erfolg.

Nach einem Neustart am nächsten Tag ... ratet mal ... genau! Das Klicken war wieder da :/

Also hdapm ausgeführt und ...
FAILED: APM not supported

Ich habe also wieder Ubuntu gebootet, "hdparm" ausgeführt und einen reboot zu OsX ausgeführt.

Mein Problem jetzt: hdapm meldet mir immer noch:
FAILED: APM not supported

Habt ihr evtl. noch eine Idee?

Vielen Dank
MacPippo
 

mrwho

Aktives Mitglied
Mitglied seit
20.07.2003
Beiträge
2.558
Es kann sein daß zwar eine korrekte Rückmeldung vorleigt ABER die Platte es trotzdem nicht ausführt.

Laut Google scheint eine neue Version der SAMSUNG HM500JI KEINE Änderung des APM mehr zuzulassen. :/
 

MacPippo

Mitglied
Thread Starter
Mitglied seit
30.10.2007
Beiträge
331
Danke für die schnelle Antwort, auch wenn Sie wenig positives hat ;)

Aber was mich wundert ist, dass es beim ersten Versuch geklappt hat ...
 

MacPippo

Mitglied
Thread Starter
Mitglied seit
30.10.2007
Beiträge
331
** Update **

Nach langer Zeit, in der ich mich mit dem Ganzen irgendwie doch nicht anfreunden konnte, habe ich es noch mal mit der Ubuntu-Live-CD 11.04 versucht.

Ubuntu booten und Terminal öffnen.

Code:
sudo hdparm -B 255 /dev/disc/by-uuid/[Name der Platte]
danach ein reboot und ... unter Os X 10.6.8 läuft wieder alles ruhig und ohne irrsinnige Load_Cycle_Count Erhöhung im Sekundentakt.

------ Fazit -------
Irgendwie nicht zufriedenstellend, aber momentan funktioniert es.

Klappt das mit der Ubuntu-Live-CD nicht beim ersten Mal, "hdapm" unter Os X erneut installieren (vorher aber komplett deinstallieren). Danach im Ubuntu-Live-System den Smartstatus mit hilfe von "hdparm" erneut einstellen und dann wieder unter Os X versuchen.
 

MacPippo

Mitglied
Thread Starter
Mitglied seit
30.10.2007
Beiträge
331
**Update die 2te**

So langsam vermute ich böse Absichten meines Rechners mir gegenüber,

nach etlichen Neustarts habe ich die Console bemüht und folgendes gefunden:
Code:
02.11.11 08:21:12	hdapm[54]	disk0: SAMSUNG HM500JI                         
02.11.11 08:21:12	hdapm[54]	Setting APM level to 0xfe: FAILED: APM not supported
02.11.11 08:21:12	com.apple.launchd[1]	(hdapm[54]) Exited with exit code: 1
02.11.11 09:29:16	hdapm[58]	disk0: SAMSUNG HM500JI                         
02.11.11 09:29:16	hdapm[58]	Setting APM level to 0xfe: FAILED: APM not supported
02.11.11 09:29:16	com.apple.launchd[1]	(hdapm[58]) Exited with exit code: 1
Nachdem ich die Ubuntu-CD erneut bemüht habe, konnte ich dann in der Console folgendes finden:
Code:
02.11.11 22:17:15	hdapm[53]	disk0: SAMSUNG HM500JI                         
02.11.11 22:17:15	hdapm[53]	Setting APM level to 0xfe: 
02.11.11 22:17:15	hdapm[53]	Success
Ich verstehe das nicht, warum wird bei jedem Neustart das ganze Prozedere mit dem booten des Ubuntu-Live-Systems nötig? Hat jemand eine Idee?

Grüße
MacPippo
 

mrwho

Aktives Mitglied
Mitglied seit
20.07.2003
Beiträge
2.558
*Eintrag durch Lagg erzeugt*
 

MacPippo

Mitglied
Thread Starter
Mitglied seit
30.10.2007
Beiträge
331
Danke, aber die habe ich schon installiert.
 

LosDosos

Aktives Mitglied
Mitglied seit
09.03.2008
Beiträge
18.538
Gibt es schon eine Lösung?
Ich habe die SAMSUNG HN-M101MBB im Optibay und nichts hat geholfen, das Klicken ist unerträglich.
 

MacPippo

Mitglied
Thread Starter
Mitglied seit
30.10.2007
Beiträge
331
Leider keine Neuigkeiten von mir. Bin aber momentan nur sporadisch auf der Suche nach neuen Antworten.

Scheint eher so zu sein, dass die Ububtu-boot-Geschichte bei den meisten Funktioniert... und zwar auch langfristig.

Melde mich bei Neuigkeiten.

Achja ansonsten gab es mal den Ansatz alle 5sec per Script eiene Datei zu erstellen und gleich wieder zu löschen. Nannte sich irgendwas mit declunc oder so ähnlich. Einfach mal googlen. Ich fand die Lösung aber unschön und verzichte daher lieber drauf.

Grüße
MacPippo
 
  • Gefällt mir
Reaktionen: LosDosos

LosDosos

Aktives Mitglied
Mitglied seit
09.03.2008
Beiträge
18.538
Ok, da schaue ich mal nach, danke.
Ich finde die Platte unerträglich (die 640 GB HM641ji war dagegen ein Traum) und entsorge sie sonst.
Scheint auf jeden Fall ja ein generelles Samsung-Problem zu sein.

Das Problem bei mir ist halt auch, dass die Platte im Optibay als Datenplatte sitzt, da ich eine SSD nutze.
Das führt dazu, dass das Book Ubuntu nicht mehr von einem externen Laufwerk booten kann, daher hatte ich versucht, Ubuntu zu virtualisieren.
Das hat leider keinen Erfolg gebracht.

Ist das Energiemanagement unter Lion vielleicht anders?
 
Zuletzt bearbeitet:
Oben