Gemeinsamer "Programme"-Ordner wird nicht angezeigt

maceis

Aktives Mitglied
Thread Starter
Registriert
24.09.2003
Beiträge
16.880
Hallo zusammen,

ich möchte gerne einen gemeinsamen Programme Ordner im Netzwerk bereitstellen. Bei den Clients erscheint aber immer nur ein Alias im "Netzwerk"-Globus.

Eigentlich bin ich genau so vorgegangen, wie im Filserverhandbuch bzw. in der Hilfe beschrieben.

Habe einen Ordner "Applications" angelegt (in "Shared Items"),
das Objekt freigegeben,
AFB und Gastzugriff sind aktiv,
Zugriff Lesen & Schreiben für die entsprechende Gruppe,
Netzwerkaktivierung für diesen Ordner aktiviert,
Protokoll AFB,
Verwenden für: Gemeinsamer "Programme"-Ordner.

Bei den Clients erscheint dennoch nur ein Alias mit einem "Weißes Blatt" Icon - manchmal wird es nach einer Weile zu einem Alias-Ordner Icon, in dem ih sogar Daten speichern kann, die dann aber nicht auf dem Server sondern in - - - "/var/automount/Network/Applications"

Woran könnte es jetzt noch liegen?
 

slowfranklin

Mitglied
Registriert
28.11.2005
Beiträge
233
Ausgabe von
Code:
lookupd -q mount
am Client posten.

Kannst du das Verzeichnis von Hand mit Gastrechten mounten?

-Ralph
 

maceis

Aktives Mitglied
Thread Starter
Registriert
24.09.2003
Beiträge
16.880
Ich kann im Augenblick nur über ssh zugreifen.
Ausgabe von lookupd -q mount:
Code:
dir: /Network/Servers/
name: bigmac.myoffice.dom:/Users
opts: net url==afp://;AUTH=NO%20USER%20AUTHENT@bigmac.myoffice.dom/Users
vfstype: url

dir: /Network/Applications
name: bigmac.myoffice.dom:/Shared Items/Applications
opts: url==afp://;AUTH=NO%20USER%20AUTHENT@bigmac.myoffice.dom/Applications
vfstype: url

dir: /Serverdaten
name: bigmac.myoffice.dom:/Shared Items/Daten
opts: url==afp://;AUTH=NO%20USER%20AUTHENT@bigmac.myoffice.dom/Daten
vfstype: url

dir: /Network/Library
name: bigmac.myoffice.dom:/Shared Items/Lib
opts: url==afp://;AUTH=NO%20USER%20AUTHENT@bigmac.myoffice.dom/Lib
vfstype: url

Das mit dem Library Ordner funktioniert übrigens auch nicht. Wie bei Applications ein toter Alias/Link; hatte ich letzte nacht noch ausprobiert.

Ob ich als Gast mounten kann, muss ich testen, wenn ich wieder im vor Ort bin.

Vielleicht ist folgendes noch von Bedeutung (am Client)
Code:
% ls -l /Network/Applications/                    516 

ls: /Network/Applications/: [b]Authentication error[/b]
lrwxr-xr-t   1 root  wheel  512  2 Feb 11:14 /Network/Applications/

Danke schon mal für dein Engagement.

Gruß
maceis
 

slowfranklin

Mitglied
Registriert
28.11.2005
Beiträge
233
Klappt denn der Zugriff Apfel+K -> afp://;AUTH=NO%20USER%20AUTHENT@bigmac.myoffice.dom/Applications ?

-Ralph
 

maceis

Aktives Mitglied
Thread Starter
Registriert
24.09.2003
Beiträge
16.880
Nach einigem hin und her, mehreren Vor-/Zurückänderungen und einigen Neustarts funktioniert es jetzt zumindest manchmal.
Dass sowohl das Library als auch das Programme Verzeichnis gleichzeitig funktionsfähig sind, ist mir noch nicht gelungen, aber das möchte ich jetzt mal hintanstellen.

Beim Programme-Verzeichnis habe ich jetzt noch das Problem, dass es nicht mit den gewünschten (und eingestellten) Bereichtingungen eingebunden werden.

Auf dem Server ist der Programme Ordner dem Benutzer 'admin' (Eigentümer) und der Gruppe 'benutzer' zugewiesen. Beide haben "Lesen & Schreiben", andere "Nur lesen". So ist das auch im WGM abgebildet.

Auf dem Client ist der Benutzer über zwei Verlinkungen unter "/private/var/automount/Network/Applications" eingebunden.
Eigentümer ist der angemeldete "Benutzer", Gruppe die Gruppe 'staff' (Primärgruppe des Benutzers). Der Benutzer ist aber Mitglied der gruppe 'benutzer'
Berechtigungen dr-xr-xr-x.

Das Ziel:
... ist jetzt, dass die Clients mit den auf dem Server eingestellten Berechtigungen mit dem Volume arbeiten können.
 

slowfranklin

Mitglied
Registriert
28.11.2005
Beiträge
233
maceis schrieb:
Das Ziel:
... ist jetzt, dass die Clients mit den auf dem Server eingestellten Berechtigungen mit dem Volume arbeiten können.
Vergiss es, das kann mit echten automounts nicht gehen, da die immer nur mit Gastrechten erfolgen. Alternativen: MCX und LoginItems.

-Ralph
 

maceis

Aktives Mitglied
Thread Starter
Registriert
24.09.2003
Beiträge
16.880
Ah, verstehe. Die Einstellungsmöglichkeiten im WGM sind dann allerdings ein bisschen irreführen.

Danke noch einmal für Deine Tipps.
 
Oben Unten