falsche Umlautdarstellung - Ü-Punkte versetzt

Diskutiere das Thema falsche Umlautdarstellung - Ü-Punkte versetzt im Forum Mac OS X & macOS.

Schlagworte:
  1. paradiso

    paradiso Thread Starter Registriert

    Beiträge:
    2
    Zustimmungen:
    0
    Mitglied seit:
    05.07.2016
    Bei mir taucht folgendes Problem auf, das ich trotz intensiver Recherche nicht lösen kann:
    Wenn ich Texte aus PDF-Dokumenten kopiere und sie in ein Word-Dokument einfüge, werden beim ü die Punkte versetzt dargestellt und ein Schreibfehler angezeigt. Auch wenn ich den Text vorher unformatiert in TextEdit ö.ö einfüge, erscheint der Fehler. In unterschiedlichen Schriftarten (Fonts) sieht die Schreibweise richtig aus, im Word-Korrekturmodus wird aber ein Rechtschreibfehler angezeigt. (siehe das Wort Unterstützung in der Grafik)

    Textfehler.png
    Weiterhin zur Eingrenzung: Wenn ich den Textcursor hinter die ü-Punkte setze muss ich mit der Cursor- oder Backspace-Taste zwei Zeichen überspringen bzw. löschen, wenn ich dabei die Shift-Taste drücke, markiere ich mit der Cursortaste u und Pünktchen als ein Zeichen.
    Wenn ich beides kopiere und in das Suchen-Fenster von Word einfüge, wird dort einkorrektes ü angezeigt, die falschen werden nicht gefunden - mit anderen Worten, die Fehler per Suchen&Ersetzen zu eliminieren, funktioniert auch nicht. Letztlich: Das Zeichen über alt-u (=Pünktchen) und u in die Suchmaske einzugeben, ist auch ohne Erfolg.
    Das Ganze passiert nur beim ü, die anderen Umlaute werden richtig kopiert.
    Hat iregndjemand da einen Tipp oder ein Workaround?
     
  2. mreball

    mreball Mitglied

    Beiträge:
    1.610
    Medien:
    1
    Zustimmungen:
    149
    Mitglied seit:
    20.03.2007
    Gibt es in Word die Funktion "Suchen und ersetzten"? Damit würde ich es als Erstes versuchen. Imho ist das versetzte "ü" auch eine andere Schriftart, musst Du mal schauen.
     
  3. helge42

    helge42 Mitglied

    Beiträge:
    240
    Zustimmungen:
    20
    Mitglied seit:
    12.10.2005
    Das 'ü' im PDF ist gar kein 'ü', sondern wahrscheinlich zusammengesetzt aus einem 'u' und zwei Punkten (Trema) '¨', also 'ü'. Das geht im Unicode-Zeichensatz prima, sieht normalerweise auch genauso aus, ist aber falsch ...
    Im Deutschen wird das z.B. benötigt für Citroën.
    Abhilfe schafft nur konsequentes Ersetzen.
     
  4. Grettir

    Grettir Mitglied

    Beiträge:
    2.962
    Zustimmungen:
    671
    Mitglied seit:
    02.04.2011
    Es sind anscheinend zwei Zeichen, die mit einer Formatierungsoption übereinander geschoben sind. Probiere mal das:

    Markiere den ganzen Text, wähle im Menü »Format/Schriftart« und im Fenster, das nun aufgeht oben »Erweitert«. Ich nehme an, dass nun der Wert bei »Abstand« unbestimmt ist. Stelle den per Auswahlbox auf »Standard« und schließe das Fenster. Nun müsste das ü ebenso wie beim reinen Textimport aus zwei Zeichen bestehen. Nun versuche, diese beiden Zeichen in die Ersetzen-Dialogbox einzugeben und durch das richtige ü zu ersetzen.

    Gib mal Bescheid, ob das so klappt.
     
  5. bjoern07

    bjoern07 Mitglied

    Beiträge:
    5.284
    Zustimmungen:
    544
    Mitglied seit:
    05.02.2007
    Rufe mal das Programm "Schriftsammlung" auf und sieh Dir die betreffende Schrift an. Vielleicht hat sie einfach eine Macke.
    Wobei dann eigentlich trotzdem nur ein Schritt zum Löschen nötig sein sollte.
    Naja, probieren kann man das ja mal.
     
  6. MacEnroe

    MacEnroe Mitglied

    Beiträge:
    18.152
    Zustimmungen:
    3.061
    Mitglied seit:
    10.02.2004
    Das tritt bei mir seit einiger Zeit im Internet auf. Beim Einfügen von Text in Wordpress. Hatte ich
    vorher auch noch nie. Und es betrifft immer nur das „ü“ ... schon komisch.
     
  7. fa66

    fa66 Mitglied

    Beiträge:
    12.293
    Zustimmungen:
    3.646
    Mitglied seit:
    16.04.2009
    Nur das »ü«? Oder kommen nur zufälligerweise keine »ä« oder »ö« in dem Text vor?
    (»ü« kommen im deutschen m.W. als Umlautzeichen am häufigsten vor – schon weil viel historische Umlaute von »a« mit »e« geschrieben werden.)

    Ich denke, dass die Textmaschine der Webseite oder der HTML-Erzeuger bei Zeichen, die enweder vorgefertigt oder komponiert eingefügt werden können, eingetippte »ü« (und vermutlich auch andere wie é) in UTF-8 anstelle der fertigen »ü« mit durch Composite-Zeichen verbundenen (»u¨«) ersetzt, mit denen dann wieder zahlreiche Anzeigeprogramme nicht zurechtkommen.

    Es hilft wohl wirklich nur das Tauschen im Quelltext.
     
  8. TEXnician

    TEXnician unregistriert

    Beiträge:
    1.585
    Zustimmungen:
    678
    Mitglied seit:
    14.02.2013
    Hier muss man unterscheiden. Unicode kennt sowohl „ü“ als auch „ë“ als einzelne Zeichen. Ist es deshalb falsch in gesetzten Texten aus u und einem Trema ein ü zu bauen? Wenn ein ü bereits im verwendeten Font vorhanden ist, sollte man auch dieses verwenden, verfügt der Font nicht über diese Glyphe, ist es korrekt bzw. der einzig praktikable Weg das „ü“ entsprechend aus „u“ und Trema zusammenzusetzen.

    Beim Kopieren aus dem PDF sollte allerdings das korrekte Unicode Zeichen kopiert werden. Passiert das nicht, kann der Fehler entweder im PDF liegen (dort ist das falsche Zeichen hinterlegt, bzw. bei zusammengesetzten Glyphen die beiden Einzelglyphen hintereinander) oder aber die Zwischenablage macht beim Kopieren bzw. Einsetzen einen entsprechenden Fehler.
     
  9. paradiso

    paradiso Thread Starter Registriert

    Beiträge:
    2
    Zustimmungen:
    0
    Mitglied seit:
    05.07.2016
    Zuerst einmal vielen Dank an alle. Ich denke, helge42 und Texnician haben das Problem erkannt. Es ist, wie ich ja beschrieben habe, tatsächlich so, dass das ü aus dem trema und dem u zusammengesetzt ist. Leider kann ich das in Word nicht in Suchen&Ersetzen eingeben. Es scheint in der Tat ein Problem von Adobe Acrobat (bei mir: 9 Pro, V 9.5.5) zu sein, weniger von OSX. Der Fehler wird mitgenommen z.B. in TextEdit oder Libre-Office. Dort eingefügt, abgespeichert und wieder per Cpy&Paste in Word - der Fehler bleibt. Vielleicht sollte ich mal im Adobe-Forum nachschauen.
    Übrigens: In Acrobat 9 Pro kann ich die PDF-Datei als Word-Datei exportieren, dann tritt der Fehler nicht auf, leider wird dabei aber oft die Datei ziemlich zerschossen, je nachdem, wie die PDF-Datei erzeugt wurde.
     
  10. TEXnician

    TEXnician unregistriert

    Beiträge:
    1.585
    Zustimmungen:
    678
    Mitglied seit:
    14.02.2013
    Macht Vorschau oder ein anderer PDF-Reader denn den gleichen Fehler? Alternativ könnte man auch noch einmal schauen, ob andere Macs bzw. andere OS X Versionen denselben Fehler machen. So könnte man eventuell einschätzen, wo der Fehler liegt.

    Wenn du schreibst, dass der Fehler in TextEdit und LibreOffice ebenso auftritt, dann liegt der Fehler sehr wahrscheinlich nicht bei Word, sondern entweder im Dokument, beim Reader oder der Zwischenablage von OS X. Wenn andere Umlaute allerdings problemlos gehen, vermute ich eher ein „Fehler“ im Dokument bzw. bei der Erstellung des Dokuments.

    Suchen und Ersetzen sollte allerdings gehen. Vielleicht nicht direkt in Word, aber wenn du den Text ohne Formatierung usw. als reinen Text in TextEdit einsetzt, solltest du normalerweise die zu ersetzenden Zeichen in TextEdit markieren und durch Kopieren und Einfügen ins Suchfeld kopieren können. Dann noch durch ein ü ersetzen und das Ergebnis dann nach Word kopieren. Das sollte normalerweise klappen. Vielleicht nicht gerade elegant, aber zumindest eine Lösung. Sollte TextEdit nicht gehen, eventuell mal einen reinen Text-Editor wie Textmate probieren. Fügst du dort den formatierten Text ein, sollte davon nur der reine Text übrig bleiben. Dann per Suchen und Ersetzen die entsprechenden Zeichen wie oben beschrieben ersetzen und das Ergebnis weiterverwenden.
     
  11. fa66

    fa66 Mitglied

    Beiträge:
    12.293
    Zustimmungen:
    3.646
    Mitglied seit:
    16.04.2009
    Tatsächlich nicht?
    Ich würde versuchen, die Zeichen im Suchdialog aus der MacOSX-Zeichenübersicht einzufügen:
    Zeichenpalette.jpg

    … also bspw. zunächst das normale e dann dahinter die COMBINING DIARHESIS ¨ (030816)
     
  12. alptz

    alptz Mitglied

    Beiträge:
    112
    Zustimmungen:
    3
    Mitglied seit:
    08.09.2007
    Die Diskussion ist schon lange her, aber ich teile trotzdem den gefundenen Workaround mit.

    Ich habe dasselbe schon mehrfach versucht in den Griff zu bekommen und war jetzt erneut auf der Suche nach einer Lösung. Dass Word in der Suchmaske das zusammengesetzte ü zu einem Zeichen vereint, aber die Kombo im Text belässt, verhindert eben gerade ein automatisiertes Ersetzen.

    Nun habe ich Text aus einem PDF in TextEdit abgelegt, von dort gleich wieder kopiert und in Word abgelegt – und siehe da, der Umlaut kommt richtig!!!

    mac OS 10.13.6; Word 16.26; Acrobat Pro 2019.012.20034
     
Die Seite wird geladen...
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite weitersurfst, akzeptierst du unseren Einsatz von Cookies. Akzeptieren Weitere Informationen...