macOS Catalina 'Digitale Bilder' kann nicht auf NAS importieren nach Update auf Catalina (com.apple.ImageCaptureCore-Fehler -9956.) (-9956).

Wende

Mitglied
Thread Starter
Mitglied seit
16.01.2004
Beiträge
63
Hi,

Habe meinen iMac auf Catalina upgedated (aus Kompatibilitätsgründen bin ich da immer etwas später dran). Plötzlich erhalte ich immer einen Fehler, wenn ich Bilder von der Spiegelreflex Kamera auf ein Synology NAS im Netzwerk importieren will. Lediglich der Import in ein lokales Verzeichnis funktioniert.

Unter High Sierre gab es hier keinerlei Probleme. Alle Rechte sind korrekt gesetzt. Bilder können per Photoshop auch direkt auf dem NAS bearbeitet werden.

Fehler: Der Vorgang konnte nicht abgeschlossen werden. (com.apple.ImageCaptureCore-Fehler -9956.) (-9956).

Bislang habe ich im Netz keine Lösung gefunden. Ein Support Chat wurde unterbrochen und liess sich nicht erneut starten, hatte auch eh den Eindruck nur mit einem Roboter verbunden zu sein.
Ist das Problem bekannt, gibt es Abhilfe?

Merci & Grüsse, Jo
 

Anhänge

MDmac64

Aktives Mitglied
Mitglied seit
26.02.2006
Beiträge
1.070
Hallo,
der Fehler ist mir nicht bekannt, aber vielleicht spielt das Netzwerkprotokoll zum NAS eine Rolle. (AFP, SMB, NFS)
Ich hatte auch diverse Probleme bei Verbindung über AFP oder SMB. Seitdem ich mit NFS verbinde, läuft es besser.
 

Wende

Mitglied
Thread Starter
Mitglied seit
16.01.2004
Beiträge
63
Danke Dir. Allerdings habe ich per Finder oder per Terminal voll Zugriff auf das NAS, kann also Dateien lesen und schreiben. Lediglich Digitale Bilder hat Probleme. Ich kann mit Digitale Bilder sogar einen Ordner auf dem NAS anlegen, nur der Import von der Kamera dorthin schlägt fehl...
 

ekki161

Aktives Mitglied
Mitglied seit
29.06.2007
Beiträge
21.985
USB-Port oder Kabel mal getauscht?

Klappt der Import lokal?

Tritt das Problem nur mit dieser Datei aus dem SC auf oder immer?
 

Wende

Mitglied
Thread Starter
Mitglied seit
16.01.2004
Beiträge
63
Ja, keine Probleme die Dateien auf den Schreibtisch zu importieren
 

MDmac64

Aktives Mitglied
Mitglied seit
26.02.2006
Beiträge
1.070
Danke Dir. Allerdings habe ich per Finder oder per Terminal voll Zugriff auf das NAS, kann also Dateien lesen und schreiben. Lediglich Digitale Bilder hat Probleme. Ich kann mit Digitale Bilder sogar einen Ordner auf dem NAS anlegen, nur der Import von der Kamera dorthin schlägt fehl...
Ich habe trotzdem das Netzwerkprotokoll unter Verdacht, auch wenn du sonst keine Probleme mit dem NAS hast!!
Probier bitte mal den Zugriff mit NFS, um es auszuschließen!

Die Verbindung mit NFS zum NAS funktioniert nicht wie gewohnt über den Finder (dort wird nur mit AFP oder SMB verbunden).
So gehts:
- im Finder-Menu auf "Gehe zu" –> "Mit Server Verbinden"
- dort eingeben nfs://die.IP.deines.NAS/Freigabe-Ordner
z.B.
Bildschirmfoto 2020-11-27 um 27. November 2020 | 11.51.08.png

- mit dem Assistenten, klick–> http://find.synology.com findest du deine NAS-IP heraus.

Übrigens, eine dauerhaft automatische Verbindung zu einem Netzwerkvolumen funktioniert so:
das angemeldete Netzwerkvolumen in Systemeinstellungen > Benutzer&Gruppen > Anmeldeobjekte hinzufügen.
 
Zuletzt bearbeitet:

Wende

Mitglied
Thread Starter
Mitglied seit
16.01.2004
Beiträge
63
Danke Dir für die Hinweise. Leider passt irgendwas mit den Rechten nicht, obwohl ich im NAS bei den Dateidiensten NFS aktiviert habe und im entsprechenden Verzeichnis die NFS Berechtigungen auf '*' gesetzt habe. Hab ich da was übersehen?

Fehler: Du hast nicht die erforderlichen Zugriffsrechte, um auf diesen Server zuzugreifen.
 

MDmac64

Aktives Mitglied
Mitglied seit
26.02.2006
Beiträge
1.070
Wichtig ist der Pfad incl. Freigabe-Ordner nicht nur allein die IP des NAS, also wie schon beschrieben:
nfs://die.IP.deines.NAS/Freigabe-Ordner
 

Wende

Mitglied
Thread Starter
Mitglied seit
16.01.2004
Beiträge
63
schon klar, das habe ich auch so gemacht. Ich muss mal etwas recherchieren wie ich die Credentials da mit übergeben kann...
 

Wende

Mitglied
Thread Starter
Mitglied seit
16.01.2004
Beiträge
63
Also, ich habe zwischenzeitlich meine Synology erfolgreich per NFS eingebunden, habe aber diesse Vorgehensweise benutzt: https://www.meintechblog.de/2013/05/synology-nas-nfs-mount-unter-os-x-einbinden/

Dennoch hatte ich besagte Zugriffsrechte Probleme, konnte diese aber wie folgt lösen: Bei den NFS-Berechtigungen der Geteilten Ordner habe ich unter Squash Root zu admin zuordnen ausgewählt, damit wird der Root vom Mac zum Synology Admin. Ich konnte nun alle Verzeichnisse per NFS mounten und per Finder problemlos auf alles zugreifen. Diese Info für alle die auch mit NFS spielen...

Aber:

- das ursprüngliche Problem mit Digitale Bilder besteht nach wie vor
- Adobe Bridge ist nicht in der Lage die NFS-Mounts zu öffnen und die Gemeinsamen Folder anzuzeigen (im Gegensatz zu smb)

Ich danke Dir trotzdem für die Hilfe, aber das Problem liegt woanders.

Insgesamt bereue ich im Übrigen den Umstieg auf Catalina sehr, das System ist instabil, stürzt ab oder friert ein. Insbesondere SuperDuper und TimeMachine machen Probleme, wenn sie im Ruhezustand gestartet werden. Wenn das weiter so geht mache ich einen 'harten' Rollback zu High Sierra. Ich muss mich wirklich fragen, was Apple da treibt, auf meinem 2015er iMac ist das OS jedenfalls nicht zu gebrauchen. Aber das gehört natürlich nicht hier her...
 

MDmac64

Aktives Mitglied
Mitglied seit
26.02.2006
Beiträge
1.070
Okay, NFS bringt also nichts. :kopfkratz:
Einen Versuch noch, falls du es noch nicht eingestellt hast:
probier mal in Systemeinstellungen -> Sicherheit -> Datenschutz –> bei Festplattenvollzugriff "Digitale Bilder" mit + hinzufügen.
 
Oben