Classic Umgebung +Programm von Mac OS X starten?

Dieses Thema im Forum "Umsteiger und Einsteiger" wurde erstellt von cjs, 24.04.2008.

  1. cjs

    cjs Thread Starter MacUser Mitglied

    Beiträge:
    13
    Zustimmungen:
    0
    Mitglied seit:
    24.04.2008
    Hallo!

    Ich habe auf meinem Mac die neueste Mac OS X 10.4.x Version installiert, und darunter läuft auch eine Classic Umgebung. Ich kann auch die Programme, welche die Classic-Umgebung brauchen, problemlos starten.

    Jetzt stellt sich die Frage, ob ich aus einem Programm, welches in der Classic-Umgebung ausgeführt werden muss, ein anderes Programm, das unter Mac OS X läuft, aufrufen kann.

    Grund: Ich habe eine alte Anwendung, die nicht mehr auf Mac OS X portiert werden kann. Diese Anwendung müsste aber eine Java-Applikation starten, die mindestens Java 5 braucht, was ja nicht für die 9.x-Versionen zur Verfügung steht. Später mal soll die Applikation unter Java 6 laufen, und da wird es sicher keine Lösung für Mac OS 9 geben.

    Gruß,
    Christian.
     
  2. Tensai

    Tensai MacUser Mitglied

    Beiträge:
    10.941
    Zustimmungen:
    582
    Mitglied seit:
    02.11.2004
    Nein, das geht imho nicht.

    Wieso kann denn die alte Anwendung nicht mehr auf OSX portiert werden? Oder handelt es sich um eine Fremdsoftware? Eventuell gibt es Alternativen direkt für OSX. Und was passiert in Zukunft, wenn irgendwann mal kein PPC-Mac/Classic mehr zur Verfügung steht? Früher oder später muss also auch eine Abhilfe her, die ohne Classic auskommt.
     
  3. cjs

    cjs Thread Starter MacUser Mitglied

    Beiträge:
    13
    Zustimmungen:
    0
    Mitglied seit:
    24.04.2008
    Hallo!

    Die alte Software wurde mit Omnis Classic erstellt, welches nicht mehr weiterentwickelt wird. Ich müsste jetzt die ganze Applikation auf Omnis Studio umstellen, und dann bin ich wieder von der Gunst von der Firma Omnis abhängig. Und Geld kosten tut das auch ordentlich.

    Ein altes Problem habe ich nun durch ein externen Java-Programm gelöst. Unter Windows läuft die Lösung brav, am Mac muss ich es erst noch zum Laufen kriegen. Früher oder Später muss da eh komplett was Neues gemacht werden (hoffentlich mit Java). Bis dahin würde ich gerne meine Zwischenlösung zum Laufen bekommen.

    Frage: Dass eine Classic-Anwendung eine andere Anwendung startet, in meinem Fall eine kleine Jar-Datei, das geht aber schon, oder? Wenn ja, was ist denn die letzte Java-Version für Mac OS 9?

    Gruß,
    Christian.
     
  4. Tensai

    Tensai MacUser Mitglied

    Beiträge:
    10.941
    Zustimmungen:
    582
    Mitglied seit:
    02.11.2004
    Die letzte Java-Version für das klassische Mac OS ist MRJ 2.2.5 und gibts hier zum Download: http://docs.info.apple.com/article.html?artnum=75097 Ich befürchte fast, dass man das aber nicht in der Classic-Umgebung installieren kann.
     
Die Seite wird geladen...

Diese Seite empfehlen