Buttons funktionieren nich !

  1. Hag

    Hag Thread StarterMacUser Mitglied

    Mitglied seit:
    06.01.2004
    Beiträge:
    160
    Zustimmungen:
    0
    Hallo,
    hab da eine sehr dringende Frage, sitze nun schon seit Tagen an nem Schulprojekt welches ich Dienstag zur benotung abgeben muß. Doch es gibt von insgesamt 9 Buttons 3 die einfach nicht funtionieren wollen. Ich verzweifel langsam weil ich echt keinen Plan habe warum die drei nicht funktionieren.
    Wenn ich den jeweiligen Button betätige leert sich der mainframe bis auf den hintergrund den ich per CSS in den body eingefügt habe.
    Die Buttons sollen die verlinkte seite im mainframe meines Framesets jedoch öffnen.

    Ich poste ienfach mal stellvertretend für einen von den drei buttons den code:

    <a href="daniel.html" target="mainframe" onMouseOver="MM_swapImage('daniel_ro','','../layout/bt_daniel_ro.gif',1)" onMouseOut="MM_swapImgRestore()"><img src="../layout/bt_daniel.gif" alt="Daniel P." name="daniel_ro" width="198" height="25" border="0"></a>

    desweiteren hier mein Frameset :

    <frameset cols="*,520,230,*" frameborder="no" border="0" framespacing="0">

    <frame src="leftframe.html" name="leftframe" frameborder="no" scrolling="no" noresize="noresize" marginwidth="*" id="leftframe" title="leftframe" />

    <frame src="main.html" name="mainframe" frameborder="no" scrolling="no" noresize="noresize" marginwidth="520" id="mainframe" title="mainframe" />

    <frame src="navi.html" name="navi" frameborder="no" scrolling="no" noresize="noresize" marginwidth="215" id="navi" title="rightframe" />

    <frame src="rightframe.html" name="rightframe" frameborder="no" scrolling="no" noresize="noresize" marginwidth="*" id="rightframe" title="rightframe" />

    </frameset>
    <noframes>

    MFG Hag
     
  2. master_p

    master_pMacUser Mitglied

    Mitglied seit:
    31.01.2005
    Beiträge:
    1.063
    Zustimmungen:
    23
    Wenn ich das schon sehe, dann wird mir ganz übel mit dem ganzen JavaScript etc. Poste den Code bitte nochmal vollständig! in Code-Tags und am besten stellst Du das mal irgendwo online, denn ich glaube nicht, dass Dir so jemand helfen kann. Ich schätze nämlich mal, dass das eher an einer falschen Verlinkung liegt.

    Und schön wäre es, wenn Du mal postest, welcher Button funktioniert und welcher nicht.
     
    master_p, 28.05.2006
  3. Darii

    DariiMacUser Mitglied

    Mitglied seit:
    24.02.2004
    Beiträge:
    2.065
    Zustimmungen:
    110
    Link wäre hilfreich....
     
    Darii, 28.05.2006
  4. ThaHammer

    ThaHammerMacUser Mitglied

    Mitglied seit:
    01.06.2004
    Beiträge:
    3.277
    Zustimmungen:
    13
    Dreamweaver lässt grüßen. Verzichte doch auf die Frames!
    Ansonsten überprüfe mal die Bildnamen (name="") bei den Bildern die nicht gehen. Werden die auch beim Body onload mitaufgerufen?
     
    ThaHammer, 28.05.2006
  5. falkgottschalk

    falkgottschalkMacUser Mitglied

    Mitglied seit:
    22.08.2005
    Beiträge:
    24.005
    Zustimmungen:
    1.599
    Hmmm: so dringend kann es ja nicht sein, sonst hätte er geantwortet.
     
    falkgottschalk, 29.05.2006
  6. Hag

    Hag Thread StarterMacUser Mitglied

    Mitglied seit:
    06.01.2004
    Beiträge:
    160
    Zustimmungen:
    0
    Sorry Leute das ich nicht mehr geantwortet habe, hab gestern noch Panik bekommen und bin noch zur Uni gefahen. Dort konnte mir leider auch keiner helfen.
    Habe dann heute Nacht den Ganzen Mist noch mal neu in CSS gebaut.
    Die Seite läuft nu auch weis aber bis jetzt immer noch nich wo bei der alten Version der Fehler lag.

    Ich danke euch auf jeden Fall für eure Hilfe

    MFG

    Hag
     
Die Seite wird geladen...
Ähnliche Themen - Buttons funktionieren nich
  1. Manni1306
    Antworten:
    0
    Aufrufe:
    1.115
    Manni1306
    08.10.2011
  2. Series 60
    Antworten:
    3
    Aufrufe:
    5.109
    phönö
    19.05.2011
  3. hightime-fan
    Antworten:
    2
    Aufrufe:
    1.196
    hightime-fan
    07.03.2009
  4. tonypolar
    Antworten:
    2
    Aufrufe:
    1.066
    tonypolar
    14.01.2009
  5. DieTa
    Antworten:
    5
    Aufrufe:
    7.107
    Katolino
    27.07.2007