Aquamacs -- wird immer zu "=

  1. theoldgimlet

    theoldgimlet Thread StarterMacUser Mitglied

    Mitglied seit:
    11.11.2005
    Beiträge:
    616
    Zustimmungen:
    48
    Hallo,

    ich habe mich entschlossen Aquamacs für die Erstellung meiner Latex Dokumente zu verwenden und bin sehr begeistert, nur wie kann ich Aquamacs oder wohl besser Aquatex abgewöhnen zwei Bindestriche -- automatisch durch "= zu ersetzen ?

    Vielen Dank im Voraus
     
    theoldgimlet, 22.11.2006
  2. tasha

    tashaMacUser Mitglied

    Mitglied seit:
    06.08.2002
    Beiträge:
    3.676
    Zustimmungen:
    38
    Hi,

    das musst Du in den AUCTeX-Einstellungen umstellen. Wo genau weiß ich auch nicht auf Anhieb, müsste auch suchen.

    Grüße,

    tasha
     
    tasha, 22.11.2006
  3. theoldgimlet

    theoldgimlet Thread StarterMacUser Mitglied

    Mitglied seit:
    11.11.2005
    Beiträge:
    616
    Zustimmungen:
    48
    Hi tasha,

    danke für deine Antwort, wenn du es finden solltest, dann verrat es mir doch bitte. Ich habe schon im Manual von AUCTeX gesucht, aber da blicke ich jetzt wirklich nicht mehr durch.

    Grüße
     
    theoldgimlet, 22.11.2006
  4. tasha

    tashaMacUser Mitglied

    Mitglied seit:
    06.08.2002
    Beiträge:
    3.676
    Zustimmungen:
    38
    Hallo,

    ich habe die Option im Manual gefunden:
    http://www.gnu.org/software/auctex/manual/html_node/European.html#European

    Sie heißt „LaTeX-babel-hyphen“.

    Grüße,

    tasha
     
    tasha, 22.11.2006
  5. virtua

    virtuaMacUser Mitglied

    Mitglied seit:
    08.01.2004
    Beiträge:
    2.680
    Zustimmungen:
    80
    Nimmst du zwei Bindestriche um einen Gedankenstrich zu schreiben? Also '--' statt '–' ? Wenn ja, dann mach es einfach mit Alt+Bindestrich und schon brauchst du keine zwei -- mehr ;)
     
    virtua, 22.11.2006
  6. Peisistratos

    Peisistratos

    Weitere Variante: dreimal Bindestrich tippen, wird automatisch zu "--".
    Auf "= sollte man vielleicht nicht verzichten, weil es in german.sty bzw. [german]{babel} einen Bindestrich markiert, an dem umgebrochen werden darf.

    Grüße, Peisistratos
     
    Peisistratos, 22.11.2006
  7. neptun

    neptunMacUser Mitglied

    Mitglied seit:
    28.09.2003
    Beiträge:
    2.017
    Zustimmungen:
    22
    Mit MacOSRoman als Encoding funktionniert das.
    Es gibt aber auch Leute, die - z.B. aus Kompatibilitätsgründen - Iso Latin 1 vorziehen. Und denen wird '–' Sorgen bereiten :(

    Gruß, neptun
     
    neptun, 22.11.2006
  8. theoldgimlet

    theoldgimlet Thread StarterMacUser Mitglied

    Mitglied seit:
    11.11.2005
    Beiträge:
    616
    Zustimmungen:
    48
    Danke für die ganzen Tipps.

    @tasha: Habe versucht die Option zu ändern, nur stelle ich mich vermutlich zu doof an.

    Daher werde ich einfach die drei Bindestriche nehmen, die Peisistratos empfohlen hat, denn Alt + - geht bei mir nicht.

    @ Was gibt es denn für Kompatibilitätsproblem mit '-' und Iso Latin 1. Und welche Kodierung meinst du hier? Doch vermutlich die vom .tex-file oder ? Da verwende ich UTF-8, gibt es da irgendwelche Punkte auf die ich aufpassen sollte ?

    Gruß,
     
    theoldgimlet, 22.11.2006
  9. neptun

    neptunMacUser Mitglied

    Mitglied seit:
    28.09.2003
    Beiträge:
    2.017
    Zustimmungen:
    22
    Das Problem hatte ich nicht mit dem einfachen '-', sondern mit '–' (alt+'-'). Ich schreibe neuerdings meine .tex-files in Iso Latin 1, und bei der Konvertierung von alten Files machen verschiedene Zeichen Ärger, wie z.B. dieses '–'; das muss ich dann durch '--' ersetzen.
    Ja, genau.
    Da bin ich jetzt überfragt.
    In dieser Kodierungsproblematik blicke ich überhaupt nicht durch, was dazu führt dass ich regelmässig Ärger beim Öffnen von Textfiles habe (nicht nur .tex). Es läuft zum Beispiel immer wieder schief, wenn ich Adressen aus einer .txt-File auf Etiketten bringen will.
    Gruß, neptun

    Gruß,
     
    neptun, 23.11.2006
  10. promille

    promilleMacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    1.288
    Zustimmungen:
    36
    promille, 23.03.2007
Die Seite wird geladen...
Ähnliche Themen - Aquamacs immer
  1. Dark Rose
    Antworten:
    10
    Aufrufe:
    174
  2. grimpeur78
    Antworten:
    0
    Aufrufe:
    322
    grimpeur78
    06.05.2012
  3. grimpeur78
    Antworten:
    2
    Aufrufe:
    658
    grimpeur78
    05.05.2012
  4. stitch_ac
    Antworten:
    8
    Aufrufe:
    3.109
    Magicq99
    02.06.2008
  5. DiscoStu
    Antworten:
    1
    Aufrufe:
    641
    DiscoStu
    11.04.2008