1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Apache v. 2.0.48 installiert - Probleme!

Dieses Thema im Forum "Mac OS" wurde erstellt von 20000st, 28.04.2004.

  1. 20000st

    20000st Thread Starter MacUser Mitglied

    Mitglied seit:
    24.10.2003
    Beiträge:
    374
    Zustimmungen:
    0
    Ich habe von http://www.serverlogistics.com Apache 2.0.48 für OS X heruntergeladen und hab jetzt ein paar Probleme.

    Muss ich dem www User im NetInfo den neuen Pfad zu Apache 2 (in diesem Fall /Library/Apache2 als neues home zuweisen?

    Wo finde ich ein PHP Paket für Apache2 (oder funzt das von entropy.ch?)

    WebSharing funzt nicht so ganz, ist mir nicht klar warum, schließlich läuft der Apache WebServer...

    Kann mir da jemand weiterhelfen?

    20000st
     
  2. 20000st

    20000st Thread Starter MacUser Mitglied

    Mitglied seit:
    24.10.2003
    Beiträge:
    374
    Zustimmungen:
    0
    Hm vielleicht sollte ich ein wenig präziser werden:

    - ich bediene den Apache2 über die mitgelieferte PrefPane
    - bein Start des Apache2 werden gleich 6 (!) httpd-Prozesse gestartet! alle natürlich mit einem eigenen PID: einer von root, ale anderen von nobody :rolleyes:
    - WebSharing geht nicht, d.h. dass man nicht mehr auf http://localhost/~
    benutzer gehen kann.

    Wer hilft mir jetzt da raus?

    20000st
     
  3. Horror

    Horror MacUser Mitglied

    Mitglied seit:
    03.02.2003
    Beiträge:
    1.416
    Zustimmungen:
    9
    Hi. Also: eigentlich ist es nicht nötig, den Apachen zu installieren, weil mitgeliefert (wenn auch nur Version 1.3.x (oder so). PHP4 musste nur in /private/etc/httpd/httpd.conf aktivieren, da sind 2 Schalter, die auskommentiert sind:

    PHP:
    #LoadModule php4_module        libexec/httpd/libphp4.so
    und

    PHP:
    #AddModule mod_php4.c
    Einfach nur '#' entfernen und den Apachen neu starten (jedoch mit sudo, also apachectl restart ;)).

    Horror
     
  4. 20000st

    20000st Thread Starter MacUser Mitglied

    Mitglied seit:
    24.10.2003
    Beiträge:
    374
    Zustimmungen:
    0
    Danke Horror, das habe ich bislang genauso gemacht wie du es beschrieben hast.

    Jetzt habe ich aber eben auf Apache 2 umgestellt und ich habe mich gefragt, wie ich das WebSharing auf die neuere Version steuern kann.

    PHP läuft bestens.

    Grüße

    20000st