Xemacs installieren

Dieses Thema im Forum "Mac OS X - Unix & Terminal" wurde erstellt von grind, 11.07.2005.

  1. grind

    grind Thread Starter MacUser Mitglied

    Beiträge:
    448
    Zustimmungen:
    3
    MacUser seit:
    17.03.2004
    Moin Forum,

    ich stecke hier grade fest bei der Installation des XEmcas. Ueber Fink kommt irgendwann der folgende Fehler:

    Information about 2212 packages read in 3 seconds.
    The following package will be installed or updated:
    xemacs
    The following 4 additional packages will be installed:
    xaw3d xaw3d-shlibs xfree86 xfree86-shlibs
    Do you want to continue? [Y/n] y
    Failed: can't find package xfree86-shlibs_4.4.0-13_darwin-powerpc.deb


    Wenn ich XEmacs ueber Darwinports installieren will, dann hab ich schon Probleme, darwinports zu installieren:
    ...
    checking for X... no
    checking for XOpenDisplay in -lX11... yes
    Please install the X11 SDK packages from the
    Xcode Developer Tools CD
    configure: error: Broken X11 install. No X11 headers


    Also meine Frage: Wie komme ich nun an einen funktionierenden XEmacs unter X11?

    Danke fuer eure Vorschlaege :D
    Norman
     
    Zuletzt bearbeitet: 11.07.2005
  2. sir.hacks.alot

    sir.hacks.alot MacUser Mitglied

    Beiträge:
    2.406
    Zustimmungen:
    113
    MacUser seit:
    10.03.2005
    Sieht so aus, als hättest Du kein X11 und/oder die Developertools instaliert.

    greetz Thomas
     
    Zuletzt bearbeitet: 11.07.2005
  3. grind

    grind Thread Starter MacUser Mitglied

    Beiträge:
    448
    Zustimmungen:
    3
    MacUser seit:
    17.03.2004
    Nee nee,

    also X11 und die Developertools sind installiert. Und eigentlich ist auch alles richtig installiert, denn ich kann X11 nutzen und Programmieren funktioniert auch...

    Wobei ich see grad, dass der X11 SDK verlangt. Ist das das gleiche wie X11?

    Vermutlich nicht,oder?
     
    Zuletzt bearbeitet: 11.07.2005
  4. Maveric

    Maveric MacUser Mitglied

    Beiträge:
    462
    Zustimmungen:
    0
    MacUser seit:
    22.03.2004
    Nein, das X11 SDK ist ein extra Paket, welches du bei der Installation der Developertools von Hand mitinstallieren mußt da es nicht in der Standardinstallation mit drin ist.

    Such die XCode CD deiner aktuellen XCode Installation und installiere von dieser das Pakete X11SDK.pkg nach und gut sollte sein. Achte dabei aber darauf, daß das X11SDK zum installierten X11 paßt.
    Für Panther brauchst du das X11SDK von XCode 1.x je nachdem welches XCode du installiert hast.

    Für Tiger brauchst du das XCode 2.0 X11 SDK wenn du XCode 2.0 installiert hast und das XCode 2.1 X11SDK wenn du XCode 2.1 installiert hast. Ein XCode 2.0 X11SDK mit XCode 2.1 verwenden ging bei mir nicht.
     
    Zuletzt bearbeitet: 11.07.2005
  5. grind

    grind Thread Starter MacUser Mitglied

    Beiträge:
    448
    Zustimmungen:
    3
    MacUser seit:
    17.03.2004
    Also ich habs jetzt das X11 SDK installiert und schwupps, hat alles geklappt. Danke fuer die Hilfe...

    norman
     
Die Seite wird geladen...