Word: AutoText - Format bzw. FormatvorlangenUNabhängig?

Dieses Thema im Forum "Office Software" wurde erstellt von archelon, 30.05.2006.

  1. archelon

    archelon Thread Starter MacUser Mitglied

    Beiträge:
    552
    Zustimmungen:
    6
    MacUser seit:
    11.07.2003
    Kann man in Word (Version 2004) den AutoText so einstellen, dass Word das zu vervollständigende Wort der aktuell verwendeten Formatvorlage anpasst bzw. übernimmt?

    [Beispiel: Ich habe ein Wort dem AutoText hinzugefügt, als die Standardformatvorlage auf Arial in Schriftgröße 12 stand. Jetzt schreibe ich in Georgia in Schriftgröße 11 (als neues Standardformat). Wird jetzt das in AutoText vorhandene Wort getippt, bietet mir Word bei erst vier getippten Buchstaben des Wortes den AutoVervollständigen-Tipp des Wortes an, sodass mit ENTER das Wort automatisch geschrieben wird (ich muss es nicht zu Ende tippen); leider wird die ursprüngliche Formatvorlage (hier: Arial,12) übernommen.]

    AutoText unabhängig von der Formatvorlage?:(
     
  2. archelon

    archelon Thread Starter MacUser Mitglied

    Beiträge:
    552
    Zustimmungen:
    6
    MacUser seit:
    11.07.2003
    Hat noch niemand diese Funktion in unterschiedlichen Formatvorlagen benutzt? Gibt es eine Lösung?
     
  3. falkgottschalk

    falkgottschalk MacUser Mitglied

    Beiträge:
    24.026
    Zustimmungen:
    1.598
    MacUser seit:
    22.08.2005
    99,99999% der Anwender würden die Krise bekommen, wenn beim Ersetzen auch die Schriftart geändert werden würde.
    So etwas musst Du dann mit der manuellen ERSETZEN-Funktion machen, kannst Du ja notfalls auf einen Makro legen.
     
  4. archelon

    archelon Thread Starter MacUser Mitglied

    Beiträge:
    552
    Zustimmungen:
    6
    MacUser seit:
    11.07.2003
    Du hast völlig recht! Auch ich kriege die Krise, WEIL die Schriftart beim Einsetzen GEÄNDERT wird!
    Word übernimmt bei einem neuen Eintrag in den AutoText-Katalog nicht nur das Wort, sondern auch die in diesem Moment aktuelle Formatvorlage - ich will aber eigentlich nur das Wort in den AutoText-Katalog aufnehmen. Wenn man dann später in einem anderen Dokument, bei dem man mit einer anderen Schrift arbeitet, einen vorhandenen AutoText-Eintrag einfügen will, wird die ursprüngliche Schrift beim Einsetzten des Wortes verwendet, nicht die des gerade zu bearbeitenden Dokumentes.
    Also, die Schrift wird, wie Du richtig erkannt hast, geändert; und vielleicht bekommen 99,99999 % der Anwender die Krise. Du hast also mein Problem erkannt! Und ich möchte, dass die Schrift NICHT ERSETZT wird!
    Weiß jemand eine Lösung?
     
  5. falkgottschalk

    falkgottschalk MacUser Mitglied

    Beiträge:
    24.026
    Zustimmungen:
    1.598
    MacUser seit:
    22.08.2005
    Salve!
    Passiert das nur bei neu von Dir zugefügten Begriffen? Dann liegt es daran, wie Du die zufügst!
    Dusselig wie M$ nun mal ist: der Default ist "formatierter Text".
    Bei den standardmäßig definierten "Drehern" wird definitv KEINE Schriftart mit geändert.

    Siehe "beiliegende" Hardcopy:
     
    Zuletzt bearbeitet: 28.05.2007
  6. archelon

    archelon Thread Starter MacUser Mitglied

    Beiträge:
    552
    Zustimmungen:
    6
    MacUser seit:
    11.07.2003
    Gut, da habe ich was gelernt: in der AutoKorrektur lässt sich einstellen, ob nur der Text selbst oder inklusive Formatierung automatisch geändert wird. Die Autokorrektur macht zb aus dem "dei" automatisch ein "die", ohne dass man etwas dafür tun muss, sozusagen automatisch beim Tippen.

    Ich meine aber den AutoText. Hierbei wird nur dann der Text automatisch eingefügt, wenn der AutoText-Vorschlag, der bei den Anfangsbuchstaben eines existierenden AutoText-Eintrag als Quick-Info angezeigt wird, per Return-Taste bestätigt wird.
    Leider finde ich im AutoText-Konfigurationsmenü keine Möglichkeit die Formatierung wie bei der AutoKorrektur auszuschalten.
    Gibt es evtl. beim Speichern der AutoText-Einträge die Möglichkeit, nur den reinen Text zu speichern?

    Anbei zwei Screenshots von zwei AutoText-Einträgen. Hierbei sieht man in der Vorschau die unterschiedlichen Formatierungen!
     

    Anhänge:

  7. Tristam Brandy

    Tristam Brandy MacUser Mitglied

    Beiträge:
    432
    Zustimmungen:
    98
    MacUser seit:
    13.02.2006
    archelon, Autotext wird grundsätzlich immer im Stil der Textstelle eingefügt, an der du den Kursor hast. Mit einer Ausnahme: Wenn du ein Wort in einem Dokument markierst, dabei die Absatzmarke mit einschließt und dann das markierte Wort als Autotext hinzufügst, wird das Format des Absatzes mit übernommen. Du hast die Absatzmarke bei deinen Autotext-Definitionen mitkopiert, deshalb sieht man sie auch in deinen Screenshots am Ende des Wortes.

    Dagegen hilft nur, dass du entweder die Einträge wieder löschst und manuell ins Autotext-Fenster einträgst oder dass du sie ohne Absatzmarke aus dem Dokument kopierst.

    Das Problem, das dich grade so nervt, ist eigentlich eine besonders smarte Funktion von Word. Du kannst selber entscheiden, ob deine Autotext-Einträge im Stil des jeweiligen Absatzes erscheinen sollen oder ob du ein ganz bestimmtes Format haben willst. Das heißt, du kannst zum Beispiel ein bestimmtes Tabellenformat oder eine chemische Formel durch Einschluss der Absatzmarke als Autotext definieren und dann ganz einfach wieder abrufen.
     
  8. archelon

    archelon Thread Starter MacUser Mitglied

    Beiträge:
    552
    Zustimmungen:
    6
    MacUser seit:
    11.07.2003
    Ich erinnere mich, dass dem so war, als ich noch unter Windows mit Word gearbeitet habe; da habe ich allerdings nur in Arial geschrieben.

    Verursacht die eingeschlossene Absatzmarke nicht, dass mit dem eingefügten Wort automatisch in den nächsten Absatz gesprungen wird? Ist bei mir allerdings so.

    Das möchte ich ja eigentlich, dass der eingefügte AutoText-Eintrag sich an die gerade benutzten Formatierungen anpasst.
    Ich habe es gerade nochmals ausprobiert: neue AutoText-Einträge in verschiedenen Schriftarten und Schriftgrößen erstellt, z.T. nur das Wort selbst, z.T. mit nachfolgendem Leerzeichen und z.T. mit Absatzmarke.
    Beim Einfügen setzt Word konsequent die bei der Erstellung verwendeten Formate mit ein (andere Schriftart und -größe).
    Was mache ich falsch???
     
  9. Tristam Brandy

    Tristam Brandy MacUser Mitglied

    Beiträge:
    432
    Zustimmungen:
    98
    MacUser seit:
    13.02.2006
    Keine Ahnung. Wie gesagt: Autotext wird immer als reiner Text gespeichert und beim Einfügen an die Zielformatierung angepasst, es sei denn du hast beim Erstellen die Absatzmarke mitkopiert. Wenn das bei dir anders ist, dann hast du offenbar die "Word 2004 Special Abnormal Autotext Implementation Edition" gekauft ..
     
  10. Tristam Brandy

    Tristam Brandy MacUser Mitglied

    Beiträge:
    432
    Zustimmungen:
    98
    MacUser seit:
    13.02.2006
    PS! Einen Lösungsvorschlag hab ich noch. Wenn er funktioniert, kannst du mir per PM ein Bier schicken:
    Schau mal nach, ob in den Word-Einstellungen unter "Allgemein" die Option "Formatierten Text in die Zwischenablage einfügen" aktiviert ist. In der Grundeinstellung müsste sie aus sein, aber wenn sie aktiviert ist, werden Autotext-Markierungen mit dem Format gespeichert. Deaktiviere die Einstellung, und Autotext wird wieder mit der Zielformatierung eingefügt.
     
Die Seite wird geladen...

Diese Seite empfehlen