Windows Clienten an OSX Server .3 spinnen...

Dieses Thema im Forum "Mac OS X Server, Serverdienste" wurde erstellt von starknights, 18.06.2004.

  1. starknights

    starknights Thread Starter MacUser Mitglied

    Beiträge:
    211
    Zustimmungen:
    16
    MacUser seit:
    31.05.2004
    Hallo,
    ich hoffe, hier kann mir jemand helfen.

    Dass heterogene Netzwerke für den osx Server kein Problem sind wissen wir alle seit Apple es so laut verkündet hat.

    Leider klappt's nicht richtig.


    Ok, hier das Problem:
    Wir haben einen OSX.3.4 Server (Xserve) und WinXP Clienten.
    Der Server identifiziert sich im Netz als Win NT4.9 Server und Zugreifen kann ich auch.

    Ich kann sogar ohne Probleme über den Windows Explorer Daten schreiben und lesen, (geht sogar flott ;) ) und auch von den Macs aus über das smb und af-Protokoll.

    Soooo, nun aber wenn ich direkt aus einer Applikation (z.B. Photoshop) auf den Server speichern möchte, dann dauert das bei ca. 2 Meg. großen Daten über eine Minute!
    Alle Dateien die mehr als ca 4 MB groß sind können erst garnicht gespeichert werden, d.h. der WinXP rechner speichert die Daten, das dauert dann ca. 3 Minuten, und dann erscheint die Fehlermeldung Datenverlust beim schreiben... konnte nciht gesichert werden.

    Tja, irgendwer eine Idee?
    Über den Explorer klappts, aber aus den Programmen heraus nciht...
    Ich verstehe die Welt nicht mehr :(

    Ach ja, die Error Log auf dem Server zeigt immer solche EInträge:
    read_socket_data: recv failure for xxxx Error = Connection reset by peer


    Über HIlfe wäre ich sehr dankbar, da ich den X-Serve hier alleine gegen die Win2000 Kiste durchgeboxt habe und nun ziemlich belämmert da stehe, weil cih den alten Win Server erstmal wieder anschließen durfte :(

    PS. Apple konnte mir auch nciht weiterhelfen...
     
  2. starknights

    starknights Thread Starter MacUser Mitglied

    Beiträge:
    211
    Zustimmungen:
    16
    MacUser seit:
    31.05.2004
    LOL, trotzdem Danke ;)

    soeben ist von Apple eine Lösung gekommen, also braucht ihr euch nicht mehr das Hirn zu zermartern.

    Aber falls nochmal so etwas auftritt, hier die Lösung (die bei uns geklappt hat)

    in der Datei smb.conf (Finder-Gehe zu-Gehe zu Ordner -> /etc) mit Text edit im Bereich [global] diese Zeile anhängen:
    socket options = SO_RCVBUF=64240

    ach ja, normalerweise ist das Verzeichnis nicht zu beschreiben, also müsst ihr am einfachsten die Datei auf den Desktop speichern und dann mit der Maus in etc ziehen, dann werdet ihr nach Admin-Name und Passwort gefragt, eintragen enter. fertig.

    Jetzt noch einen Neustart und es sollte laufen.

    et voilá: es klappt ;)
    (zumindest bis jetzt die ersten tests)
    *freu*


    Wünsche allen noch ein frohes Wochenende (ich hab's jetzt)


    CU

    Michael Hermes
     
Die Seite wird geladen...

Diese Seite empfehlen