Und er bootet nicht... (User-Datenbank zerschossen?)

Diskutiere mit über: Und er bootet nicht... (User-Datenbank zerschossen?) im iMac, Mac Mini Forum

  1. msslovi0

    msslovi0 Thread Starter MacUser Mitglied

    Beiträge:
    2.713
    Zustimmungen:
    115
    Registriert seit:
    20.03.2005
    Die Betreffzeile ist etwas kurz für mein Problem ;)

    Meine Stereoanlage ist zur Zeit auf dem besten Weg Geschichte zu schreiben, nämlich als erster Mac, der mir wirklich Probleme macht.

    Zunächst aber die (leider etwas längliche) Vorgeschichte:

    Vorgestern hatte der mini mal wieder keine Airportverbindung. Das kommt alle paar Wochen mal vor, liegt wohl auch eher am betagten Netgear-Router, also nichts dabei gedacht und neu gestartet. Nachdem der mini schon nicht runterfahren wollte habe ich ihn mit Gewalt beendet und danach wieder neu gestartet. Zum Hochfahren hatte er dann aber auch keinen Bock, es hat schon sehr lange gedauert bis überhaupt ein Bild auf den Monitor kam und dann war da nur der Apfel und der Spinner. Und zwar auch noch als ich wieder aus der Dusche kam.

    Also zunächst wieder ausgemacht, Tastatur ran, Parameter-RAM gelöscht. Keine Besserung. Der anschließende Versuch im Single-User-Modus zu booten endete auch beim Apfel.
    Der verbose-Mode ist, wie der Name schon sagt, in dem Fall etwas aussagekräftiger. Die letzte Meldung ist
    Code:
    Jun  7 18:13:27 maryland memberd[63]: dsFindDirNodes returned -14071, count = 0
    Jun  7 18:13:27 maryland memberd[63]: dsFindDirNodes returned -14071, count = 2147483646
    Jun  7 18:13:27 maryland memberd[63]: Couldn't find root user.  Sleeping and trying again. 
    
    Und das macht er dann bis tief in die Nacht - wenn man ihn läßt.
    Google ist, danach befragt, recht workarg und bei mir trat das Problem ja auch nicht auf nachdem ich irgendwas installiert hatte, sonder von jetzt auf gleich. Außerdem scheint bei den meisten der Single-User-Mode noch zu gehen, bei mir hingegen nicht. Also hab ich mal das große Feuerwerk abgefackelt:

    Zunächst auf die Suche nach der Installations-CD gemacht, aber nur die vom PowerBook (10.3) gefunden. Bei der Gelegenheit auch noch eine Maus gesucht, nachdem noch eine CD im Laufwerk war und der Touchscreen natürlich nicht funktioniert.

    Mit der 10.3-CD gestartet und das Festplattendienstprogramm ausgeführt. Die Platte müsse repariert werden, aber genau das klappt nicht. Nachdem mit der 10.3er Installation noch keine anderen Programme ausführbar sind, ich aber ein Terminal haben wollte, habe ich dann doch noch die mini-DVDs suchen müssen. Wieder nicht gefunden, dafür die normale Tiger-Version vom PowerMac. Drauf gesch*ssen, reingeworfen. Aber auch im Terminal das gleiche Bild: Platte kaputt, kann nicht repariert werden. Trotzdem, ich konnte alle Verzeichnisse der Platte im Terminal anschauen, offensichtlich alles da und auch das kopieren auf die per Firewire angeschlossene Platte klappte prima - bis die Platte voll war :D Auch das Festplattendienstprogramm vermeldet im SMART-Status für die Platte: Überprüft.

    Nachdem ich eine Nacht drüber geschlafen hatte und mir auch wieder eingefallen ist, wo die 10.4-DVD vom mini sein könnte, habe ich dann heute zunächst den alten PC aus der Ecke geholt, Platte ausgebaut, in ein FW-Gehäuse gesteckt und platt gemacht. Dann mit der mini-DVD gebootet.
    Mit dem Festplattendienstprogramm habe ich ein komplettes Image auf die neue Platte gezogen, ohne Probleme, das Image läßt sich am PowerBook auch öffnen und im Finder durchklickern. Vor einem erneuten Versuch, die Platte zu reparieren, habe ich dann den "hilft-immer"-Vorschlag meines Bruders noch durchgeführt: Rechte reparieren. Und siehe da, es klappt. Die Platte ist repariert, alles wieder im grünen Bereich. Denkste. Die Kiste bootet immer noch nicht, das gleiche Bild wie vorher.

    Also nochmal von CD gebootet, dieses mal aber den Hardware-Test. Die ausführliche Variante ist ohne Probleme durchgelaufen, alle Tests bestanden.
    Ein erneuter Start im verbose-Mode brachte genau das gleiche wie vorher ans Tageslicht, nach wie vor kein root-User in Sicht.

    Letzter Versuch: Von DVD booten und Kennwörter zurücksetzen, vielleicht gibt das der offensichtlich korrupten User-Datenbank den nötigen Tritt, um wieder ins Gleichgewicht zu kommen. Platte vom mini ausgewählt und... Nichts. Kein User in Sicht. Das Dropdown ist nicht auswählbar und es steht nur drin "Keine verfügbaren Benutzer".

    Und jetzt kommt der Punkt, wo ich so langsam aber sicher mit meinem Latein am Ende bin.

    Bevor ich mich aber an die Neuinstallation mache wollte ich hier noch mal gefragt haben, vielleicht hat ja wer einen Tipp wie man das ganze, evtl. auch von einem anderen Mac aus, wieder gerade biegen könnte...

    Matt
     
  2. msslovi0

    msslovi0 Thread Starter MacUser Mitglied

    Beiträge:
    2.713
    Zustimmungen:
    115
    Registriert seit:
    20.03.2005
    Ich muss den nochmal nach oben schieben ;)

    Niemand eine Idee?

    Matt
     
  3. lengsel

    lengsel MacUser Mitglied

    Beiträge:
    4.627
    Zustimmungen:
    53
    Registriert seit:
    25.11.2003
    Ich würde in diesem Fall einfach neu installieren, es sei denn Du hast unbegrenzt Zeit und Lust dem Problem auf die Spur zu kommen.
    Prinzipiell bin ich kein Freund von "Gewaltlösungen", aber wie bereits gesagt wären mir bei dem Fall Zeit und Nerven zu schade für die Ursachensuche.

    Grüße (ins scheene Meenz),
    Flo
     
  4. msslovi0

    msslovi0 Thread Starter MacUser Mitglied

    Beiträge:
    2.713
    Zustimmungen:
    115
    Registriert seit:
    20.03.2005
    Naja, das mit der Zeit ist relativ. Es ist jetzt nicht so, dass mein Rechner, mit dem ich arbeiten muss, von dem Problem betroffen ist. Von daher kann ich da schon noch etwas Zeit investieren.
    Und Neuinstallieren ist auch zeitaufwendig. Nicht das OS an und für sich, aber der ganze andere Programmkram, der da noch dazukommt...

    Matt
     
Die Seite wird geladen...
Ähnliche Themen - bootet (User Datenbank Forum Datum
iMac late 2013 (27") bootet nicht, grüner Bildschirm und dann weiß iMac, Mac Mini 14.11.2016
Bootet Imac normal? iMac, Mac Mini 26.10.2016
Mac mini Server - Bootet nicht mehr iMac, Mac Mini 05.08.2015
iMac 24" (late 2006) bootet nicht mehr iMac, Mac Mini 15.07.2015
iMac 24 bootet gar nichts mehr ausser Single User iMac, Mac Mini 29.10.2013

Diese Seite empfehlen

Benutzerdefinierte Suche