Umlaute in RW-Formular

Dieses Thema im Forum "Web-Editoren" wurde erstellt von ge2r, 12.02.2007.

  1. ge2r

    ge2r Thread Starter MacUser Mitglied

    Beiträge:
    130
    Zustimmungen:
    5
    MacUser seit:
    16.10.2006
    Hallo,

    Ich habe über die Suche nichts konkretes zu meinem Problem gefunden, deshalb möchte ich euch mal direkt Fragen.

    Ich habe mit Rapidweaver eine Website erstellt und bin mit dem Programm (als ziemlicher Laie) auch gut zurecht gekommen. Auch meine Formulare funktionieren tadellos, nur mit Sonderzeichen wie deutschen Umlauten und den französischen é,à,â, etc. gibt's Probleme.

    Wenn man sie eingibt werden sie richtig angezeigt. Im Mail, das danach verschickt wird, bleibt nur noch das bekannte Kauderwelsch. Hier ein Beispiel:

    Name: Gérard Koob (é)

    E-Mail: gerardkoob@vo.lu

    Adresse: 2, route d\'Arlon (d'Arlon)

    PLZ und Ortschaft: L-9176 Niederfeulen

    Telefon: 88 84 76

    Fax:

    Betreff: Tést (Tést) ;)

    Nachricht: Un petit test en français (français), avec des accents aigus (é) (é) et des accents grâves (è) (grâves)


    Ae,ä (ä) - Ue,ü (ü)


    Ich habe schon was über die Textkodierung hier im Forum gelesen, aber wie sage ich RW, was es mit den Eingaben ins Formular anstellen soll ? :confused:

    Bin dankbar für alle Tips

    Viele Grüsse,
    ger

    EDIT: Ein Link zur Seite: http://www.campingdunord.lu
     
  2. b.legt210

    b.legt210 MacUser Mitglied

    Beiträge:
    81
    Zustimmungen:
    4
    MacUser seit:
    01.03.2006
    Hi ge2r,

    ich denke das Problem liegt in der Datei mailer.php. Deine gesamte Seite ist in UTF-8, die Daten werden aber vermutlich als ISO-8859-1 versendet. Kontrollier also bitte mal diese PHP-Datei und schau ob du dort den verwendeten Zeichensatz einstellen kannst.
     
  3. ge2r

    ge2r Thread Starter MacUser Mitglied

    Beiträge:
    130
    Zustimmungen:
    5
    MacUser seit:
    16.10.2006
    Hallo,

    RapidWeaver bietet UTF-8 und Western (Latin 1) an. Ich habe für die Formulare mal letzteres ausgewählt und jetzt scheint es zu klappen!

    Vielen Dank,
    ger
     
  4. heldausberlin

    heldausberlin MacUser Mitglied

    Beiträge:
    14.081
    Zustimmungen:
    302
    MacUser seit:
    01.05.2004
    Viele Plugins sind auf ISO-5589-1 (Latin 1) ausgerichtet, da ist es sinnvoll, das auch standardmäßig zu verwenden.

    Ein anderer Tipp: Nenne die Ablageordner und Dateinamen (in „index.html“)deiner Unterseiten um (Seiteneinstellung mit apfel+i). Dann heißt z. B. deine Kontaktseite

    www.campingdunord.lu/kontakt/

    und nicht

    www.campingdunord.lu/page11/page11.html

    sieht schöner aus und lässt sich besser mitteilen, wenn man mal den Direktlink weitereichen will. :)
     
  5. ge2r

    ge2r Thread Starter MacUser Mitglied

    Beiträge:
    130
    Zustimmungen:
    5
    MacUser seit:
    16.10.2006
    Stimmt, das war mir gar nicht aufgefallen. Ich werde das ändern, sieht wirklich besser aus.

    Danke für den Tip!
     
Die Seite wird geladen...

Diese Seite empfehlen