Systemeinstellungen stürzen ab

Dieses Thema im Forum "Mac OS X" wurde erstellt von mc.Mac, 23.06.2005.

  1. mc.Mac

    mc.Mac Thread Starter MacUser Mitglied

    Beiträge:
    270
    Zustimmungen:
    3
    MacUser seit:
    30.06.2004
    Systemeinstellungen bieiben hängen

    OS X 10.3.9 (Panther)
    PB 12'', 1.33

    Hallo zusammen,

    seit dem jüngsten Security Update 2005-006 (V 1.0) - so jedenfalls mein Empfinden - klappt's mit den Systemeinstellungen nun gar nicht mehr.

    Bei Einstellungen, die eine Authentifizierung erfordern: Nach dem ich das PW eingab (Klicken sie auf das Schloss, um Änderungen vorzunehmen) und egal wo eine Änderung vornahm (bspw. in "Energie sparen": Schieberegler bei Ruhezustand nach n Minuten), hängt sich 'Systemeinstellungen' auf. Ich muss auf "Sofort beenden" gehen. Quasi gehen mir damit die wichtigsten Einstellungsmöglichkeiten verloren.

    Bisherige Maßnahmen:
    Starten von CD ('C' bei Start des PB)
    -> Festplattendienstprogramm
    -> Volume überprüfen und reparieren
    -> Zugriffsrechte überprüfen und reparieren
    Ergebnis: Keine Änderungen

    Versuch, im Single User Mode zu starten ('ctrl' + 's' bei Start des PB - gleich nach dem Startsound)
    Ergebnis bei mehreren Versuchen: Das PB startet einfach nicht im SUM sondern munter bis zum gewohnten Loginfenster

    Vorgestern ist die Softwareaktualisierung von selbst komplett abgestürzt.
    Ich wollte nach neuer Software suchen, hatte noch nicht den Button 'suchen' betätigt sondern noch woanders rumgesucht, da stürzt das Teil plötzlich ab.

    Hat jemand einmal ähnliche Erfahrungen gemacht und kann mir damit weiteres Vorgehen empfehlen?
    Hat jemand unter euch eine Idee, warum der SUM nicht startet?

    Danke im Voraus und viele Grüße
    mc.mac
     
    Zuletzt bearbeitet: 23.06.2005
  2. hertzchen

    hertzchen MacUser Mitglied

    Beiträge:
    1.993
    Zustimmungen:
    21
    MacUser seit:
    20.09.2004
    als erstes würde ich rechte reparieren, von cd|dvd starten> festplattendienstprogramm und rechte reparieren - was für zusätzliche "kontrollfelder" hast du installiert?
     
  3. hertzchen

    hertzchen MacUser Mitglied

    Beiträge:
    1.993
    Zustimmungen:
    21
    MacUser seit:
    20.09.2004
    oh - habe nicht zu ende gelesen - hast du ja schon gemacht ;-)

    preferences gelöscht?
     
  4. mc.Mac

    mc.Mac Thread Starter MacUser Mitglied

    Beiträge:
    270
    Zustimmungen:
    3
    MacUser seit:
    30.06.2004
    du meinst die .plist? falls zutreffend, welche genau sollte ich löschen?

    als zusätzliche prefs (unter "Sonstige") habe ich installiert: Déjà Vu, Logitech Control Center, Menu Meters. Side Tracks und Urchin. Aber mit denen gab's bislang keinerlei Probleme.
     
  5. mc.Mac

    mc.Mac Thread Starter MacUser Mitglied

    Beiträge:
    270
    Zustimmungen:
    3
    MacUser seit:
    30.06.2004
    Zwiscchendurch: Ist es möglich und könnte es Erfolg bringen, mit Hilfe der 2 System CD's OS X nochmal drüber zu bügeln, um damit schadhafte Anteile mit Originaldateien wieder zu überschreiben?

    Das Ganze darf natürlich keinerlei Datenverlust mit sich bringen!
     
  6. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    Ich würde Dir raten, alle selbstinstallierten PrefPanes an einen anderen Ablageort zu verschieben und damit vorläufig zu deinstallieren.
    Dann Rechner neu starten und prüfen, ob das Problem noch besteht.
     
  7. mc.Mac

    mc.Mac Thread Starter MacUser Mitglied

    Beiträge:
    270
    Zustimmungen:
    3
    MacUser seit:
    30.06.2004
    I/O Error bei Zugriff auf Systemeinstellungen

    Hallo maceis,

    das habe ich nun getan. Leider erfolglos.
    Im console.log entdeckte ich folgende Einträge:
    Mac OS X Version 10.3.9 (Build 7W98)
    2005-06-25 00:28:58 +0200
    2005-06-25 00:28:59.147 loginwindow[238] FSResolveAliasWithMountFlags returned err = -43

    2005-06-25 00:29:50.314 System Preferences[446] has battery

    2005-06-25 00:30:09.427 System Preferences[459] *** NSTask: Task create for path /System/Library/PrivateFrameworks/Admin.framework/Resources/writeconfig failed: 5, "Input/output error".

    2005-06-25 00:30:39.868 System Preferences[478] *** NSTask: Task create for path /System/Library/PrivateFrameworks/Admin.framework/Resources/writeconfig failed: 5, "Input/output error".

    Der i/o Error taucht auf, sobald ich in den Systemeinstellungen die Passwort-Abfrage habe/hatte. Die Zugriffsrechte von "writeconfig" sind hier (ich denke ordnungsgemäß) nur für System auf "Lesen & Schreiben" - alle anderen auf "Nur Lesen".

    Was fällt sonst noch auf: Bei den meisten Abfragen des Admin-KW dauert es ungewöhnlich lange, bis die Eingabe angenommen wird - während dessen läuft die Animation "Bitte warten" (die auch beim Start von OS X zu sehen ist). Bei den Systemeinstellungen läuft diese Animation außerdem auffällig schnell und unruhig - bei einem Rad würde man vergleichsweise sagen: Das Teil hat 'ne Unwucht.

    Hmn... Ich hab nun wirklich keine Lust, das System nach fast einem Jahr komplett neu aufzusetzen - dazu ist eigentlich zu viel installiert und konfiguriert. Wenn's natürlich keine andere Möglichkeit gibt ....
     
  8. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    Damit wird es natürlich auch um so schwieriger aus der Ferne die Fehlerursache zu erraten.
    Sorry, das ich da nicht weiterhelfen kann.
     
Die Seite wird geladen...
Ähnliche Themen - Systemeinstellungen stürzen
  1. disillusion
    Antworten:
    0
    Aufrufe:
    175
  2. Fuechsl
    Antworten:
    0
    Aufrufe:
    114
  3. MBrown
    Antworten:
    2
    Aufrufe:
    524
  4. BAXX
    Antworten:
    3
    Aufrufe:
    438
  5. LetsMac
    Antworten:
    1
    Aufrufe:
    366

Diese Seite empfehlen