Syslogd soll vom Linksys Router logs empfangen...

Dieses Thema im Forum "Mac OS X - Unix & Terminal" wurde erstellt von jlepthien, 24.01.2006.

  1. jlepthien

    jlepthien Thread Starter MacUser Mitglied

    Beiträge:
    4.858
    Zustimmungen:
    118
    MacUser seit:
    05.04.2004
    Hallo!

    Ich moechte die logs von meinem Linksys Router gerne an meinen Mac schicken und auch in eine Datei schreiben lassen. Der Router wurde schon angewiesen, die Daten an meinen Host zu senden. Ich habe dann in der Datei /System/Library/LaunchDaemons/com.apple.syslogd.plist die Zeile <string>/usr/sbin/syslogd</string> in <string>/usr/sbin/syslogd -udp_in 1</string> geaendert. Ich empfange aber keinerlei Daten vom Router. Wie kann ich dem syslogd sagen in welche Datei er ueberhaupt die Daten schreiben soll? Ich konnte am Router leider nur den Loghost angeben, jedoch keine Facility oder so. Ach ja und ich habe zwischen meinem Router und dem Mac keine weitere Firewall, der Port 514 udp wird also nicht gesperrt. Jemand eine Idee?

    Danke
     
  2. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    Gabs kürzlich eine Anleitung dazu.

    Du musst folgende Änderung in der Plist Datei durchführen:

    Code:
    <string>/usr/sbin/syslogd</string>
    <string>-u</string>
    Die zweite Zeile musst Du einfach nur einfügen.
    Wie Du auf Deine Syntax kommst ist mir unklar.

    -u steht übrigens für unsecure, da man damit in gewissen Situationen ein Sicherheitsproblem bekommen könnte.
    Im Heimnetzwerk ist das aber belanglos.

    Es wäre übrigens nicht schlecht gewesen, wenn Du Dein Posting ein wenig strukturiert hättest (mit Absätzen und so).
    Das mach das Ganze gleich viel lesbarer.
     
  3. jlepthien

    jlepthien Thread Starter MacUser Mitglied

    Beiträge:
    4.858
    Zustimmungen:
    118
    MacUser seit:
    05.04.2004
    Danke fuer deine Hilfe auch trotz der nicht vorhandenen Absaetze ;)

    So funktioniert es jetzt. Die Syntax habe ich aus einem Buch. Dort stand das man diese oder das mit -u nehmen kann. Hatte es nur nicht in ein extra <string> tag gepackt.

    Nun sah ich die einkommenden logs auch im system.log, ich moechte sie jedoch in z.B. linksys.log haben. Dann habe ich in der syslogd.conf den Eintrag
    Code:
     kern.* /var/log/linksys.log
    eingetragen, jedoch schreibt er in diese Datei nichts rein, hoert aber auch auf in die system.log zu schreiben. Die Datei habe ich natuerlich auch angelegt.

    Hier nochmal zu meinem Paramter die Info aus der Manpage von syslog:
    Code:
    [b]The -u option
        is equivalent to using the -udp_in 1 option.
    [/b]
     
    Zuletzt bearbeitet: 24.01.2006
  4. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
  5. jlepthien

    jlepthien Thread Starter MacUser Mitglied

    Beiträge:
    4.858
    Zustimmungen:
    118
    MacUser seit:
    05.04.2004
    Danke! Jedoch erwaehnte ich bereits, dass ich auf dem Router keine Facility einstellen kann, sondern nur die IP des syslog Servers. Dann haette ich es ja auch schon so gemacht.
     
  6. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    Nun, die fehlende Funktionalität eines Produktes wird man nicht ändern können.

    Möglicherweise kannst Du anhand der Einträge im System Log herausfinden, welche Facility Dein Router verwendet und dementsprechend filtern.

    Möglicherweise bietet Dein Router auch ein Kommandozeilen Interface, wo man mehr einstellen kann, als mit der grafischen Konfiguration.
    Ansonsten musst Du halt mit den Einträgen im system.log leben.
    Kann man ja mit grep extrahieren.
     
  7. jlepthien

    jlepthien Thread Starter MacUser Mitglied

    Beiträge:
    4.858
    Zustimmungen:
    118
    MacUser seit:
    05.04.2004
    Ja hat er. Darauf haette ich auch selbst kommen koennen ;)
    Ich werde es mal zu Hause testen.
     
  8. below

    below MacUser Mitglied

    Beiträge:
    13.882
    Zustimmungen:
    1.086
    MacUser seit:
    15.03.2004
    Ich habe hier auch einen Linksys BEFVP41, habe syslogd -u aktiviert, und das logging im Router angemacht.

    Aber: Ich empfange keine Logs :( Ich hab auch schon mal sudo tcpdump udp port syslog laufen lassen, da kommt nichts)

    In anderen Posts hiess es mal, der Linksys würde gar kein syslogd kompatibles Format senden, kann das jemand bestätigen oder widerlegen?

    Alex
     
  9. jlepthien

    jlepthien Thread Starter MacUser Mitglied

    Beiträge:
    4.858
    Zustimmungen:
    118
    MacUser seit:
    05.04.2004
    Ich weiss jetzt garnicht mehr, ob das bei mir mal lief. Nutze jetzt ne Astaro Firewall auf Linux Basis. Die ist ja fuer Homeuser kostenlos und kann so einiges mehr ;)
     
Die Seite wird geladen...

Diese Seite empfehlen