Spotlight indizierung auf USB Festplatte abschalten

Dieses Thema im Forum "Mac OS X" wurde erstellt von cschroec, 04.01.2006.

  1. cschroec

    cschroec Thread Starter MacUser Mitglied

    Beiträge:
    293
    Zustimmungen:
    1
    MacUser seit:
    04.01.2005
    Habe hier eine USB-Festplatte, die ich immer nur für Backups mit DejaVu benutze. jedesmal wenn ich die anstecke, fängt Spotlight an das Teil zu indizieren. Wie verhindere ich das Dauerhaft? In den Spotlighteinstellungen kann ich sie zwar hinzufügen, nach dem auswerfen und erneuten anschliessen geht der Spass aber wieder los...
    Bitte helft!!!
     
  2. setrok

    setrok MacUser Mitglied

    Beiträge:
    7
    Zustimmungen:
    0
    MacUser seit:
    04.01.2006
    Das geht nur vom Terminal (Kommandozeile) aus. Öffne mal das Terminal und gib "man mdutil" ein. Der richtige Schalter müsste "-i" sein, also etwa "mdutil -i off /Volumes/cschroecs-usb-festplatte" sein. Natürlich musst Du den richtigen Volume-Namen einsetzen. :)

    (Den Tipp habe ich übrigens aus einem kürzlich gekauften Mac OS X 10.4 Tiger Buch von Marc Oliver Thoma)
     
    Zuletzt bearbeitet: 05.01.2006
  3. cschroec

    cschroec Thread Starter MacUser Mitglied

    Beiträge:
    293
    Zustimmungen:
    1
    MacUser seit:
    04.01.2005
    Supi, danke!
     
  4. setrok

    setrok MacUser Mitglied

    Beiträge:
    7
    Zustimmungen:
    0
    MacUser seit:
    04.01.2006
    Kaum hatte ich's Dir geschrieben, brauchte ich es selbst. Spotlight wollte unbedingt meine Backup-Festplatte indizieren. ;) Deshalb noch kurz ein (wahrscheinlich unnötiger) Nachtrag: mdutil lässt sich nur als root ausführen, deshalb ein "sudo" davor setzen.
     
  5. echt0711

    echt0711 MacUser Mitglied

    Beiträge:
    858
    Zustimmungen:
    12
    MacUser seit:
    11.10.2003
    Hi Leute!

    Habe den Thread hier gefunden und darauf hin mal das Terminal bemüht, um meinem Problem auf die Sprünge zu kommen… bei mir wird nämlich eine Platte nicht indiziert:

    Code:
    knoedgen-dual-g5:~ mac_root$ sudo mdutil -s /Volumes/tiger_g5
    Password:
    /Volumes/tiger_g5:
            Status: Indexing Enabled
    knoedgen-dual-g5:~ mac_root$ sudo mdutil -s /Volumes/fileserver_g5
    /Volumes/fileserver_g5:
            Error: Could not get indexing status for volume.
    knoedgen-dual-g5:~ mac_root$ 
    Was könnte da los sein? Das Volume, auf das hier zugegriffen wird ist ein RAID 0 Array, bestehend aus 2 SATA Platten, das an einer neu gekauften RocketRaid Karte hängt (http://www.highpoint-tech.com/USA/rr1820amac.htm).

    Mein Mac ist aber mal sowas von extrem schnell, wenn er auf die Platte zugreifen darf, daß ich dazu tendiere, alle möglichen Dateien auf den "Fileserver Stripe" zu verschieben... wäre schön, wenn ich die Platte indizieren könnte.

    Immerhin ist das Ganze doch für Tiger (10.4.3) nichts weiter als ein Volume, oder? Was sollte man da am besten tun, um dem Fehler auf die Schliche zu kommen?
     
  6. Wast

    Wast MacUser Mitglied

    Beiträge:
    70
    Zustimmungen:
    3
    MacUser seit:
    13.06.2004
    Hallo,

    ich habe ebenfalls eine externe Festplatte, die ich mit SuperDuper! als Ersatz-Boot-Medium verwende!

    Das mit mdutil habe ich hinbekommen. Spotlight indiziert die externe Platte nicht mehr.
    Leider merkt sich spotlight nicht, dass es diese Platte nicht indizieren soll.

    --> Bei erneutem Anstecken der Platte wird das Indizieren erneut gestartet.

    Kann man dies nicht vielleicht doch dauerhaft abschalten?
     
  7. youmac

    youmac MacUser Mitglied

    Beiträge:
    5
    Zustimmungen:
    0
    MacUser seit:
    21.12.2007
    Bei mir kommt

    localhost:~ james$ sudo mdutil -s /Volumes/My Book
    Error: invalid path `/Volumes/My'.
    Error: invalid path `Book'.

    obwohl es als "My Book" angezeigt wird.

    localhost:~ james$ cd /volumes
    localhost:volumes james$ ls
    My Book PowerBook HD
    localhost:volumes james$

    Auch mit Unterstrich zwischen "My" und "Book" geht es nicht . Ebenso invalid path :(

    Kann mir jemand bitte sagen wie ich das machen muss ? Bin Mac Neuling, denke mal ich mache nur eine Kleinigkeit falsch :confused:

    Gruß David
     
  8. Wast

    Wast MacUser Mitglied

    Beiträge:
    70
    Zustimmungen:
    3
    MacUser seit:
    13.06.2004
    Hi,

    Tipp: gib mal folgendes ein
    cd /Vol --> Zab drücken --> My --> Tab drücken

    sehen müsstest du dann folgendes:
    cd /Volumes/My\ Book/

    ansonsten sollte auch folgendes funktionieren:
    cd '/Volumes/My Book'
     
  9. youmac

    youmac MacUser Mitglied

    Beiträge:
    5
    Zustimmungen:
    0
    MacUser seit:
    21.12.2007
    ok danke, jetzt funktioniert es zumindest theoretisch aber jetzt kommt folgendes Problem " Error: unexpected indexing state (/Volumes/My Book) " oder " Error: unable to perform operation. (-1) "

    :o

    Last login: Sun Feb 3 20:19:24 on ttys000
    localhost:~ james$ sudo mdutil -s /Volumes/My\ Book
    /Volumes/My Book:
    Indexing enabled.
    localhost:~ james$ sudo mdutil -i /Volumes/My\ Book
    Error: unexpected indexing state (/Volumes/My Book)
    Usage: mdutil -pEsa -i (on|off) volume ...
    Utility to manage Spotlight indexes.
    -p Publish metadata.
    -i (on|off) Turn indexing on or off.
    -E Erase and rebuild index.
    -s Print indexing status.
    -a Apply command to all volumes.
    -v Display verbose information.
    localhost:~ james$


    so gehts auch nicht:

    localhost:~ james$ mdutil -i off /Volumes/My\ Book
    /Volumes/My Book:
    Error: unable to perform operation. (-1)
    Indexing enabled.
    localhost:~ james$


    Was soll ich machen ?
    Ich muss das dringend ausgeschaltet bekommen, das Indexing braucht jedes Mal ne Stunde bis ich die Platte endlich normal benutzen kann.

    Gruß David
     
    Zuletzt bearbeitet: 03.02.2008
  10. youmac

    youmac MacUser Mitglied

    Beiträge:
    5
    Zustimmungen:
    0
    MacUser seit:
    21.12.2007
    Ahh ! Ich Trottel :D

    sudo vergessen ^^:hamma:

    Ok jetzt klappts .

    Hat schon jemand nen Weg gefunden es dauerhaft abzuschalten ?
    Kenn mich nur mit Win/Dos aus, da wär das ja kein Problem mittels batch Datei ..

    Sowas muss in OSX doch sicher auch problemlos machbar sein...
     
Die Seite wird geladen...

Diese Seite empfehlen