Samba Verbindungsabbrüche

Dieses Thema im Forum "Internet- und Netzwerk-Hardware" wurde erstellt von Caipi, 06.12.2005.

  1. Caipi

    Caipi Thread Starter MacUser Mitglied

    Beiträge:
    56
    Zustimmungen:
    1
    MacUser seit:
    21.06.2004
    Hallo,

    habe hier ein Netzwerk bestehend aus einem Gentoo-Server, Macs und PCs. Der Server stellt die Daten per Samba zur Verfügung. Wenn ich von den Macs (egal welcher) auf die Samba-Share zugreife und eine größere Datei hoch- oder runterlade kommt zwischendurch ein Fenster, welches mit mitteilt, dass es zu einem Verbundungsabbruch gekommen ist. Ich kann dann entweder auf "Trennen" oder "OK" klicken. Gehe ich auf "OK" werden die Daten einfach weiterübertragen. Leider funktioniert das aber nur drei mal, denn dann bricht, er die Verbindung wirklich ab, so kann ich nur selten mehr als 4GB hochladen. Von den PCs aus geht es, nur die 10.3.Xer Macs wollen nicht mitspielen.

    Habe im Forum nur was von Geschwindigkeitsproblemen, oder nicht angezeigten Shares gelesen, das geht alles nur wird eben mitten im Kopieren die Verbindung unterbrochen.

    Kann mir jemand nen Tipp geben?

    Grüße

    Caipi
     
  2. Lucky_Darts

    Lucky_Darts MacUser Mitglied

    Beiträge:
    412
    Zustimmungen:
    0
    MacUser seit:
    28.01.2004
    klingt nach einem idle-timeout trotz traffic
     
  3. Caipi

    Caipi Thread Starter MacUser Mitglied

    Beiträge:
    56
    Zustimmungen:
    1
    MacUser seit:
    21.06.2004
    jep, wobei keep alive in der smb.conf aktiviert ist, kann man da mac-seitig noch was einstellen?
     
  4. Caipi

    Caipi Thread Starter MacUser Mitglied

    Beiträge:
    56
    Zustimmungen:
    1
    MacUser seit:
    21.06.2004
    Hier mal der [global] meiner smb.conf

    [global]
    socket options = SO_KEEPALIVE SO_BROADCAST TCP_NODELAY
    unix extensions = yes
    keepalive = 30
    smb passwd file = /etc/samba/private/smbpasswd
    netbios name = server.loc
    server string = server.loc
    admin users = @staff
    workgroup = WORK
    os level = 64
    preferred master = yes
    encrypt passwords = yes
    security = user
    wins support = true
     
  5. cptsalek

    cptsalek MacUser Mitglied

    Beiträge:
    24
    Zustimmungen:
    0
    MacUser seit:
    10.08.2003
    Bleibt Deine Netzwerkverbindung denn generell bestehen? Ich habe bei mir das merkwürdige Phänomen, dass bei einem größeren Datentransfer via Samba oder Netatalk mein Interface abzustürzen scheint. Ich muß es dann manuell runter und wieder hochfahren, dann wird der Transfer eine Weile fortgesetzt, bis es erneut zu diesem Fehler kommt.
    In dem Moment, wo der Datentransfer abbricht, bleiben auch alle SSH-Sessions hängen, es ist also durchaus etwas "globales". Schau doch mal bei Dir nach, ich will hier auch nichts durcheinander werfen, aber evtl. ist die Ursache bei uns identisch?
     
  6. Caipi

    Caipi Thread Starter MacUser Mitglied

    Beiträge:
    56
    Zustimmungen:
    1
    MacUser seit:
    21.06.2004
    Ne ist bei mir nicht so, Netzwerk geht weiterhin. Habe mal Screenshots der Fehlermeldungen gemacht:

    Zuerst kommt (bis zu 3mal):
    [​IMG]

    Wenn ich "OK" klicke geht es einfach weiter, dann kommt:

    [​IMG]

    und danach geht nix mehr, dann ist die Datei nur unvollständig auf dem Server.
     
  7. Caipi

    Caipi Thread Starter MacUser Mitglied

    Beiträge:
    56
    Zustimmungen:
    1
    MacUser seit:
    21.06.2004
    Die neuesten Erkentnisse, vielleicht kann mir ja doch jemand helfen.

    - Der Verbindungsabbruch passiert nur beim Upload, Download geht einwandfrei.
    - Wenn ich die Daten via muCommander hochlade geht es

    Es scheint so als ob der Finder den Upload nicht als fortlaufenden Prozess ansieht sondern denkt es würde nichts mehr passieren und deshalb der timeout passiert.

    Kann man da was tweaken??
     

Diese Seite empfehlen