Rechteproblem? Fehler beim drucken, Prob mit MS- und Openoffice bzw. X11.app

Dieses Thema im Forum "Mac OS X" wurde erstellt von Charles_Garage, 21.02.2005.

  1. Charles_Garage

    Charles_Garage Thread Starter MacUser Mitglied

    Beiträge:
    1.977
    Zustimmungen:
    18
    MacUser seit:
    20.10.2004
    Hallo,
    ich hab eine Probleme MS-Office unter normalen Benutzern zu starten.

    Es gibt immer die Fehlermeldung:

    "Sie haben nicht die notwendigen Zugriffsrechte, um dieses Programm zu öffnen"

    Starte ich ein X-Programm z.B OpenOffice.org heißt es:

    "Could not launch X Window". X startet zwar, beendet sich aber wieder.

    Desweiteren kommt beim Drucken die Meldung:

    "Fehler beim Drucken"

    Im Administrator-Konto funktioniert alles.
    Eine Rechte-Reparatur von CD habe ich schon durchgeführt. Komme ich nun um eine Neuinstallastion herum? Und wenn nicht: Bleiben meine Apps und Einstellungen erhalten?

    Viele Grüße

    Charles
     
  2. Lynhirr

    Lynhirr Gast

    Wenn du 10.3.8 laufen hast, lade dir doch mal das Combo-Update bei Apple herunter und istalliere das. Dabei werden auch die Prebindings erneuert. Vielleicht hilft das schon …
     
  3. sanamiguel

    sanamiguel MacUser Mitglied

    Beiträge:
    1.524
    Zustimmungen:
    0
    MacUser seit:
    15.08.2002
    Wenn Du auf z.B. Exel markierst, dann auf Apfel + i drückst (=Information), müßtest Du unter Eigentümer/Zugriffsrechte sehen können, wer lesen/schreiben darf. Evtl hilft es ja, dieses ggf dort zu ändern (mit Adm.-Passwort)
     
  4. dani76

    dani76 MacUser Mitglied

    Beiträge:
    11
    Zustimmungen:
    0
    MacUser seit:
    22.04.2004
    Fehler beim Drucken

    Hallo,

    ich habe da ein ähnliches Problem... Bei mir kommt immer die Meldung "Fehler Beim Drucken" obwohl andere User alle Programme benutzen können...

    Andere Benutzer können aber keine Fotos von Digitalkameras importieren...

    Ich habe da einem Mac Support mal angerufen... der wusste auch nicht weiter... Tja. Schade. War doch bis jetzt so zufrieden mit dem Mac... *schnieff* ;-)

    Ich habe mal mit dem Festplattendienstprogramm alle Rechte zurückgesetzt... hat auch nichts genutzt...

    wäre auch froh um jeden Tipp.

    Gruss Dani
     
  5. Charles_Garage

    Charles_Garage Thread Starter MacUser Mitglied

    Beiträge:
    1.977
    Zustimmungen:
    18
    MacUser seit:
    20.10.2004
    @Lynhirr:

    Danke, das hat zumindest bei dem MS-Officeproblem Abhilfe geschaffen. Es bleibt aber dennoch das Problem mit dem Drucken und mit den X11-Anwendungen.

    Viele Grüße, Charles
     
    Zuletzt bearbeitet: 22.02.2005
  6. Charles_Garage

    Charles_Garage Thread Starter MacUser Mitglied

    Beiträge:
    1.977
    Zustimmungen:
    18
    MacUser seit:
    20.10.2004
    Mit dem Kommandozeilenbefehl: lp kann ich übrigends Problemlos drucken. Ich muss also erstmal in eine pdf-Datei drucken. Und dieses pdf kann ich dann mit "lp *.pdf" drucken.
    Das ist aber etwas umständlich und die X-Programme hätte ich auch gerne wieder am laufen (Openoffice, gimp, kpatience, kstars ...).
    Wo hat X11 eigentlich überall Dateien? Weiß das jemand? Dann könnte ich die Rechte mal "zu Fuß" überprüfen.

    Vielen Dank

    Charles Garage
     
  7. lundehundt

    lundehundt MacUser Mitglied

    Beiträge:
    19.352
    Zustimmungen:
    881
    MacUser seit:
    22.02.2003
    Beim Rechte reparieren werden nur solche Rechte repariert die in den receipts (bill of material) der .pkg files auf der Platte gefunden werden. Wenn fuer die Anwendung kein solches .pkg existiert werden auch keine Rechte repariert. Sowohl MS Office als auch X-11 haben solche .pkg's unter /Library/Receipts.

    Funktioniert X-11 als Admin? Funktioniert es nur bei bestimmten usern nicht oder bei allen die nicht Admin sind? Kannst du mal einen neuen user anlegen und es mit dem probieren - damit koennte man user spezifische Einstellungen in den preferences (.plists) ausschliessen.

    Cheers,
    Lunde
     
  8. Charles_Garage

    Charles_Garage Thread Starter MacUser Mitglied

    Beiträge:
    1.977
    Zustimmungen:
    18
    MacUser seit:
    20.10.2004
    Seltsamerweise funktioniert X11 wenn ich es direkt starte. Starte ich aber ein Programm, das X11 benötigt, dann startet X11 zunächst, verschwindet dann aber wieder von der Bildfläche. So als könnten die X11-Programme keine Verbindung zum X-Server herstellen.
    Das nur bei konventionellen Nutzern. Im Admin-Account geht alles Problemlos.
     
  9. lundehundt

    lundehundt MacUser Mitglied

    Beiträge:
    19.352
    Zustimmungen:
    881
    MacUser seit:
    22.02.2003
    Das es bei alle Benutzern ohne Admin Rechte nicht geht spricht zwar nicht dafuer aber einen Versuch ist es Wert. Jeder user hat in /user/Library/Preferences eine Datei namens com.apple.LaunchSevices.plist. Das ist der cache der LaunchServices die fuer die Zuordnung von Dokumenten (.suffix, type, creator) zu Anwendungen zustaendig sind. Diese Dateien zu loeschen entspricht in etwa dem rebuild-desktop unter classic. Schaden kann es nicht. Unter Umstaenden brauchen Anwendungen die ueber Dokumente geoeffnet werden beim erstem mal einen Tick laenger.

    Cheers,
    Lunde
     
    Zuletzt bearbeitet: 26.02.2005
Die Seite wird geladen...