PureFTPd und seine Tücken! - Hilfäää!!!!

Dieses Thema im Forum "Internet- und Netzwerk-Software" wurde erstellt von Talin, 30.11.2005.

  1. Talin

    Talin Thread Starter MacUser Mitglied

    Beiträge:
    17
    Zustimmungen:
    0
    MacUser seit:
    11.12.2004
    Tja, da steh ich nun ich armer Thor und mein FTP funtkioniert nicht wie je zuvor....*hust* :D


    Aber nunmal zur Sache. Ich hab mir gestern PureFTPd auf die Kiste geschmissen (g5 dual-1,8 | OS 10.4), hab es installiert, habe einen User angelegt, habe die Firewall meines Mac entsprechend eingestellt, habe auf meinem Router die Ports entsprechend forwarded.....ALLES WUNDERBAR.


    Nur wenn ich mich jetzt noch via FTP einloggen könnte, wäre das prima. Der FTP-Server an sich läuft, man kann ihn auch erreichen, aber man kann sich nicht einloggen. Jedesmal INCORRECT PASSWORD.

    Frage: Hat hier NOCH jemand ausser mir (oder leide ich mal wieder nur als einziger *lol*) diese Probleme mit PureFTPd? Es funktioniert alles, aber ich kann mich nicht einloggen, weil angebl. das PWD des Usernamens falsch ist.

    Irgendeiner eine Idee wodran das liegt?!


    Lieben Gruß

    Uwe :)


    P.S.: Ja, das Passwort habe ich richtig geschrieben.
    P.P.S: Ja....das die PW´s Case Sensitive sind, habe ich auch bedacht
    P.P.P.S.: Nein, es sind keine Umlaute und Sonderzeichen darin enthalten

    :D
     
  2. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.804
    Zustimmungen:
    3.632
    MacUser seit:
    23.11.2004
    hast du den pureftpd richtig geconfiged?
    schliesslich benutzt os x keine passwd/shadow...
     
  3. Talin

    Talin Thread Starter MacUser Mitglied

    Beiträge:
    17
    Zustimmungen:
    0
    MacUser seit:
    11.12.2004
    spreche nicht kryptisch! *g* Ich versteh zwar alles schnell, aber ich brauch für neue Sachen immer einmal die Vollidiotenanleitung ;)
     
  4. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.804
    Zustimmungen:
    3.632
    MacUser seit:
    23.11.2004
    kannst du dich denn lokal einloggen?
    wenn das schon nicht geht, dann liegt es an der config...
    wenn es lokal geht und extern nicht, dann hast du nicht die richtigen bzw genügend ports geforwardet am router
     
  5. Talin

    Talin Thread Starter MacUser Mitglied

    Beiträge:
    17
    Zustimmungen:
    0
    MacUser seit:
    11.12.2004
    nein, lokal kann ich mich auch nicht einloggen. das ist es ja, was mich so fuchst, das es überhaupt nicht funktioniert.

    die config sollte eigentlich so stimmen, wie sie ist. gibts da irgendwas besonderes, auf das man achten sollte?! so den typischen "ich seh den wald vor bäumen nicht"-Fall?!
     
  6. Talin

    Talin Thread Starter MacUser Mitglied

    Beiträge:
    17
    Zustimmungen:
    0
    MacUser seit:
    11.12.2004
    mit meinem system-usernamen komm ich wohl rein, nur ich hab nicht wirklich vor für jeden knaben, der sich da auf dem ftp einloggen soll, nen system-user anzulegen....da werd ich ja nimmer glücklich mit.
     
  7. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.804
    Zustimmungen:
    3.632
    MacUser seit:
    23.11.2004
    lies halt mal die anleitung, welches auth-modul du für was einbinden musst...
    PAM oder so für die system-user...
    keine ahnung wie das mit den virtuellen usern bei pureftpd geht, und was du dazu einbinden musst...
     
  8. Talin

    Talin Thread Starter MacUser Mitglied

    Beiträge:
    17
    Zustimmungen:
    0
    MacUser seit:
    11.12.2004
    ich hab mir mal alle möglichen config-files von der kiste angesehen....da sind die einträge komischerweise richtig drinne. ich weiss allerdings nicht, warum die kiste nicht läuft. es ist echt zum haareraufen :(

    die virtuellen user werden auch via pam verwaltet.
     
  9. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.804
    Zustimmungen:
    3.632
    MacUser seit:
    23.11.2004
    nach änderung in der config musst du den daemon restarten...
     
Die Seite wird geladen...

Diese Seite empfehlen