Probleme Xcode | openGL (signal 6 (SIGABRT)

Diskutiere mit über: Probleme Xcode | openGL (signal 6 (SIGABRT) im Mac OS X Entwickler, Programmierer Forum

  1. supervision

    supervision Thread Starter MacUser Mitglied

    Beiträge:
    42
    Zustimmungen:
    0
    Registriert seit:
    29.04.2006
    Hallo,

    und zwar startet mein kleines Programm unter xcode nicht.
    Code:
    ZeroLink: unknown symbol '__Z11gltxReadRGBPc'
    
    Texturierung has exited due to signal 6 (SIGABRT).
    Hatte neulich genau das gleiche Problem, im Projekt lag eine main.c die er statt der main.cpp hat versucht hat zu starten. Ist diesmal aber nicht so.

    Irgendwelche Ideen?

    Und ja, mein Programm verfügt über eine main-Funktion ;)

    shoutz,
    supervision
     
  2. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.774
    Zustimmungen:
    3.629
    Registriert seit:
    23.11.2004
    das sieht nach einem library problem aus...
    die, in der gltxReadRGB ist, scheint nicht im projekt zu sein...
     
  3. supervision

    supervision Thread Starter MacUser Mitglied

    Beiträge:
    42
    Zustimmungen:
    0
    Registriert seit:
    29.04.2006
    jau, das ist es...es gibt da noch die gltx.c

    Wusste nicht das ich sie nochmal extra dem Projekt bekannt machen muß,
    auf der Dose reicht es, wenn sie im gleichen Ordner liegt.

    Hab die Datei jetzt einfach mal per drag'n'drop reingezogen, aber bekomme
    nach wie vor den Fehler...wie mache ich den nun die c-datei im Projekt bekannt?

    so sieht das momentan bei mir aus:

    screenshot
     
  4. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.774
    Zustimmungen:
    3.629
    Registriert seit:
    23.11.2004
    du musst die nur compillieren...
    dann sollte der linker die automatisch als bestandteil des projekts finden...
     
  5. supervision

    supervision Thread Starter MacUser Mitglied

    Beiträge:
    42
    Zustimmungen:
    0
    Registriert seit:
    29.04.2006
    mmmh, also ich gehe auf die gltx.c, mache ein build, und dann dann gehe ich auf meine main.cpp und mache build and go;
    trotzdem bekomme ich den selben Fehler..

    ?
     
  6. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.774
    Zustimmungen:
    3.629
    Registriert seit:
    23.11.2004
    bist du sicher, dass die funktion auch in dem file ist?
    clean mal das projekt von den object files, kann sein, dass da noch mal komplett neu gelinkt werden muss....
     
  7. supervision

    supervision Thread Starter MacUser Mitglied

    Beiträge:
    42
    Zustimmungen:
    0
    Registriert seit:
    29.04.2006
    ja, die Funktion gltxReadRGB ist in der gltx.c vorhanden.
    Projekt gecleant, rebuild, immer noch gleicher Fehler.

    Ich verstehts auch nicht, muß ja irgendwas mit der gltxReadRGB sein... :mad:
     
Die Seite wird geladen...
Ähnliche Themen - Probleme Xcode openGL Forum Datum
Probleme beim bauen von "fontconfig" Mac OS X Entwickler, Programmierer 23.11.2016
Ich habe probleme mit c++ mit xCode... Mac OS X Entwickler, Programmierer 08.01.2006
probleme mit xcode Mac OS X Entwickler, Programmierer 18.07.2005
XCode 2 Probleme Mac OS X Entwickler, Programmierer 16.05.2005
Probleme mit xCode - update auf 1.5 nicht möglich und gcc funktioniert nicht Mac OS X Entwickler, Programmierer 08.11.2004

Diese Seite empfehlen

Benutzerdefinierte Suche