Probleme mit der Anmeldung wg. AFP-Ordnern

Dieses Thema im Forum "Mac OS X Server, Serverdienste" wurde erstellt von mmakunga, 05.07.2004.

  1. mmakunga

    mmakunga Thread Starter MacUser Mitglied

    Beiträge:
    18
    Zustimmungen:
    0
    MacUser seit:
    05.07.2004
    Moin moin,

    bin leider (noch) kompletter MAC-DAU :rolleyes:, aber gezwungen, einen MAC-Server zu administrieren.

    Konfiguration:

    - Server: Mac OS X Server 10.3.4, Client: Mac OS X 10.?
    - automatisch aktivierbare AFP-Netzwerk-Ordner für Privatordner erstellt ('meinEigenesUserVerzeichnis', Protokoll:AFP)
    - Accounts liegen im LDAP-Verzeichnis des Servers (Open Directory Master)

    Nun habe ich -beispielsweise- einen Benutzer xyz erstellt und sein Homeverzeichnis auf folgenden Ordner gesetzt (Arbeitsgruppen-Manager): Accounts->Privat->Ort: afp://195.xxx.xxx.xxx/meinEigenesUserVerzeichnis

    Das Problem ist, dass ich mich mit diesem Benutzer nicht anmelden kann (nicht am Server direkt und auch nicht am Client), es kommt immer folgende Fehlermeldung:

    'Sie können sich derzeit nicht mit dem Benutzernamen "xyz" anmelden.

    Das Anmelden mit diesem Benutzernamen ist aufgrund eines Fehlers fehlgeschlagen. Der Privatordner des Benutzers befindet sich auf einem AFP- oder SMP-Server. Für Unterstützung wenden Sie sich an Ihren Administrator.'

    Braucht Ihr noch mehr Infos zur Lösungsfindung oder kann mir jemand von Euch so schon helfen, so dass ich mich mit den Usernamen nun auch anmelden kann?

    Schöne Grüße und vielen herzlichen Dank schonmal im Voraus,
    mm
     
  2. mmakunga

    mmakunga Thread Starter MacUser Mitglied

    Beiträge:
    18
    Zustimmungen:
    0
    MacUser seit:
    05.07.2004
    Probleme mit der Anmeldung wg. AFP-Ordnern - Nachtrag

    Moin nochmal,

    wenn im Arbeitsgruppen-Manager über Accounts->Privat->Ort das Standardverzeichnis /Users gewählt wird, ist ein Login möglich :confused:. Nun sollen die Userverzeichnisse halt aber in einem anderen Volume liegen...

    Ich hoffe, irgendwer da draußen kann mir helfen,
    mm
     
  3. echt0711

    echt0711 MacUser Mitglied

    Beiträge:
    858
    Zustimmungen:
    12
    MacUser seit:
    11.10.2003
    Ich kann mir nicht vorstellen, daß es ratsam ist, einem anderen User Dein eigenes (admin-) Homeverzeichnis als home zuzuweisen. Vielleicht funktioniert das sogar garnicht… leg doch alles was Du freigeben willst in ein eigenes Verzeichnis und gib dieses frei. Die User, die auf den Server Zugriff haben sollen, sollten alle ihr eigenes Home-Verzeichnis (mit allem was dazugehört) bekommen!
     
  4. mmakunga

    mmakunga Thread Starter MacUser Mitglied

    Beiträge:
    18
    Zustimmungen:
    0
    MacUser seit:
    05.07.2004
    Moin echt0711,

    danke für Deine Antwort!

    Selbstverständlich soll jeder Benutzer sein eigenes Verzeichnis bekommen, und zwar beispielsweise unter dem Netzwerkordner afp://195.xxx.xxx.xxx/hierLiegenAlleUser (also z.B. in LANGERPFADDURCHVERZEICHNISBAUM/hierLiegenAlleUser/xyz, LANGERPFADDURCHVERZEICHNISBAUM/hierLiegenAlleUser/abc,...). Im Arbeitsgruppen-Manager ('Privat') werden die Pfade ja auch korrekt gesetzt (automatisch auf afp://195.xxx.xxx.xxx/SHORTNAME).

    Nur leider scheitert das Login.

    Schöne Grüße und auf weitere Hilfe hoffend,
    mm
     
  5. echt0711

    echt0711 MacUser Mitglied

    Beiträge:
    858
    Zustimmungen:
    12
    MacUser seit:
    11.10.2003
    also nochmal: den Server findet er (d.h. die Adressierung via IP funktioniert)? Aber der Login wird abgelehnt? Dann ist der Benutzer nicht korrekt eingerichtet - dort würde ich suchen :)
     
  6. mmakunga

    mmakunga Thread Starter MacUser Mitglied

    Beiträge:
    18
    Zustimmungen:
    0
    MacUser seit:
    05.07.2004
    Moin echt0711,

    Benutzer ist IMO korrekt erstellt, da ein Login (auf dem Server und von einem Client) mit im Arbeitsgruppen-Manager lokal eingestelltem Standard-Home-Verzeichnis ('/Users') möglich ist, mit einem AFP-Netzwerkordner ('afp://195.xxx.xxx.xxx/hierLiegenAlleUser/') aber nicht. Laut dem Apple-PDF 'Mac OS X Server Benutzerverwaltung' soll dieser Weg über die AFP-Netzwerkordner gegangen werden ('Einrichten eines Privatordners im Netzwerk')...

    Seuftz, irgendwie komme ich nicht weiter...

    Schöne Grüße und auf weitere Hilfe hoffend,
    mm
     
  7. echt0711

    echt0711 MacUser Mitglied

    Beiträge:
    858
    Zustimmungen:
    12
    MacUser seit:
    11.10.2003
    mal ne blöde Frage… hast Du den FileServer Dienst eingeschaltet? :)
     
  8. mmakunga

    mmakunga Thread Starter MacUser Mitglied

    Beiträge:
    18
    Zustimmungen:
    0
    MacUser seit:
    05.07.2004
    Hi echt0711,

    AFP arbeitet und läuft... aber leider ohne mich :rolleyes:

    Schöne Grüße in den Süden aus dem verregneten Norden,
    mm
     
  9. mmakunga

    mmakunga Thread Starter MacUser Mitglied

    Beiträge:
    18
    Zustimmungen:
    0
    MacUser seit:
    05.07.2004
    Lösung gefunden...

    Falls jemand diesen Fehler auch hat, kann er hier nachlesen:

    http://www.info.apple.com/kbnum/n107695

    Kurzfassung: Bei AFP mit automount darf der Pfad zum neuen Home nicht über 89 Zeichen lang sein... :rolleyes: Da hätte man natürlich auch selbst drauf kommen müssen... :(

    Vielen Dank für Eure Versuche, mir zu helfen.
    mm
     
  10. echt0711

    echt0711 MacUser Mitglied

    Beiträge:
    858
    Zustimmungen:
    12
    MacUser seit:
    11.10.2003
    Eieiei… das ist ne interessante Information! Ein Hinweis auf dieses Limit sollte Apple vielleicht mal irgendwo im OS verankern oder per Error abfangen - sonst kann man ja lange suchen :)
     
Die Seite wird geladen...