Probleme auf Intel-Maschinen mit Applescript Studio Programm

Diskutiere mit über: Probleme auf Intel-Maschinen mit Applescript Studio Programm im Mac OS X Entwickler, Programmierer Forum

  1. hoschy07

    hoschy07 Thread Starter MacUser Mitglied

    Beiträge:
    204
    Zustimmungen:
    5
    Registriert seit:
    12.05.2004
    Hallo!

    Ich habe ein sehr seltsames Problem. Ein Applescript Studio-Programm funktioniert auf PPC einwandfrei, allerdings kommt es unter Intel zu Abstürzen.

    Das Programm habe ich als Universal Binary mit XCode kompiliert.

    Da ich selbst leider nur einen PPC zur Verfügung habe, stellt sich die Fehlersuche als sehr mühsam dar.

    Ich weiß leider nicht wo ich ansetzen kann. Gibt es bekannte Probleme, die mit Applescript-Applikationen auf den Intel-Macs auftreten können?

    Über Hilfe wäre ich sehr dankbar.

    Schöne Grüße, hoschy07.
     
  2. below

    below MacUser Mitglied

    Beiträge:
    13.882
    Zustimmungen:
    1.086
    Registriert seit:
    15.03.2004
    Bekannte Probleme gibt es nicht. Du solltest versuchen, den abstürzenden Teil zu isolieren, und isoliert auf PPC und Intel debuggen

    Alex
     
  3. MacTuX

    MacTuX MacUser Mitglied

    Beiträge:
    347
    Zustimmungen:
    4
    Registriert seit:
    11.02.2002
    Stürzt das Programm schon beim Start einfach ab? Was steht in der Konsole?

    Es kann sein, dass du in den Build Einstellungen die Option "ZeroLink" noch an hast. Dann läuft das Programm nur auf dem Entwicklungsrechner richtig. Das hat den Vorteil, dass das Programm schneller compiled, aber für den Release muss man das Ausmachen, bzw. die Konfiguration "Release" wählen. Da ist das dann auch ausgeschaltet.

    Grüße Markus
     
  4. hoschy07

    hoschy07 Thread Starter MacUser Mitglied

    Beiträge:
    204
    Zustimmungen:
    5
    Registriert seit:
    12.05.2004
    Hallo und danke für die Antworten.
    ZeroLink ist deaktiviert, da ich "Release" als Build gewählt habe.
    Ich habe von den Usern ein Crash-Log zugeschickt bekommen, allerdings werde ich daraus nicht richtig schlau.
    Das Programm stürzt nicht gleich am Anfang ab, sondern erst in bestimmten Funktionen. Allerdings kann ich dort definitiv keinen Fehler finden, deswegen war ich ja der Meinungen, dass evtl. dieses Problem nur unter Intel auftritt.
    Inwiefern Isolieren? Nicht als UB kompilieren?

    Ich wäre auch sehr dankbar zu wissen, wie ich es am besten debugge.

    Danke für Eure Hilfe.

    hoschy07
     
  5. below

    below MacUser Mitglied

    Beiträge:
    13.882
    Zustimmungen:
    1.086
    Registriert seit:
    15.03.2004
    Hast Du einen Intel Mac, auf dem Du das Problem reproduzieren kannst? Was sagt der Stack Trace?

    Alex
     
  6. hoschy07

    hoschy07 Thread Starter MacUser Mitglied

    Beiträge:
    204
    Zustimmungen:
    5
    Registriert seit:
    12.05.2004
    Also ich habe soeben von einem Tester die Mitteilung bekommen, dass die Anwendung, wenn er sie unter Rosetta startet funktioniert. Also scheint das Problem nur aufzutreten, wenn das Programm nativ läuft.

    Wie funktioniert das mit Stack Trace? Ich muss irgendwie versuchen, an einen Intel-Mac zum selbst testen zu gelangen.
     
Die Seite wird geladen...
Ähnliche Themen - Probleme auf Intel Forum Datum
Probleme beim bauen von "fontconfig" Mac OS X Entwickler, Programmierer 23.11.2016
An die App-Programmier - eure Erfahrungen, Probleme, gescheiterten Projekte... Mac OS X Entwickler, Programmierer 01.06.2016
Performance Probleme bei UITableView (Grouped) auf iPhone Mac OS X Entwickler, Programmierer 06.09.2009
Probleme mit C++ auf 10.4 Mac OS X Entwickler, Programmierer 11.01.2008
Probleme mit xCode - update auf 1.5 nicht möglich und gcc funktioniert nicht Mac OS X Entwickler, Programmierer 08.11.2004

Diese Seite empfehlen

Benutzerdefinierte Suche