Problem mit SDL

Dieses Thema im Forum "Mac OS X - Unix & Terminal" wurde erstellt von Ranmaru, 07.01.2007.

  1. Ranmaru

    Ranmaru Thread Starter MacUser Mitglied

    Beiträge:
    765
    Zustimmungen:
    29
    MacUser seit:
    08.10.2005
    Moin,

    ich versuche zur Zeit, ein Programm von den Quellen zu kompilieren, weil es keine native OS X Binaries gibt. Mein Problem ist, daß ich beim ./configure immer folgende Meldung kriege:
    Code:
    checking for SDL - version >= 1.2.0... no
    *** Could not run SDL test program, checking why...
    *** The test program failed to compile or link. See the file config.log for the
    *** exact error that occured. This usually means SDL was incorrectly installed
    *** or that you have moved SDL since it was installed. In the latter case, you
    *** may want to edit the sdl-config script: /sw/bin/sdl-config
    Ich habe SDL 1.2.9 über Fink installiert und sdl-config --version spuckt auch 1.2.9 aus, trotzdem scheint das nicht korrekt erkannt zu werden. Dann habe ich aus Frust direkt nochmal die Quellen von der SDL-Homepage runtergeladen, und Version 1.2.39 selber kompiliert und installiert … funktioniert aber immer noch nicht.

    Kann mir wer sagen, woran das liegt? Die SDL_CONFIG Variable ist definitiv korrekt im .profile eingetragen, daran hatte ich auch zuerst gedacht. :confused:
     
  2. der_Kay

    der_Kay MacUser Mitglied

    Beiträge:
    1.693
    Zustimmungen:
    7
    MacUser seit:
    02.09.2004
    Was steht denn in "config.log"?
     
  3. Ranmaru

    Ranmaru Thread Starter MacUser Mitglied

    Beiträge:
    765
    Zustimmungen:
    29
    MacUser seit:
    08.10.2005
    Code:
    configure:3481: checking for sdl-config
    configure:3499: found /sw/bin/sdl-config
    configure:3512: result: /sw/bin/sdl-config
    configure:3521: checking for SDL - version >= 1.2.0
    configure:3618: gcc -o conftest  -pipe -I. -I/usr/local/include -I/usr/include -D__UNIXSDL__ -D__MACOSX__ -D__OPENGL__ -arch i386 -mdynamic-no-pic -mstackrealign -I/sw/include/SDL -D_THREAD_SAFE   -L/usr/local/lib -L/usr/lib -framework Carbon -framework IOKit -framework Foundation -framework OpenGL -mdynamic-no-pic -read_only_relocs suppress -undefined dynamic_lookup conftest.c  -L/sw/lib -lSDLmain -lSDL -framework Cocoa -framework OpenGL >&5
    gcc: installation problem, cannot exec 'i686-apple-darwin8-gcc-4.0.0': No such file or directory
    configure:3621: $? = 255
    configure: program exited with status 255
    configure: failed program was:
    | /* confdefs.h.  */
    | #define PACKAGE_NAME ""
    | #define PACKAGE_TARNAME ""
    | #define PACKAGE_VERSION ""
    | #define PACKAGE_STRING ""
    | #define PACKAGE_BUGREPORT ""
    | /* end confdefs.h.  */
    Liegt's etwa am GCC? Wobei ich mich gerade frage, wieso der einen x86-GCC haben will. o_O
     
Die Seite wird geladen...