Problem mit mod_rewrite

Diskutiere mit über: Problem mit mod_rewrite im Web-Programmierung Forum

  1. thewalrus

    thewalrus Thread Starter MacUser Mitglied

    Beiträge:
    412
    Zustimmungen:
    0
    Registriert seit:
    16.02.2004
    Eigentlich das falsche Forum, aber woanders passt es auch nicht so recht.

    Ich habe bei mir in der .htaccess folgende Regel:

    RedirectMatch ^(.*)\.jpg$ /image.php?name=$1 [QSA]

    Alle Aufrufe von JPG-Dateien sollen auf die image.php umgeleitet werden, die das betreffende Bild dann von einer anderen Quelle holt. Hat seine Gründe warum ich das so mache.

    An sich funktioniert das auch so, allerdings macht der Server aus dem Fragezeichen in der URL "%3f", was zu einer Fehlermeldung führt.
    (z.B: http://www.server.de/image.php?name=blah.jpg)

    Wie bekomme ich es hin dass im URI ein Fragezeichen steht? Hat jemand da eine Idee? Danke.
     
  2. thewalrus

    thewalrus Thread Starter MacUser Mitglied

    Beiträge:
    412
    Zustimmungen:
    0
    Registriert seit:
    16.02.2004
    OK, hat sich schon erledigt. Ich machs lieber so:

    RewriteRule (.*)\.(jpg|jpeg|gif|png)$ image.php?name=$1 [NC]

    Hat zudem den Vorteil dass der Besucher nicht merkt dass er umgeleitet wurde *eg*
     
Die Seite wird geladen...
Ähnliche Themen - Problem mod_rewrite Forum Datum
XAMPP Problem mit Zugriffsrechte Web-Programmierung 30.04.2014
Syntax Problem PHP Variable an JS-Funktion Web-Programmierung 12.09.2013
Problem mit mod_rewrite und Authentifiziereung Web-Programmierung 28.12.2012
mod_rewrite-Problem mit neuem Server Web-Programmierung 04.12.2007
Apache 1.3.33 + mod_rewrite + .htaccess = Problem Web-Programmierung 27.09.2007

Diese Seite empfehlen

Benutzerdefinierte Suche