OS 10.3: Programme hängen, Runterfahren geht nicht

Dieses Thema im Forum "Mac OS X" wurde erstellt von Arnulf, 20.01.2005.

  1. Arnulf

    Arnulf Thread Starter MacUser Mitglied

    Beiträge:
    32
    Zustimmungen:
    0
    MacUser seit:
    20.01.2005
    Hi Leute!

    Vorweg muss ich erstmal sagen, dass ich selbst nicht MacUser bin. Ich werde nur als Helfer in der Not geholt wenn irgendwie nichts mehr geht. Selbst habe ich bisher nur Windows und Linux benutzt... der mac mini ist allerdings schon fast bestellt (gekauft wird er definitiv).

    Jetzt habe ich aber erstmal nen anderes Problem: Ich hab hier nen G4 Mac mit OS X 10.3 rumstehen und der hat leider ein kleines bis mittleres Problemchen. Zunächst mal zum kleineren Problem:
    In das Ding wurde ein NEC DVD-Brenner eingebaut und dieser wurde mit Patchburn zum Laufen gebracht. So weit so gut. Leider kommt nun folgendes vor:
    Wenn man eine CD reinlegt wird diese korrekt erkannt und ist auch lesbar. Wenn man sie allerdings längere Zeit im Laufwerk lässt (laut Beobachtungen des Benutzers > 10 Minuten) und danach versucht drauf zuzugreifen, dann kommt eine Meldung wie "Die angegebene Resource ist nicht mehr verwendbar" (ich weiß den Wortlaut leider nicht mehr, der Sinn dürfte aber in etwa hinkommen). Wenn man nun versucht per Tastatur die CD auszuwerfen, dann passiert genau nichts. Auch ein Druck auf den Taster am Laufwerk bringt nichts.
    In der Prozessliste sehe ich, dass der umount-Prozess noch läuft... nur ein Neustart behebt das Problem.

    Was kann man hier machen? Liegt es am Brenner bzw. an der fehlenden, offiziellen Unterstützung? Hilft eventuell nen Update der Brennerfirmware?


    Jetzt zum deutlich ärgerlicheren Problem: Auf dem Rechner werden unter anderem Freehand, Photoshop und InDesign verwendet. Nach einiger Zeit der Arbeit an diesem Rechner ist es dann plötzlich so, dass sich kein Programm mehr aufrufen lässt (gilt auch für iCal und sowas). Wenn man es im Dock anklickt, dann hüpft es lustig rum, aber mehr passiert dann nicht. Nach und nach passiert das dann mit allen Programmen, dies lässt sich dann nur noch durch einen Neustart beheben.
    Ich habe jetzt rausgefunden (nach einem Tipp hier im Forum), dass das Entfernen des Library-Ordners (der des jeweiligen Benutzers) hier kurzzeitig Besserung bringt. Allerdings passiert es dann irgendwann wieder... mal früher mal später, so richtig reproduzierbar scheint das ganze nicht zu sein.
    Nach einem Neustart gehts dann erstmal wieder... aber halt auch nicht ewig. Vorhin habe ich mal ne Weile die ganzen Programme gestartet und nebenbei geSafariT, doch da passierte es nicht. Als ich dann noch etwas hin und her bastelte passierte es dann plötzlich, leider musste ich dann aber weg.
    Es hat jemand vermutet, dass es mit nachträglich installierten Schriften zu tun haben könnte. Außerdem hat der Rechner nen Grafiktablett mit entsprechender, laufender Software und einen Epson Scanner.

    Eine Rechtereparatur mit dem Festplattendienstprogramm habe ich schon versucht und irgendwie hat es das nicht gebracht.

    Was passiert, wenn man den Library-Ordner auf der obersten Ebene der Festplatte löscht? Startet das System dann überhaupt noch? Da gibts außerdem noch einen dritten Library Ordner, mir ist nur leider gerade entfallen wo... wie siehts mit dem aus?


    Das schlimmste: Meistens lässt sich der Rechner nach dem Auftreten einer der beiden obigen Probleme nicht mehr runterfahren. Dazu kommt noch, dass der Besitzer des Macs beteuert, dass auch eine Neuinstallation von OS X nichts geändert hätte. Der schnelle Test mit der Apple Hardware Test CD hat keinerlei Fehler gefunden.

    Danke euch schonmal für die Tipps,


    Arnulf
     
  2. H.Stony

    H.Stony MacUser Mitglied

    Beiträge:
    552
    Zustimmungen:
    0
    MacUser seit:
    27.03.2004
    PRAM reset (apfel alt p und r), und ram test machen...update von apple ziehen...was für ein rechner ist es? was für ein 10.3? osX neu drüberinstallieren falls nicht hilft
     
  3. ratti

    ratti MacUser Mitglied

    Beiträge:
    1.515
    Zustimmungen:
    56
    MacUser seit:
    09.05.2004
    Utilitities -> Konsole -> Logbücher durchblättern -> Fehlermeldung sehen -> Googeln.


    Von "Fremdbrennern" in Macs kann ich nur abraten.
     
  4. G4Wallstreet

    G4Wallstreet MacUser Mitglied

    Beiträge:
    1.595
    Zustimmungen:
    37
    MacUser seit:
    08.01.2004
    So ciel ahnung wie Ihr habt - neuinstallation.
     
  5. Andi

    Andi MacUser Mitglied

    Beiträge:
    7.842
    Zustimmungen:
    653
    MacUser seit:
    16.05.2002
    ...

    Hallo Arnulf,

    G4 Macs gibts in den verschiedensten Ausführungen. Im Apfelmenü links oben gibt es einen Menüpunkt "Über diesen Mac". Dort erhälst Du Informationen über das Gerät. Der Button "Weitere Informationen" Startet den System Profiler. Dort kannst Du unter Hardware sehen, welche Boot-ROM-Version installiert ist. Ich sag mal so ne Art BIOS. Diese Firmware wird manchmal aktualisiert. Bei vielen G4 bzw. G3 wurde das unter OS 9.1 aktualisiert. Hat man das versäumt und OS X installiert, kann es zu ganz unangenehmen Überraschungen kommen. Dort könnte der Fehler liegen. Poste mal die Angaben.

    Zum Brenner: Wie ist der gejumpert? Ältere Macs können kein Cable Select. Da muss auf Master gejumpert werden. Ich glaube ab den MDD G4 geht auch Cable Select.

    Zur Library: Erst mal Finger Weg von der /Library und von der /System/Library erst recht. Die Voreinstellungen der Programme werden in /User/Library/Preferences gespeichert. Jedes Programm legt eine eigene Datei an, die auf .plist endet. Man kann relativ einfach die betreffende Datei finden, da sie sinnig benannt ist. In der User Library sind auch die Mails usw. gespeichert! Also Lieber nur in Preferences etwas Löschen.

    Das Nichtstarten deutet schon auf ein Prefences bzw. Rechteproblem hin. Rechte eventuell auch mal von der CD/DVD reparieren und die Festplatte überprüfen.

    Schriften: Eine defekte Schrift ist so schlimm wie ein Virus!

    Programme beenden: Alt-Apfel-Esc gemeinsam drücken. Damit kannst Du Programme die nicht reagieren sofort killen.

    Neuinstallation: Meistens nicht nötig! Einfach den letzten Comboinstaller (Servicepack) von Apple drüberbügeln. Und Software Aktualisierung starten um eventuell noch ein paar kleinere Updates nachladen.

    Die Caches und die Swapfiles (Virtual Memory) könnten auch den Fehler verursachen. Caches Findest Du /User/Library/Caches und System/Library/Caches. Die Swapfiles sind in /private/var/vm und können nur von root gelöscht werden.

    Der Tipp von ratti mit den Logfiles wird Dir bestimmt helfen den Fehler einzugrenzen.

    Norton! Norton ist auf einer CD bestens aufgehoben und nicht! auf der HD!

    Für alle Fälle noch ein Link:
    http://www.macosxhints.com/article.php?story=2004011205473937

    Gruß Andi
     
    Zuletzt von einem Moderator bearbeitet: 24.10.2015
  6. Arnulf

    Arnulf Thread Starter MacUser Mitglied

    Beiträge:
    32
    Zustimmungen:
    0
    MacUser seit:
    20.01.2005
    Hi!

    Also, danke erstmal für alle eure Antworten. Ich hab am Wochenende erstmal wieder ein wenig gebastelt, aber geholfen hat es alles nix.

    Zunächst mal zu den Daten des Rechners:
    Code:
    H a r d w a r e : 
    	H a r d w a r e - Ü b e r s i c h t : 
    
    	C o m p u t e r m o d e l l :   P o w e r   M a c   G 4 
    	C P U - T y p :   P o w e r P C   G 4     ( 2 . 1 ) 
    	A n z a h l   d e r   C P U s :   2 
    	C P U - G e s c h w i n d i g k e i t :   8 6 7   M H z 
    	L 2 - C a c h e   ( p r o   C P U ) :   2 5 6   K B 
    	L 3 - C a c h e   ( p r o   C P U ) :   1   M B 
    	S p e i c h e r :   1   G B 
    	B u s g e s c h w i n d i g k e i t :   1 3 3   M H z 
    	B o o t - R O M - V e r s i o n :   4 . 4 . 8 f 2 
    
    S o f t w a r e : 
             Ü b e r b l i c k   ü b e r   d i e   S y s t e m s o f t w a r e : 
                 S y s t e m v e r s i o n :   M a c   O S   X   1 0 . 3 . 7   ( 7 S 2 1 5 ) 
                 K e r n e l - V e r s i o n :   D a r w i n   7 . 7 . 0 
                 S t a r t v o l u m e :   G 4   M e g a M a c 
    
    (Sorry, dass es so hässlich aussieht)

    Das ist der G4 Mac mit den verspiegelten Laufwerksblenden.



    So weit so gut. Am Wochenende habe ich also unter anderem eine Überprüfung der beiden Festplatten und eine Reparatur der Rechte auf beiden Platten gemacht. Beides hat keinerlei Veränderung gebracht, heute wurde wieder damit gearbeitet und die Programme machen wohl immernoch Probleme.

    Wo finde ich denn wohl den neusten "Comboinstaller" von Apple zum Drüberinstallieren?

    Außerdem habe ich (natürlich) diese Apple Hardwaretest-CD durchlaufen lassen. Keinerlei Fehler gefunden.

    @ratti: Den Tipp mit den Logfiles habe ich nicht (so genau) verstanden. Es gibt unter Programme -> Dienstprogramme -> Konsole eine Reihe von Logdateien (die die es halt auch unter Linux gibt), aber keine gibt da näheren Aufschluß über Fehler.

    Dazu fällt mir noch was auf: Wenn der Rechner anfängt Probleme zu machen, dann kann man das Terminal (Eingabeaufforderung) auch nicht mehr öffnen. Es startet zwar, ist dann aber nur ganz klein (quasi nur die Titelleiste und die auch nur knapp schmaler als der rote Knopf). Sie lässt sich nicht vergrößern und man kann damit allgemein auch recht wenig anfangen.

    Die neusten Softwareupdates sind übrigens gemacht, den PRAM habe ich resettet und das System ist 10.3.7.

    So weit, so schlecht, mit dem Brenner bin ich auch nicht wirklich weitergekommen. Es ist ein NEC 3500AG mit neuester, offizieller Firmware. Ich habe viel gegoogelt und der Brenner wird wohl eigentlich relativ erfolgreich von verschiedenen Macusern eingesetzt. Gejumpert war er übrigens tatsächlich auf Cable Select, ich hab das jetzt auf Master geändert, aber das hat leider keinerlei Besserung gebracht. Ist eventuell der Brenner kaputt (es scheint mir als würde er abstürzen) oder liegt es an Mac OS?
    Wenn er nicht aufgeht (und der umount-Prozess hängt), dann lässt sich übrigens auch per Druck auf dem am Gehäuse vorhanden Eject-Knopf nix mehr ändern.


    Hat noch einer nen Tipp oder sollte ich mich tatsächlich mal an der Neuinstallation von OS X versuchen? Was meint ihr?


    Danke schonmal!

    Arnulf
     
    Zuletzt bearbeitet: 24.01.2005
  7. nkonde

    nkonde MacUser Mitglied

    Beiträge:
    974
    Zustimmungen:
    6
    MacUser seit:
    25.11.2004
    ich bin in solchen dingen zwar nicht sehr versiert, habe jedoch schon die eine oder andere fehlersuche hinter mir.. ;)
    da also der brenner sowieso probleme macht, kannst du evtl. mal testen, ob er alleiniger verursacher aller probleme ist.
    also einfach mal abklemmen und rumtesten, oder den alten (sofern noch vorhanden einbaun)
    vielleicht hilfts ja... viel glück
     
  8. ratti

    ratti MacUser Mitglied

    Beiträge:
    1.515
    Zustimmungen:
    56
    MacUser seit:
    09.05.2004
    /var/log/system.log oder so. Wenn da natürlich nix drinsteht, is schiet...

    Schwierig...

    Du kanst mit "sudo su" root werden und mal versuchen, mit "lsof" aufzulisten, welcher Prozess noch an der CD rumnuckelt. Kombiniert mit "grep", versteht sich, wobei man den Suchbegriff wohl mal variieren müsste, nach Pfad bzw. Mediumname. Etwa so:

    lsof | grep -i "daten"

    ...wenn der Name der CD "daten" ist. Ein Substring reicht, "-i" sucht case-insensitiv.

    Nach deiner Fehlerbeschreibung würde ich allerdings befürchten, daß der Kernel selbst hängt. Typisch dafür wäre, daß selbst ein "kill -9 xxxx" (Für xxxx die ProzessID von umount) nicht in der Lage ist, diesen Prozess zu beenden. Dann ist Achterbahn, denn das sind absolute LowLevel-Funktionen, die da hängen.

    Gruß, Ratti
     
  9. Arnulf

    Arnulf Thread Starter MacUser Mitglied

    Beiträge:
    32
    Zustimmungen:
    0
    MacUser seit:
    20.01.2005
    Hi!

    Also die Probleme bestanden wohl auch schon vor Einbau des Brenners, ein Zusammenhang ist also eher unwahrscheinlich.

    Andi hat ja gesagt, dass eine kaputte Schriftart so schlimm wie ein Virus sei. Ist es vorstellbar, dass diese Art von Problemen durch eine kaputte Schrift verursacht werden? Meines Wissens nach werden auf diesem Rechner relativ regelmässig neue Schriftarten installiert und nach dem Löschen des Library-Verzeichnisses sind diese neuen Schriftarten auch weg, das würde also erklären, dass es hierbei zu einer Besserung kommt.

    Aber kann eine Schriftart wirklich derartige Probleme auslösen?


    Arnulf
     
  10. Arnulf

    Arnulf Thread Starter MacUser Mitglied

    Beiträge:
    32
    Zustimmungen:
    0
    MacUser seit:
    20.01.2005
    @ratti:

    Das letzte Mal als ich den Kill auf das umount versucht habe war ich "nur" normaler Benutzer und ich durfte es deshalb nicht. Aber bei nächster Gelegenheit werde ich es auf jeden Fall mal versuchen, was dann passiert.

    Danke schonmal.


    Arnulf
     
Die Seite wird geladen...

Diese Seite empfehlen