NFS-Verbindung elend lahm!

Dieses Thema im Forum "Mac OS X" wurde erstellt von sewulba, 01.01.2006.

  1. sewulba

    sewulba Thread Starter MacUser Mitglied

    Beiträge:
    122
    Zustimmungen:
    0
    MacUser seit:
    18.10.2005
    Hallo...

    Ich habe von meinem MacOS X Tiger auf meinen Gentoo Linux Xeon Server eine NFS-Verbindung gemacht und wollte Daten übertragen.
    Wenn ich vom Mac auf dem Server per Samba Daten übertrage bekomme ich einen Durchsatz von mindestens 14MB/s (dann ist es verhältnismäßig schon lahm).
    Übertrage ich Daten per NFS komm ich auf höchtens 300kB/s. Das sonderbare daran ist, dass wenn ich unter Linux das mache bekomm ich dann auch mindestens 10MB/s an Speed zusammen! :rolleyes:
    Wie bekomm ich unter Tiger die NFS-Verbindung schneller (der NFS-Server auf der Gentoo-Kiste läuft auf jedenfall einwandfrei; Auf keinen der beiden Computer bekomm ich mehr CPU-Last als 2%. Daran liegt es auf jeden Fall auch nicht).
    Hat jemand von Euch eine Lösung für mein Problem? Möchte das, was ich per NFS mache nicht per Samba tun. Muss ja auch unter MacOS gut gehen, oder doch nicht?

    Sewulba
     
  2. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.831
    Zustimmungen:
    3.633
    MacUser seit:
    23.11.2004
    vielleicht hilft hier auch das ausschalten von dem delayed_ack..
    sudo sysctl -w net.inet.tcp.delayed_ack=0
     
  3. sewulba

    sewulba Thread Starter MacUser Mitglied

    Beiträge:
    122
    Zustimmungen:
    0
    MacUser seit:
    18.10.2005
    Nein... Das hat leider überhaupt nichts gebracht!!! :(
     
  4. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.831
    Zustimmungen:
    3.633
    MacUser seit:
    23.11.2004
    dann probier doch mal die tipps von hier:
    [DLMURL]http://nfs.sourceforge.net/nfs-howto/performance.html[/DLMURL]
    [DLMURL]http://www.macosxhints.com/article.php?story=20030504042711312&query=nfs[/DLMURL]
     
  5. sewulba

    sewulba Thread Starter MacUser Mitglied

    Beiträge:
    122
    Zustimmungen:
    0
    MacUser seit:
    18.10.2005
    Ich habe alles ausprobiert!!! Der Tip mit NFSIOD hatte mir eingeleuchtet. Also habe ich auch diesen Tip bis 16 ausgereizt. Es ändert sich einfach nichts am Durchsatz!!! kopfkratz
    So langsam zweifle ich an mir selbst!!! :rolleyes:

    Sewulba
     
  6. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.831
    Zustimmungen:
    3.633
    MacUser seit:
    23.11.2004
    vielleicht vertragen sich die eingesetzten nfs versionen nicht besonders?
    es gibt da noch andere zusätzliche sysctl tweaks zum tunen, google mal danach...
     
  7. sewulba

    sewulba Thread Starter MacUser Mitglied

    Beiträge:
    122
    Zustimmungen:
    0
    MacUser seit:
    18.10.2005
    Werde ich machen! :) Danke dir!!! :D

    Sewulba
     
  8. sleight

    sleight MacUser Mitglied

    Beiträge:
    3.233
    Medien:
    10
    Zustimmungen:
    295
    MacUser seit:
    27.05.2007
    ich häng mich hier mal hinten an.

    Ich habe das gleiche Problem, schreibzugriff ist ok, aber lesend ist es elendig langsam, 50MB auf mein NAS kopieren braucht 20min.

    Ich hab auch gegoogelt und d sobald ich den prozess nfsiod kille läuft alles wie geschmiert...

    Aber eigentlich will ich ungern irgendwelche systemprozesse beenden, vor allem nicht weil ich das bei jedem neustart machen muss...

    edit: also der prozess scheint ja alles andere als wichtig zu sein, kann mir jemand helfen, wie ich verhindere das er gestartet wird?
     
    Zuletzt bearbeitet: 03.06.2007
Die Seite wird geladen...