NFS mount mit dbox 2.0 Image nicht möglich

Dieses Thema im Forum "Multimedia Allgemein" wurde erstellt von lomus, 28.04.2006.

  1. lomus

    lomus Thread Starter MacUser Mitglied

    Beiträge:
    5
    Zustimmungen:
    0
    MacUser seit:
    18.03.2006
    Hallo zusammen,

    ich habe das "MD-Image on your Philips D-BOX2 - Kernel 2.4.31-dbox2" vom 7.3.2006 (glaube ich...) installiert und bin soweit zufrieden. (entspricht Neutrino 2.0 glaube ich).
    Ich nutze Neutrino und kann auch auf meinem Mac streamen (dbox-TV mit sserver) - läuft sehr gut.

    Probleme habe ich allerdings damit, per NFS eine Freigabe vom Mac zu mounten (Mac 10.4.6 Tiger). Das mounten funktioniert schlicht und einfach nicht. Wenn ich per telnet manuell z.B. mit mount -t nfs 192.168.1.25:/Volumes/Freigabe /mnt versuche, passiert nach ENTER gar nichts und ich kann bis zum nächsten Tag warten.

    Bevor mich jemand für einen Anfänger hält...: Ich habe die Mac-Freigaben schon von verschiedenen Linux Clients (SuSE) an verschiedenen Router-Ports mit Kernel 2.4x und 2.6x getestet: JEDESMAL erfolgreich - einzig die dbox will nicht! Sogar mit der Option vers=3 usw. habe ich herumprobiert.

    Was ist am MD-Image bzw. YADI anders? Ich hatte vorher schonmal eine YADI-Version 1.10.irgendwas mit dem gleichen Problem.


    Googlen in macuser-Foren, Apple-Support und tuxboxmeetsmac haben mir leider nicht weitergeholfen. Aus Mac- und Linux-Sicht ist ja auch alles in Ordnung...


    HELP!
     
  2. hanop

    hanop MacUser Mitglied

    Beiträge:
    26
    Zustimmungen:
    0
    MacUser seit:
    10.08.2001
    Hoffe das ich es richtig verstanden habe, den

    ich habe seit kurzem Dbox und NFS in gebrauch, aber unter Mac 10.4 ist es nicht mehr dasselbe mit NFS Freigaben und schon gar nicht wie Linux!
    Habe nach Koffler Linux Kochbuch gearbeitet und letzten endes mit dem NFS Manager von Bresink ca. 17Euro das ganze im Griff bekommen! Vielleicht isset ja ne Hilfe :D
     
  3. Horror

    Horror MacUser Mitglied

    Beiträge:
    1.416
    Zustimmungen:
    9
    MacUser seit:
    03.02.2003
    Also bei mir klappt das via Telnet nicht (kann ich auch ewig warten), über die GUI hingegen schon. Hast du die schon mal probiert (ging aus deinem Post nicht hervor)? Der NFS-Share scheint ja korrekt zu sein, wie du beschrieben hast…

    Dirk
     
  4. lomus

    lomus Thread Starter MacUser Mitglied

    Beiträge:
    5
    Zustimmungen:
    0
    MacUser seit:
    18.03.2006
    Ist gelöst

    Hallo,

    hatte das Problem gelöst:

    Man muß die Option -nolock verwenden, dann funktioniert es. Es dürfte im Übrigen ausreichen, wenn man die Datei /etc/exports erstellt. 'nen NFS-Manager braucht man dazu denke ich nicht.

    /Volumes/Data/Media/Video/dbox -alldirs -mapall=root 192.168.0.25 (rw,rsize=32768,wsize=32768,udp)

    unter Linux ist der Befehl dann einfach (wenn der Mac die Adresse 192.168.1.25 hat und an der dbox in's Verzeichnis /mnt/filme gemountet werden soll):

    mount -t nfs -o nolock 192.168.1.25:/Volumes/Data/Media/Video/dbox /mnt/filme
     
  5. Horror

    Horror MacUser Mitglied

    Beiträge:
    1.416
    Zustimmungen:
    9
    MacUser seit:
    03.02.2003
    Diese Option ist btw. auch im Mount-Dialog von der Neutrino-GUI angegeben ;) Habe ich aber zugegebenermaßen auch übersehen :rolleyes:

    Allerdings ;)

    Dirk
     
Die Seite wird geladen...