Netzwerkprobleme

Dieses Thema im Forum "Internet- und Netzwerk-Hardware" wurde erstellt von Dennis24, 05.02.2004.

  1. Dennis24

    Dennis24 Thread Starter MacUser Mitglied

    Beiträge:
    2
    Zustimmungen:
    0
    MacUser seit:
    05.02.2004
    Hallo Liste,

    habe Pobleme dem Netzwerk in unserer Firma. Wir (Großunternehmen) sind eine Art "Mac-Insel" in unserem Netzwerk. Soll heißen das es hauptsächlich PC´s in unserem Netzwerk gibt. Unser Problem ist nun folgendes (in Kurzform):
    Zwei unserer Mac´s kommen nicht korrekt (bezogen auf die Verbindungsgeschwindigkeit) ins Netz/ auf den Server. Dies sind Mac´s der Generation "Quicksilver" 933 MHz, OS 9.2.2. (Modell-Nr. M8493, lt. Rückseite des Mac´s)
    Wenn ich nun im Apple System Profiler in der Netzwerkübersicht nachschaue, dann habe ich nur bei den beiden Quicksilver-Mac´s den Verbindungstyp: 10 und Duplex: Halb. Bei den anderen Mac´s liegt diese Einstellung,dank autom. Geschwindigkeitserkennung vom Port (Switch), bei Typ:100, Duplex: Voll.

    Zur Austattung:

    - Mac´s: insgesamt 11 Stück
    - G4: 4 Mac´s Dual 1.25 GHz
    - G4: 3 Mac´s 400 MHz
    - G3: 2 Mac´s iMac+türkis G3
    - G4: 2 Mac´s 933 MHz "Quicksilver" (---> "Problemkinder" !)

    Habe außerdem gelesen wenn der Port am Switch nicht auf automatische Geschwindigkeitserkennung eingestellt ist, dann wird auch der Duplex-Modus einer Ethernet Verbindung zu einem Switch nicht erkannt. Der Mac erkennt zwar die korrekte Geschwindigkeit, arbeitet aber standardmäßig mit Halb-Duplex. Kann man dies irgendwie abändern!? Zur Info unser IT-Spezi hat aber alle(!) Port´s auf autom. Geschwindigkeitserkennung eingestellt!, Switch in unserem Rechenzentrum 100MBit. Wenn aber nun der Port am anderen Ende der Verbindung auf Voll-Duplex eingestellt ist, und der Rechner dies nicht erkennt, kommt es zu Verzögerungen bei der Datenübertragung. Leider kann ich nicht genau sagen welche Windows-Version auf den Server draufgespielt wurde! :(, muss leider noch genauer nachfragen!
    Habe im Internet zusätzlich fleißig recherchiert und ein Zusatztool von Apple gefunden: "Duplexer Tool" mit dem angeblich die Duplexeinstellung abgeändert werden kann, funktioniert bei uns aber nicht. Meine Frage also: Kann dies eventuell an den Netzwerkkarten liegen, also ein Hardware-Problem? Weil wir haben schon die vermeintlich "langsamen" Quicksilver an die "schnellen" Ports gehängt und es gab keine Änderung in der Geschwindigkeit! Gibt es irgendein Firmware-Update seitens Apple o.ä.?, bzw. wo kann ich herauslesen was für eine Netzwerkkarte mein Mac hat? Wie kann ich dieses Problem also lösen ? ? ? Meine Kollegen und ich wissen nicht mehr weiter! Kennt irgendjemand von euch dieses Problem?

    Gruß

    Dennis
     
  2. thomastr

    thomastr MacUser Mitglied

    Beiträge:
    45
    Zustimmungen:
    4
    MacUser seit:
    26.01.2004
    Hallo Dennis,

    das von Dir beschriebene Problem kommt in der IT Welt häufiger vor. Hintergrund dabei ist, dass falls die automatische Geschwindigkeitserkennung nicht funktioniert (d.h. Switch und Rechner erkennen sich gegenseitig nicht) auf die niedrigst mögliche Geschwindigkeit zurückgeschaltet wird. Das ist nunmal 10 MBit halfduplex. Hier liegt sozusagen eine inkombatibilität zwischen Ethernetkarte und Switch vor (dafür spricht aus, dass beide Quicksilver davon betroffen sind). Ein einseitiges ändern der Verbindungsparameter bringt hier gar nichts, und macht alles noch schlimmer. Wenn Du den Mac auf fullduplex (btw. in der Ethernetspezifikation ist 10Mbit fullduplex nicht so richtig definiert) stellst bekommt der Switch davon nichts mit und die Komunikation wird arg langsam. Aus meiner Sicht gibt es nur zwei Lösungsmöglichkeiten:
    Ihr lebt mit den 10Mbit halfduplex oder Ihr stellt am Mac und am Switch 100 Mbit fullduplex fest ein.
    Wie ich aber die Netzwerker in "Großunternehmen" so kenne, sind die Erfolgsaussichten da eher gering.

    Gruß

    Thomas
     
  3. Dennis24

    Dennis24 Thread Starter MacUser Mitglied

    Beiträge:
    2
    Zustimmungen:
    0
    MacUser seit:
    05.02.2004
    Hallo Thomas,

    hast Recht mit den "Netzwerkern/IT-Spezi´s". Haben uns aber auch schon überlegt jeweils morgens die benötigten Daten auf die Festplatte zu kopieren, um von ihr aus zu arbeiten und dann wieder abens auf den Server hochzuspielen! :( Blöde Lösung . . .
    Aber kann man trotzdem irgendwo herausfinden was für Netzwerkkarte die beiden Quicksilver-Mac´s haben?!
    Im Übrigen hat unser IT-Mensch, denn Switch meineswissens schon auf auto-negotiation eingestellt. Hat er zumindest gemeint.
    Naja danke für die Antwort, bin mal gespannt ob es noch andere da draußen gibt, die sich mit dem Problem auskennen und eventuell Lösungen wissen...
    Also an alle bitte melden ! ! !

    Grüße und schönes Wochenende

    Dennis
     
  4. Quicksilver1976

    Quicksilver1976 MacUser Mitglied

    Beiträge:
    433
    Zustimmungen:
    0
    MacUser seit:
    12.07.2002
    Hallo Dennis...

    Du schreibst soweit Du weist hat der Netzwerker den Port auf autosensing eingestellt. Bitte diesen netten Menschen doch mal den Port für einen der Problemkinder auf 100/full umzustellen. Dann stelle das auch am Quicksilver ein.

    Klappt die Verbindung? Besser wie vorher?

    Wenn ja dann erkläre das dem Netzwerker und lasse ihn die anderen Ports der Problemkinder auch umstellen.

    So wie Du das geschrieben hast beteiligt der sich ja an der Problemlösung und scheint auch gewillt zu sein nen Port umzustellen.
     
  5. thomastr

    thomastr MacUser Mitglied

    Beiträge:
    45
    Zustimmungen:
    4
    MacUser seit:
    26.01.2004
    Hallo Dennis,
    nun mal nicht gleich die ITler mit den Netzwerkern in einen Topf werfen :eek: Ich bin selber ein ITler und habe die gleiche Probleme mit den Netzwerker, die sich nicht gerne von anderen reinreden lassen.

    Wir hatten ein ähnliches Problem mit weit über 500 Sunrechner in einer Bank und konnten es nur lösen, indem auf beiden Seiten eine feste Einstellung vorgenommen haben.
    Autonegotiation heißt übrigens nicht, das der Switch automatisch die Einstellung der Gegenseite übernimmt, sondern das beim Verbindungsaufbau die zu verwendenden Parameter ausgehandelt werden. Dies funktioniert nur dann, wenn beide Teilnehmer am Aushandeln teilnehmen.

    Ich hätte da noch eine Idee: Falls die Netzwerker nicht mit sich reden lassen, könntet Ihr es ja mal mit dem Einbau einer zusätzlichen Ethernetkarte versuchen.

    Gruß

    Thomas
     
  6. F.Golchert

    F.Golchert MacUser Mitglied

    Beiträge:
    1
    Zustimmungen:
    0
    MacUser seit:
    17.02.2004
    Netzwerk-Probleme

    Hi, Dennis,

    so trifft man sich wieder. Genau wie Du auf der ständigen Suche nach Antworten.

    Kurzer Zwischenstand: Apple ist immer noch am forschen. Habe in einer Dokumentation einen Hinweis auf die Switcher-Konfiguration gefunden.
    Den sog. "span tree" deaktivieren, wozu auch immer der gut ist.

    Meine G4s und ebenso die G3-Rechner (alle 9.2.2 ) finden sich immer noch im im Netz und haben sich fürchterlich lieb.....nur gaaannnzzz langsam.

    Alle Rechner finden sich wie auch der Switch im 100MB Voll-Duplex wieder. Das funktioniert soweit.

    Auch 2 G4 über 1GB-Ethernet finden sich toll, nur nach wie vor ist in welcher Konfiguration auch immer der klassische AppleTalk-Betrieb nahezu doppelt so schnell wie über TCP/IP.
    Also ( Durchschnittswerte ) :
    Daten ( Platte/Platte) TCP/IP über AppleShare: etwa 1.000KB
    Daten ( Platte/Platte) AppleTalk : etwa 2.000KB
    Drucker TCP/IP über AppleShare: etwa 15.000KB

    Drucker im Netzwerk in beiden Fällen super. Selbst Datentransfer zu ner Dose ging problemlos.

    Apple erhält in den nächsten Tagen alle möglichen Daten von 2 Testrechnern, die mittlerweile nur noch das Betriebssystem haben mit den entsprechenden Messprotokollen. Man ist etwas ratlos,....ich auch.

    Habe in einem Forum ( aus etwa dem Jahre 2000 ) nur einen Hinweis gefunden, dass AppleShare die Bremse sein soll, aber leider auch sonst nix weiter.

    Mich würde interessieren, ob das Problem bei anderen Kollegen auch schon aufgetaucht ist, und ob das schon mal jemand unter OS X getestet hat mit z.B. Helios LanTest ?

    Muss doch möglich sein, mit ner 1GB Schnittschnelle einen halbwegs akzeptablen Datendurchsatz zu bekommen, der über dem 20 Jahre alten AppleTalk liegt.
    Nur der Form halber : Kabel und Hardware sind ok. Alle Rechner verfügen über die bekannten on-board-ethernet-slots.

    Gerne jederzeit Infos und Kommentare.


    Auf bald


    Frank Golchert
     
  7. phoenix2004

    phoenix2004 MacUser Mitglied

    Beiträge:
    691
    Zustimmungen:
    2
    MacUser seit:
    10.06.2005
    Hallo allerseits,

    darf ich diesen Uralt-Thread mal "nach vorn holen"? Habt Ihr seinerzeit eine Lösung gefunden?
    Kann ich 2 (oder mehr) Rechner, die alle 100MBit-Ethernet-Karten haben, "zwingen" mit dieser Geschwindigkeit zu kommunizieren?
    Momentan tun sei es bei automatischer Einstellung nur mit 10MBit/s.
     
  8. DieTa

    DieTa MacUser Mitglied

    Beiträge:
    3.278
    Zustimmungen:
    30
    MacUser seit:
    17.09.2003
    Du hast da bestimmt keinen Hi-End Switch, oder? :) Dann geh mal in die Systemeinstellungen -> Netzwerk -> Anzeigen "Ethernet" -> Tab "Ethernet" -> Konfiguaration "Manuell (Erweitert)" -> Geschwindigkeit "100baseTX" -> Duplex "Vollduplex".

    Das machste dann 1x bei jedem Mac im Netz.

    Frag mich nicht wie das mit den MTU's ist - die "Jumbo" Option von 9000 bekomme ich nicht eingestellt, lass es einfach auf 1500.

    Was für einen Switch setzt Du denn ein?
     
  9. phoenix2004

    phoenix2004 MacUser Mitglied

    Beiträge:
    691
    Zustimmungen:
    2
    MacUser seit:
    10.06.2005
    Hi DieTa,

    dank Dir, Du hattest mir schon gestern weitergeholfen.
    Ich war die Netzwerk-"Spralle" ;)

    Werd es mal probieren.
     
  10. DieTa

    DieTa MacUser Mitglied

    Beiträge:
    3.278
    Zustimmungen:
    30
    MacUser seit:
    17.09.2003
    :) Dann bin ich mal auf Dein Feedback gespannt. Bei mir war es in der Grafik vom Server eine gewaltige Kurve nach oben, nachdem ich das eingestellt hatte.
     
Die Seite wird geladen...

Diese Seite empfehlen