NAP und Xcode 2.2

Dieses Thema im Forum "Mac OS X" wurde erstellt von janosch, 27.12.2005.

  1. janosch

    janosch Thread Starter MacUser Mitglied

    Beiträge:
    1.298
    Zustimmungen:
    6
    MacUser seit:
    24.10.2003
    HI!

    Seiddem ich Xcdoe 2.2 auf meinem DP 2.0 GHz G5 installiert habe, funktioniert dieses Script nicht mehr:

    PHP:
    do shell script "hwprefs cpu_nap=false"
    Ich bekomme dann immer diese Meldung:

    [​IMG]



    Das Script hatte ich bis jetzt immer in den Startobjekten eines Normalen Users. Wie bekomme ich jetzt das Script wieder als normaler user zum Laufen? Was muss ich im Script ändern?

    Gibt es eine Möglichkeit den Befehl den ich oben im Script aufrufe auch als sudo auszuführen? Wie kann nich das Admin password dann im Script angeben so das ich nicht immer das Passwort für sudo angeben muss?
     
    Zuletzt bearbeitet: 27.12.2005
  2. k3rn3lpanic

    k3rn3lpanic MacUser Mitglied

    Beiträge:
    83
    Zustimmungen:
    0
    MacUser seit:
    05.04.2005
    Ich hab das ganze gerade Janosch schon ueber IM geschrieben, will euch das aber nicht vorenthalten:

    Die einfachste und soweit auch sicherste Variante ist, das ganze ueber sudo zu machen.
    Dazu macht man im Terminal ein schoenes "sudo vim /etc/sudoers" und schreibt ans Ende
    Code:
    %users   ALL = NOPASSWD: /usr/bin/hwprefs cpu_nap=false
    und schon kann das ganze jeder beliebige Nutzer machen, der Mitglied der Gruppe "users" ist, was eigentlich jeder sein sollte :D

    Schoenen Tach noch :)

    Edit: Hatte noch vergessen, dass das Script in
    Code:
    do shell script "sudo hwprefs cpu_nap=false"
    aendern muss :)
     
    Zuletzt bearbeitet: 27.12.2005
  3. janosch

    janosch Thread Starter MacUser Mitglied

    Beiträge:
    1.298
    Zustimmungen:
    6
    MacUser seit:
    24.10.2003
    Jupp, dem geht jetzt ^^THX nochmal
     
Die Seite wird geladen...

Diese Seite empfehlen