mysql Fehlermeldung

Diskutiere mit über: mysql Fehlermeldung im Datenbanksysteme für das Web Forum

  1. ThaHammer

    ThaHammer Thread Starter MacUser Mitglied

    Beiträge:
    3.276
    Zustimmungen:
    13
    Registriert seit:
    01.06.2004
    #1251 - Client does not support authentication protocol requested by server; consider upgrading MySQL client

    MYSQL und php laufen soweit. Nur wenn ich ein Passwort für meinen rootuser eintrage kommt bei phpmyadmin folgende Fehlermeldung.
     
  2. autoexec.bat

    autoexec.bat MacUser Mitglied

    Beiträge:
    2.130
    Zustimmungen:
    20
    Registriert seit:
    21.01.2005
    google machts möglich
     
  3. Incoming1983

    Incoming1983 MacUser Mitglied

    Beiträge:
    7.597
    Zustimmungen:
    1
    Registriert seit:
    23.07.2005
    Dein MySQL Client ist veraltet. Besorg dir einen aktuellen, oder downgrade dein dbms. Steht doch alles da ;-)
     
  4. ThaHammer

    ThaHammer Thread Starter MacUser Mitglied

    Beiträge:
    3.276
    Zustimmungen:
    13
    Registriert seit:
    01.06.2004
    Ich habe mysql 4.1.13 drauf ist das nicht die aktuellste?

    Das ist aber das Paket das ich für Tiger brauche.

    php 4.3.10
     
  5. ThaHammer

    ThaHammer Thread Starter MacUser Mitglied

    Beiträge:
    3.276
    Zustimmungen:
    13
    Registriert seit:
    01.06.2004
    Trotzdem Danke, das mit dem Old Passwort funktioniert nicht.

    Habe gesehen das meine Anleitung hier aus dem Forum sich auf mysql 4.1.11 bezieht. Was haben die von mysql geändert?
     
  6. Incoming1983

    Incoming1983 MacUser Mitglied

    Beiträge:
    7.597
    Zustimmungen:
    1
    Registriert seit:
    23.07.2005
    du mußt nicht den server, sondern den client upgraden, also deine php bibliothek..
     
  7. ThaHammer

    ThaHammer Thread Starter MacUser Mitglied

    Beiträge:
    3.276
    Zustimmungen:
    13
    Registriert seit:
    01.06.2004
    Du meinst eine neue php Version installieren als die die ich habe, oder wie muss ich das jetzt verstehen?

    Welche php Bibliothek? :(
     
  8. Incoming1983

    Incoming1983 MacUser Mitglied

    Beiträge:
    7.597
    Zustimmungen:
    1
    Registriert seit:
    23.07.2005
    php hat einen mysql connector. Und der kommt mit dem neuen mysql Server nicht klar. Ich kenn mich mit php nicht aus, aber den mußt du upgraden.
     
  9. ThaHammer

    ThaHammer Thread Starter MacUser Mitglied

    Beiträge:
    3.276
    Zustimmungen:
    13
    Registriert seit:
    01.06.2004
    Ich habe da auch keinen Plan! Nun gut solange ich keine Lösung kenne muss ich halt ohne Passwort auskommen. Hauptsache es funktioniert jetzt wieder.

    Danke für die Hilfe.
     
  10. echt0711

    echt0711 MacUser Mitglied

    Beiträge:
    858
    Zustimmungen:
    12
    Registriert seit:
    11.10.2003
    PHP Upgrade Problem! Bitte um schnelle Hilfe!

    Es geht darum:

    ===
    [1.17a] I cannot connect to the MySQL server. It always returns the error message, "Client does not support authentication protocol requested by server; consider upgrading MySQL client"
    You tried to access MySQL with an old MySQL client library. The version of your MySQL client library can be checked in your phpinfo() output. In general, it should have at least the same minor version as your server - as mentioned in FAQ 1.17.

    This problem is generally caused by using MySQL version 4.1 or newer. MySQL changed the authentication hash and your PHP is trying to use the old method. The proper solution is to use the mysqli extension with the proper client library to match your MySQL installation. Your chosen extension is specified in $cfg['Servers'][$i]['extension']. More information (and several workarounds) are located in the MySQL Documentation.
    ===

    Vor dem Problem stehe ich jetzt auch…*OS X Tiger 10.4.3 druff, eine mySQL mysql-standard-4.1.16-apple-darwin8.2.0-powerpc-64bit gezogen und per pkg installer alles draufgeworfen - und jetzt frage ich mich, ob ich PHP upgraden sollte...

    Ich weiß, daß es PHP zum komfortablen Nachinstallieren für OS X bei http://www2.entropy.ch/software/macosx/ gibt. Leider ist die Seite aktuell down, das bringt mich zu meinen beiden Fragen:

    1.) Wie kann ich das standardmässige PHP Version 4.3.11 upgraden, daß ich die richtige mySQL Library verwende, OHNE daß ich "Altdaten" auf meinem OS X liegen lasse. Ich bin kein Terminal Freak, eher Web Programmierer und weiß daher nicht, wie ich die alte PHP Version löschen kann ohne irgendwas kaputt zu machen.

    2.) Wo krieg ich ein aktuelles PHP her (möglichst komfortabel zu installieren bitte :D ), da die Website von entropy down ist. Dort habe ich letztes mal, als ich das gemacht habe eine sehr einfache Installationsmöglichkeit gefunden, bei der ich nicht groß im Terminal scripten musste.

    Die Library von http://de2.php.net/mysqli downzuloaden und manuell zu installieren traue ich mir nicht zu… ich bin gerade mal so weit daß ich in der php.ini, der httpd.conf und dem phpMyAdmin Config File so einigermaßen durchblicke…


    3.) Auch ein Downgrade von mySQL wäre für mich okay, solange meine alten PHP Scripts dann noch laufen :rolleyes: Keine Ahnung ob ich SQL4 Befehle verwende, ist alles so ein Halbwissen bei mir und noch viel Trial and Error, leider ;)
    Auch hier wäre die Frage: Wie krieg ich die eben installierte SQL 4 Version wieder weg vom System so daß nix durcheinander kommt?

    Hat einer einen Link please?

    Wär superklasse :) Würde echt gern heute Nacht noch phpmyadmin zum Laufen bekommen, damit ich morgen ein paar PHP Scripts lokal hier testen kann…
     
Die Seite wird geladen...
Ähnliche Themen - mysql Fehlermeldung Forum Datum
Mysql - Duplicates abfangen, mit php oder mit unique keys? Datenbanksysteme für das Web 08.03.2016
mysql abfrage optimieren Datenbanksysteme für das Web 26.03.2014
php - mysql_error != mysqli_error - mysql meldet Fehler, mysqli nicht Datenbanksysteme für das Web 05.07.2013
Fragen & Hilfe zu Projekt mit php & mySQL Integration Datenbanksysteme für das Web 01.07.2013
Fragen zu MySql Datenbanksysteme für das Web 04.03.2013

Diese Seite empfehlen