mysql Datenbank

Dieses Thema im Forum "Web-Programmierung" wurde erstellt von SLAPPER, 05.03.2004.

  1. SLAPPER

    SLAPPER Thread Starter MacUser Mitglied

    Beiträge:
    137
    Zustimmungen:
    0
    MacUser seit:
    04.03.2004
    hallo:))

    nun hab ich erfolgreich php installiert auf macosx Server und auch den mysqlAdmin ;)

    nun hab ich mal eine datenbank auch schon generiert damit

    aber wo finde ich die auf der Festplatte?? wo legt mysqladmin die ab??
    hab schon mit der konsole sämtliche verzeichnisse durchgewühlt - finde aber nix :confused:

    kann doch nicht so schwierig sein, odaaaa???

    will die DB ja später auch mal per ftp auf nen anderen server schicken...

    vielleicht kann mir schnell einer hier das sagen wo OSX das ablegt:)
    dankeeee
     
  2. HAL

    HAL Gast

    normalerweise im verzeichnis

    festplatte > library > mysql > var

    aber wenn du mit phpmyadmin arbeitest, ist es
    möglicherweise sinnvoller, die datensätze zu
    exportieren, und auf dem server im netz wieder
    zu importieren.
     
  3. SLAPPER

    SLAPPER Thread Starter MacUser Mitglied

    Beiträge:
    137
    Zustimmungen:
    0
    MacUser seit:
    04.03.2004
    danke Hal9500

    also da hab ich schon nachgeschaut da ist aber auch nix:(

    noch zur anmerkung, ich hab mysql nicht nachträglich installiert, sondern habe den mySQL-Manager unter MacOSX Server 10.2.8 gestartet

    der mySQL-Manager liegt unter Dienstprogrammen
    das mysql verzeichnis selbst find ich ja auch nicht:(
     
  4. SLAPPER

    SLAPPER Thread Starter MacUser Mitglied

    Beiträge:
    137
    Zustimmungen:
    0
    MacUser seit:
    04.03.2004
    noch was

    normalerweise müsste ich das ja ganz schnell finden mit "Apfel-F"
    da finde ich aber weder das mysql Verzeichnis (nur unter Startup-Items) noch die sql-Datenbank "test"

    anscheinend ist die Suchfunktion von Apple nicht gerade sehr leistungsstark:((

    hab mich schon als SU angemeldet, findet da auch nix:(
     
  5. lun_IX

    lun_IX MacUser Mitglied

    Beiträge:
    687
    Zustimmungen:
    8
    MacUser seit:
    03.11.2003
    probiers mal damit:

    PHP:
    sudo bash
    Adminpasswort eingeben

    PHP:
    find / -name "Datenbankname"
    wobei du natürlich die Anführungszeichen weglassen musst!

    Wenn du dich beim phpMyAdmin einloggen kannst, gibt es auch sicher eine Datenbank...du hast ja auch eine angelegt, deren Namen oben mal in den find Befehl einsetzen und dann sollte er es finden!

    Hast du beim Suchen auf Gross- und Kleinschreibung geachtet? OS X basiert ja auch Unix und damit sind sämtliche Dateien und Verzeichnisse case sensitiv (also auch der Datenbankname!).
     
  6. SLAPPER

    SLAPPER Thread Starter MacUser Mitglied

    Beiträge:
    137
    Zustimmungen:
    0
    MacUser seit:
    04.03.2004
    dankeeee

    danke Linux:))

    das war der richtige Hinweis von dir!
    übrigens hat das die normale konsole auch gemacht, musste nicht in die Bash wechseln:)

    er hat es gefunden im Verzeichnis:
    /private/var/mysql/testdb

    also kein wunder das ich es im Finder nicht sehe und gefunden habe

    die Verzeichnisse "/" werden ja nicht angezeigt im Finder:rolleyes:

    weist du zufällig den unix-befehl wie ich von dort die DB in ein sichtbares Verzeichnis kopieren kann? schliesslich will ich später per ftp die DB verschicken und muss auch per Finder darauf zugreifen können.

    danke dir clap
     
  7. lun_IX

    lun_IX MacUser Mitglied

    Beiträge:
    687
    Zustimmungen:
    8
    MacUser seit:
    03.11.2003
    hiho!

    schön, dass ich helfen konnte!
    Aber zum Export der daten würde ich die Export Funktion von mysql bzw. phpMyAdmin nutzen, dort kannst du von deinen Datenbanken/Tabellen sogenannte "dumps" erstellen, das sind Textdateien, wo sämtliche sql Befehle drin stehen, die du brauchst, um die tabelle mit genau den Einträgen auf einem anderen System zu erstellen.


    ansonsten hättest du auf der Konsole folgenden Befehl zu Verfügung:

    PHP:
    cp -/var/.../datenbank /volumes/deine partition/dein Verzeichnis
     
  8. SLAPPER

    SLAPPER Thread Starter MacUser Mitglied

    Beiträge:
    137
    Zustimmungen:
    0
    MacUser seit:
    04.03.2004
    hallo lunix:)

    du bist ja ein richtiger experte!
    das ging auch supi:)))))

    jetzt hab ich da noch ein kleines problem
    wenn ich den phpMyAdmin starte hab ich gleich auf dem StartupScreen unten eine Mega-Warnung in rot:

    Das $cfg['PmaAbsoluteUri']-Verzeichnis MUSS in Ihrer Konfigurationsdatei angegeben werden!

    Ihre Konfigurationsdatei enthält Einstellungen (Benutzer "root" ohne Passwort), welche denen des MySQL-Standardbenutzers entsprechen. Wird Ihr MySQL-Server mit diesen Einstellungen betrieben, so können Unbefugte leicht von außen auf ihn zugreifen. Sie sollten diese Sicherheitslücke unbedingt schließen!


    weist du wie ich die abstellen kann? scheint ja was ernsthaftes zu sein...

    merci schon mal carro
     
  9. lun_IX

    lun_IX MacUser Mitglied

    Beiträge:
    687
    Zustimmungen:
    8
    MacUser seit:
    03.11.2003
    hi!

    Zur ersten Meldung kann ich dir leider nix sagen, keine Ahnung!

    Aber die zweite heisst einfach, dass es in deiner Mysql Konfiguration einen Benutzer namens "root" gibt, der alle Rechte hat, aber kein Passwort.
    Das heisst, jeder kann von aussen (wenn der Rechner ohne Firewall im Internet ist) auf alle deine datenbanken über den root Benutzer zugreifen.

    Das kannst du auf der phpMyAdmin Startseite unter "Privileges" ändern! Den root solltest du mit einem guten Passwort versehen und dir selbst einen Benutzer mit für dich ausreichenden Rechten (auch mit gutem Passwort) anlegen und dich nur noch über den einloggen!

    Der root ohne passwort ist bei mysql standardmässig aktiv!
     
  10. SLAPPER

    SLAPPER Thread Starter MacUser Mitglied

    Beiträge:
    137
    Zustimmungen:
    0
    MacUser seit:
    04.03.2004
    hi

    danke:)

    jetzt hab ich die Warnung auch weg

    hab es allerdings anderst gemacht
    bei privileg hab ich erst ein paswort vergeben, dann konnte ich komischerweise den phpmyAdmin nicht mehr starten:((( ist wohl ein bug??

    nun hab ich aber die config.inc.php anschliessend geöffnet und
    die folgenden parameter geändert dann bin ich als root mit anmeldefenster wieder draufgekommen:))

    $cfg['Servers'][$i]['auth_type'] = 'http'; // Authentication method (config, http or cookie based)?
    $cfg['Servers'][$i]['user'] = 'root'; // MySQL user
    $cfg['Servers'][$i]['password'] = 'meinpasswort'

    nun funzt es

    die andere fehlmeldung konnte ich ebenfalls dort abstellen mit:

    $cfg['PmaAbsoluteUri'] = '/Applications/phpMyAdmin';

    nun kann ich ja mal was schaffe damit:))
    danke lunix
     
Die Seite wird geladen...

Diese Seite empfehlen