mount_smbfs / smbutil buggy?

Dieses Thema im Forum "Internet- und Netzwerk-Hardware" wurde erstellt von hannizkaos, 07.09.2004.

  1. hannizkaos

    hannizkaos Thread Starter MacUser Mitglied

    Beiträge:
    766
    Zustimmungen:
    1
    MacUser seit:
    31.07.2004
    Moin, moin,

    ich versuche mir grade ein Skript zu bauen, welches abhängig von einer bestimmten Umgebung smb-shares mountet, doch leider läuft das ganze nicht so rund.

    Ich habe rausgefunden, dass ich smbutil benutzen sollte, doch leider funktioniert der befehl 'login' nicht...

    Code:
    mkdir /Volumes/Test | smbutil -v login -N //192.168.1.1/daten /Volumes/Test
    ...und jeder andere Versuch smbutil mit dem Kommando login zu benutzen, ergibt:
    Code:
    smbutil: unknown command login
    Bin ich irgendwie blind? Was ist da los. Das Kommando wird mir angegeben und ich benutze es wie vorgegeben, aber es läuft nich!? :confused:

    Bitte um Hilfe...
     
    Zuletzt bearbeitet: 07.09.2004
  2. cla

    cla MacUser Mitglied

    Beiträge:
    2.958
    Zustimmungen:
    128
    MacUser seit:
    24.10.2003
    Ich kanns jetzt grad nicht ausprobieren, aber was sagt "man smbutil" zu den möglichen Parametern von smbutil?

    cla
     
  3. hannizkaos

    hannizkaos Thread Starter MacUser Mitglied

    Beiträge:
    766
    Zustimmungen:
    1
    MacUser seit:
    31.07.2004
    Manpage von smbutil
    Manpage von mount_smbfs

    Code:
    login [-connection options] //[workgroup;][user[password]@]
                 server[/share]
                 Login/attach to the specified server and/or share as user.  This
                 command will create and authenticate connection to an SMB server,
                 and will leave it active after exit.  Thus, one can login only
                 once and then use other SMB commands without authentication pro-
                 cedure and additional connections.  For the description of
                 [-connection options] see mount_smbfs(8) command (all uppercase
                 options are connection options).
     
    Zuletzt bearbeitet: 07.09.2004
  4. hannizkaos

    hannizkaos Thread Starter MacUser Mitglied

    Beiträge:
    766
    Zustimmungen:
    1
    MacUser seit:
    31.07.2004
    Um sicher zu gehen, ist es richtig, dass bei Verwendung von smbutil, der Finder mitbekommt, dass ein smb-share gemountet wurde?

    Code:
    mkdir /Volumes/test | mount_smbfs //192.168.1.1/daten /Volumes/test
    mountet den share, aber erzeugt keinen Eintrag im Finder...

    :confused: :(
     
  5. cla

    cla MacUser Mitglied

    Beiträge:
    2.958
    Zustimmungen:
    128
    MacUser seit:
    24.10.2003
    So...habs jetzt grad mal bei mir ausprobiert. Selbes Problem. Er meint, er würde "login" nicht kennen. Seltsam...

    Die Optionen stimmen sonst soweit mit deinen überein, bis darauf, das ich zusätzlich noch die Option "-I" verwende. Wenn man schon die IP angibt.

    Aber auch das hilft nicht. An Root-Rechten kanns auch nicht liegen, da mit "sudo" die selbe Meldung kommt.

    Jetzt bin ich selbst etwas am rätseln. Wie machts denn dann OS X?

    Vielleicht hat ja .ut oder maceis noch nen Tip?

    cla
     
  6. hannizkaos

    hannizkaos Thread Starter MacUser Mitglied

    Beiträge:
    766
    Zustimmungen:
    1
    MacUser seit:
    31.07.2004
    *LAUT RUF* :)
     
  7. ?=?

    ?=? MacUser Mitglied

    Beiträge:
    941
    Zustimmungen:
    14
    MacUser seit:
    09.02.2004
    Sorry, aber es scheint so zu sein, dass sowohl der "usage" Text als auch die man-page nicht zu smbutil passen:

    Mit etwas Googlen bin ich hierauf gestoßen . . .

    Das Verhalten von smbutil passt nach meinen Stichproben exakt zu dem Source, d.h. die Commands

    - lc
    - login
    - logout
    - print

    werden nicht unterstützt und "status" wird unterstützt.


    Gruß,

    ?=?
     
Die Seite wird geladen...
Ähnliche Themen - mount_smbfs smbutil buggy
  1. Eames
    Antworten:
    1
    Aufrufe:
    478

Diese Seite empfehlen