[mailto:] ... mit mehreren Adressen

Dieses Thema im Forum "Web Page Design" wurde erstellt von maceis, 08.03.2005.

  1. maceis

    maceis Thread Starter MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    Hallo zusammen,

    ich habe folgendes kleine Problem;

    ich möchte auf einer Webseite einen mailto:-Link einbauen, mit dem man eine Email an eine ganze Gruppe (rd. 20 Mailadressen) auf einmal versenden kann.

    Der normale Ansatz sieht so aus:
    <a href="mailto:name1@server1.de,name2@server2.de,name3@server3.de,[...],name20@server20.de">Link</a>

    So; von einem Windos-Rechner aus geht das. Mit dem internetExplorer[ääächz] geht es auch auf dem Mac.

    Nur im Zusammenspiel Safari <-> Mail gibt es erheblich Probleme.
    Die Email Adressen tauchen mehrmals hintereinander auf und sind "zerhauen"; es fehlen Teile der Adressen.

    Hat jemand das auch schon beobachtet?
    Kann man das umgehen?
     
  2. xlqr

    xlqr MacUser Mitglied

    Beiträge:
    1.943
    Zustimmungen:
    15
    MacUser seit:
    08.09.2003
    hast du im original ein leerzeichen hinter den kommata?
     
  3. maceis

    maceis Thread Starter MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    Ich hatte beide Variante probiert. Das macht keinen Unterschied, außer dass in der Safari Statusleiste die Leerzeichen mit "%20"-kodiert angezeigt werden.
     
  4. master_p

    master_p MacUser Mitglied

    Beiträge:
    1.065
    Zustimmungen:
    23
    MacUser seit:
    31.01.2005
    Also bei mir funktioniert es. Mit Safari und Entourage läuft es zumindest einwandfrei:

    Code:
    <A HREF="mailto:me@me.com,you@you.com">Maillink</A>
     
  5. xlqr

    xlqr MacUser Mitglied

    Beiträge:
    1.943
    Zustimmungen:
    15
    MacUser seit:
    08.09.2003
    eigenartig -

    ich habe gerade eine testsite gemacht und safari öffnet mail und die mails werden verschickt und kommen an.

    hier mal der source:

    hilft dir wahrscheinlich nicht weiter ...

    PHP:
    <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    <
    html>
    <
    head>
      <
    meta content="text/html; charset=ISO-8859-1"
     
    http-equiv="content-type">
      <
    title>test</title>
    </
    head>
    <
    body>
    <

    href
    ="mailto:info@xxxx.net,jeff@xxxx.de,test@xxxx.com">link</a>
    </
    body>
    </
    html>
     
  6. maceis

    maceis Thread Starter MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    Danke für Euren Einsatz.
    Inzwischen konnte ich das Problem lösen.
    Einer der Benutzer (ein Spassvogel) hatte anstelle einer "0" ein "ø" eingegeben.
    Nachdem ich das "ausgebügelt" hatte, war alles wieder okay.

    Danke nochmals und Grüße
     
  7. xlqr

    xlqr MacUser Mitglied

    Beiträge:
    1.943
    Zustimmungen:
    15
    MacUser seit:
    08.09.2003
    :D

    zehn zeichen
     
Die Seite wird geladen...
Ähnliche Themen - [mailto mehreren Adressen
  1. Eastwood
    Antworten:
    2
    Aufrufe:
    376
  2. teamoh
    Antworten:
    9
    Aufrufe:
    678

Diese Seite empfehlen