lokalen WebDav Server einrichten für ical

Dieses Thema im Forum "Mac OS X - Unix & Terminal" wurde erstellt von clae, 21.05.2005.

  1. clae

    clae Thread Starter MacUser Mitglied

    Beiträge:
    9
    Zustimmungen:
    0
    MacUser seit:
    10.05.2005
    Hallo Forum,
    (hier bin ich hoffentlich im richtigen)
    ich würde gerne in unserem Büro ical-Kalender veröffentlichen ohne mir .mac oder ähnliches einzurichten (ich alter sparfuchs). Nun habe ich im Archiv diese Forums (http://www.macuser.de/forum/archive/index.php/t-2944.html) eine Erklärung gefunden, wie so etwas funktionieren soll. Leider funktioniert das bei mir nicht. Ich finde die Datei httpd.conf nicht. Liegt das an einer neueren OS X Version (ich benutze 10.3)?
    es kann natürlich auch sein, dass ich einfach generell etwas falsch mache. Ich kenne mich mit Terminal überhaupt nicht aus. Sollte ich dann lieber die Finger von solchen versuchen lassen? Gibt es irgendeine benutzerfreundlichere Weise einen OSX Computer zum WebDav Server zu machen?
    Vielen Dank für Hilfe
    clae
     
    Zuletzt von einem Moderator bearbeitet: 13.03.2016
  2. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    Hallo clae,

    hier bist Du richtig.
    Dann wird es zumindest etwas schwieriger.
    Die Datei "httpd.conf" liegt in einem Verzeichnis, das im Finder unsichtbar ist.
    Normale Benutzer dürfen diese Datei auch nicht ändern.

    Villeicht könne wir das in den nächsten Tagen aber gemeinsam machen.
     
  3. pcdog

    pcdog MacUser Mitglied

    Beiträge:
    192
    Zustimmungen:
    2
    MacUser seit:
    12.03.2005
    werd ich wahrscheinlich morgen aktivieren (auf Linux, aber geht gleich)

    btw.. hat tiger apache1 oder 2?

    grüsse
    Silvan
    (poste dann n howto)
    (auf pcdog.ch laeuft es schon... aber weiss nimmer genau wie, hatte es für SVN gebraucht)
     
  4. clae

    clae Thread Starter MacUser Mitglied

    Beiträge:
    9
    Zustimmungen:
    0
    MacUser seit:
    10.05.2005
    Da währe ich Dir sehr dankbar.
     
  5. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    Wenn Du Dich gar nicht mit dem Terminal auskennst, würde ich vorschlagen, dass wir die Datei "httpd.conf" auf Deinen Schreibtisch kopieren, damit Du sie nicht im Terminal bearbeiten musst, sondern zumindest diesen Teil in TextEdit erledigen kannst.
    Vorher legen wir natürlich eine Sicherheitskopie an.

    Öffne dazu das Terminal und gib der Reihe nach folgende Kommandos ein.
    Du gibst dabei immer nur den blauen Teil des Anweisungen ein (den, der vor dem #-Zeichen steht);
    ab dem # gebe ich Dir nur ein paar Erklärungen, was Du da eigentlich gerade machst.

    Du musst als "admin"-Benutzer angemeldet sein.
    Wenn Du nach dem Passwort gefagt wirst, gibst Du es ein (Du siehst dabei nichts im terminalfenster).
    Jetzt geht es los (Terminal öffnen):

    cd /etc/httpd #damit wechselst Du in das Verzeichnis in dem die httpd.conf liegt.
    sudo cp httpd.conf httpd.conf.original # damit erstellst Du die Sicherheitskopie.
    # es folgt eine Passwortabfrage, bei der Du unsichtbar Dein Passwort eingibst und mit "enter" bestätigst.
    sudo cp httpd.conf ~/Desktop/httpd.conf.txt # damit erstellst Du eine Kopie auf dem Schreibtisch
    sudo chown ben ~/Desktop/httpd.conf.txt # anstelle von ben gibst du hier Deinen Benutzernamen ein und wirst damit zum Eigentümer der Datei

    -------------
    Jetzt nimmst Du in der Datei httpd.conf.txt, die Du auf dem Schreibtisch findest, mit Textedit die notwendigen Änderungen vor und speicherst diese ab.
    Dann gehts wieder im Terminal weiter:

    sudo cp ~/Desktop/httpd.conf.txt /etc/httpd/httpd.conf # zurückkopieren
    sudo chown root /etc/httpd/httpd.conf # Eigentümer wird wieder root
    apachectl configtest # Testen ob Syntaxfehler vorhanden sind
    sudo apachectl restart # Apache neu starten (nur wenn keine Fehler ausgegeben wurden; sonst startet Apache u. U. nicht mehr)
    --------------
    Mal bis hierher.
    Ich hoffe, Du komst soweit klar.
    Ansonsten -> Fragen!
    Es wäre sinnvoll, wenn Du Dir ein wenig mitschreibst, was Du alles änderst bzw. machst (z. B. auch, wo Du ggf. Verzeichnisse anlegst etc.), damit man bei Problemen einfacher kommunizieren kann.

    HTH
     
  6. clae

    clae Thread Starter MacUser Mitglied

    Beiträge:
    9
    Zustimmungen:
    0
    MacUser seit:
    10.05.2005
    Vielen Dank maceis, dass Du Die die Mühe gibst mir zu helfen.
    Es ging alles gut, bis zum kopieren auf den Schreibtisch.

    Danach erschien folgendes:
    cp {-R {-H / -P}} {-f / -i / -n) (-pv) src target
    cp {-R {-H / -P}} {-f / -i / -n) (-pv) src1 ... srcN directory
    (Die Klammern sollen eckig sein und die Striche senkrecht)
    ist das noch richtig?

    Danach (nach dem ich natürlich meinen Benutzernamen anstelle von Ben eingegeben habe) kam die Meldung No such file or directory
    auf dem Desktop liegt auch nix.
    Ich habe nochmal in /etc/httpd geschaut (das kann ich mittlerweile)
    cd /etc/httpd
    ls -a
    dort liegt die txt datei auch nicht mehr. wo ist sie hin?
     
  7. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    Das Kopieren ist fehlgeschlagen.
    Vermutlich hast Du die Kommandos abgetippt und einen Fehler gemacht (z. B. das Leerzeichen vor ~ vergessen).
    Copy und Paste wäre besser.
    Dass dann auch keine Datei auf dem Schreibtisch gefunden wird ("No such file or directory") ist klar.
    Versuchs einfach nochmal, und kopiere den Befehl mit Apfel-c und setze ihn mit Apfel-v im Terminal ein.

    HTH
     
  8. clae

    clae Thread Starter MacUser Mitglied

    Beiträge:
    9
    Zustimmungen:
    0
    MacUser seit:
    10.05.2005
    Wenn Es denn funktioniert habe ich noch ne Frage die ich schon mal vorweg schicke:

    im o.g. archiv Beitrag wird gesagt:

    dann zu den Zeilen mit mit
    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>

    und durch die Zeilen (aufpassen auf die beiden Zeilen darüber wichtig)
    DAVLockDB /usr/local/apache/var/DAVLock

    # lege ich damit einen Ordner an? und wenn ja wo? muss ich den Teil irgendwie auf meine Bedürfnisse anpassen?
    DAVMinTimeout 600
    <Directory />
    DAV On
    Options FollowSymLinks
    AllowOverride All
    </Directory>
    ersetzen.



    So, dann noch fix die Rechte setzen, 2 Ordner und 1 Datei erstellen
    chmod -R 777 /Library/WebServer/Documents
    cd /usr/local
    mkdir apache
    cd apache/
    mkdir var
    cd var/
    touch DAVLock
    cd ../../
    chmod -R 777 apache

    # Was für Rechte setzte ich da?
     
  9. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    Damit definiert man einen Ablageort, wo der DAV Server temporäre Dateien ablegen kann.
    Man kann das anpassen; empfehlen würde ich das aber erst, wenn Deine Anleitung (die ich übrigens nur schnell überflogen habe) funktioniert.
    Sonst verzettelst Du Dich vielleicht.

    Du setzt für alle Dateien, die unterhalb von "/usr/local/apache" liegen Vollzugriff für alle Benutzer.
    Man kann das so machen und für die Anfangskonfiguration ist es vielleicht nicht schlecht, da man so Rechte-Probleme von vorneherein ausschließt
    Wenn andere Leute Zugriff auf Deinen Rechner haben und die DAV Dateien nicht sehen sollen, kann man es auch anders einstellen.
    Würde ich aber erst dann machen, wenn alles läuft.
     
  10. clae

    clae Thread Starter MacUser Mitglied

    Beiträge:
    9
    Zustimmungen:
    0
    MacUser seit:
    10.05.2005
    So, jetzt hats geklappt. Wahrscheinlich tatsächlich etwas falsch geschrieben.
    Ich habe die Textdatei auf dem Desktop gelegt. Bearbeitet wie im archiv beschrieben. gespeichert und nach deiner Anleitung wieder zurück kopiert. rechte auf root gestellt. syntaxfehler-test durchgeführt und positive meldung bekommen und apache neu gestartet.
    Was nun?
     
Die Seite wird geladen...

Diese Seite empfehlen