Linux / Zusätzliche gemountete Partitionen - kein Zugriff

Dieses Thema im Forum "Linux auf dem Mac" wurde erstellt von unknown, 15.08.2006.

  1. unknown

    unknown Thread Starter MacUser Mitglied

    Beiträge:
    95
    Zustimmungen:
    0
    Registriert seit:
    02.06.2006
    Hallo Leute,

    ich hab nur noch ein Problem beim Zugriff auf meinen Linux-Rechner, zwei HDD's die ich jeweils als Partition in mein Home mit eingebunden habe. Der Zugriff auf das Home selbst funktioniert problemlos, lesen und schreiben. Auf die beiden anderen HDD's / Partitionen hab ich allerdings gar keinen Zugriff.

    Meine fstab:

    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    /dev/hda1       /               ext3    defaults,errors=remount-ro 0       1
    /dev/hda5       /home           ext3    defaults        0       2
    /dev/hdb5       /home/unknown/archiv/movie vfat  iocharset=utf8,umask=000  0    0
    /dev/hdc5       /home/unknown/archiv/mp3_hdd vfat  iocharset=utf8,umask=000  0    0
    /dev/hda6       none            swap    sw              0       0
    /dev/hdd        /media/cdrom0   udf,iso9660 user,noauto     0       0
    ebenfalls erfolglos getestet:

    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    /dev/hda1       /               ext3    defaults,errors=remount-ro 0       1
    /dev/hda5       /home           ext3    defaults        0       2
    /dev/hdb5       /home/unknown/archiv/movie vfat  iocharset=utf8,dev,suid,rw,exec,auto,user      0    0
    /dev/hdc5       /home/unknown/archiv/mp3_hdd vfat  iocharset=utf8,dev,suid,rw,exec,auto,user    0    0
    /dev/hda6       none            swap    sw              0       0
    /dev/hdd        /media/cdrom0   udf,iso9660 user,noauto     0       0
    Es geht um die Laufwerke hdb5 und hdc5.

    Weiß einer welche Rechte ich setzen muss? Auf den Partitionen sind alle Rechte (777) auf allen Dateien rekursiv vergeben.

    Hoffe ihr könnt mir helfen.


    Grüße
    unknown
     
  2. ricci007

    ricci007 MacUser Mitglied

    Beiträge:
    2.566
    Zustimmungen:
    13
    Registriert seit:
    11.10.2004
    Ich glaube du bist hier im falschen Forum.

    Dein Fehler ist, dass du /home nach /home/unknown/archiv/movie und /home/unknown/archiv/mp3_hdd mountest. Somit hast du keinen Zugriff auf die zwei letzten Verzeichnisse :D.

    EDIT: Wobei auch deine Mount-Optionen hoechst fragwuerdig sind! Ich wuerde es so probieren (die Verzeichnisse muessen natuerlich auf /home exisitieren, d.h. auf /dev/hda5:

    Code:
    /dev/hdb5       /home/unknown/archiv/movie    auto  user,exec,rw      0    3
    /dev/hdc5       /home/unknown/archiv/mp3_hdd  auto  user,exec,rw      0    3
    
     
  3. unknown

    unknown Thread Starter MacUser Mitglied

    Beiträge:
    95
    Zustimmungen:
    0
    Registriert seit:
    02.06.2006
    Ich dachte ich versuchs hier einfach mal, weil es ja doch mit dem Umstieg zu tun hat :mad:

    Die erste fstab hat das OS selbst angelegt nachdem ich ihm die Verzeichnis vorgegeben hab (hab mal 'nen grafischen Installer getestet) :rolleyes:

    Der Zugriff unter Linux funktioniert erste Sahne, also Verzeichnisse sind vorhanden und die darin liegenden Dateien mit vollen Rechten gesetzt (hilft natürlich nicht wenn der Zugriff eine Ebene höher scheitert.)

    Dank dir, werds heut nach Feierabend daheim mal testen :)
     
Die Seite wird geladen...

Diese Seite empfehlen