LaTeX: Problem mit Umlauten

Diskutiere mit über: LaTeX: Problem mit Umlauten im Office Software Forum

  1. MAVERICK_

    MAVERICK_ Thread Starter MacUser Mitglied

    Beiträge:
    1.203
    Zustimmungen:
    11
    Registriert seit:
    05.05.2005
    Hallo!

    Ich probiere jetzt 4 Stunden herum, vergeblich! Ist es in TextMate wirklich nicht möglich, deutsche Umlaute zu erzeugen? Ich habe in der Präambel das stehen:

    Code:
    \usepackage[applemac]{inputenc}
    \usepackage[T1]{fontenc}
    \usepackage{lmodern}
    
    Trotzdem kann ich keine Umlaute erzeugen, es kommen nur eigenartige Zeichen und Fehlermeldungen, wenn ich Umlaute eingebe! Und das Kuriose: Auch manchen Seiten (ich verwende \include) werden sie erzeugt, auf manchen bzw. den meisten nicht.

    TextMate habe ich deinstalliert und wieder neu installiert. Anscheinend ist es in TextMate wirklich nicht möglich, Umlaute zu erzeugen. In TexShop funktioniert es nämlich.
     
    Zuletzt bearbeitet: 26.12.2006
  2. mr660

    mr660 MacUser Mitglied

    Beiträge:
    294
    Zustimmungen:
    22
    Registriert seit:
    28.08.2006
    das mit den umlauten funktioniert grundsaetzlich schon. textmate setzt grundsätzlich alles in UTF-8. ansich keine schlechte idee, nur manchmal isses eher unpraktisch.

    man muss also entweder TeX auf UTF-8 umstellen oder Textmate beibringen, alles wie gehabt in latin1 zu speichern. ich habe mich für Letzteres entschieden.

    ich setze alles in

    Code:
    \documentclass[fontsize=10pt]{scrlttr2}
    \RequirePackage[latin1]{inputenc}
    \RequirePackage[gen,right]{eurosym}
    \RequirePackage{ngerman}
    \RequirePackage{ifthen}
    \RequirePackage{graphicx}
    % font-einstellungen
    \usepackage[T1]{fontenc}
    \renewcommand{\rmdefault}{0ce}
    \renewcommand{\sfdefault}{0cs}
    \RequirePackage[gen,right]{eurosym}
    \renewcommand{\euro}{\geneuronarrow}
    \setkomafont{footnote}{\sffamily}
    % zapfdings
    % \RequirePackage{pifont}
    \RequirePackage{amssymb}
    
    \begin{document}
    das ist ein Test äöüß
    \end{document}
    
    die Umlaute klappen damit ohne weiteres.

    in den Textmate Einstellungen unter "Advanced -> Saving" noch File Encoding auf ISO-8859-1 und Line Endings auf LF und "Use for existing files as well" markieren.

    das hat bei mir geholfen. der Versuch über UTF-8 und "applemac" hat bei mir auch irgendwie nicht so richtig geklappt...

    Ich hoffe, dass die Textmate-Leute das UTF-8 Handling noch überarbeiten. Textmate versucht wohl intern alles in UTF-8 darzustellen, beim Öffnen von Dateien versucht er dabei den verwendeten Zeichensatz zu erraten. Ich nutze Textmate eben für die Web-Programmierung, und da kann bzw. will ich nicht immer UTF-8 verwendern...


    markus
     
  3. hoppelmoppel

    hoppelmoppel MacUser Mitglied

    Beiträge:
    518
    Zustimmungen:
    2
    Registriert seit:
    12.04.2006
    JO ich habs auch immer auf latin-1
     
  4. helgeh

    helgeh MacUser Mitglied

    Beiträge:
    532
    Zustimmungen:
    12
    Registriert seit:
    18.11.2004
    Bleib ruhig bei utf-8 und füge die folgenden Zeilen zu der Präambel hinzu.

    \usepackage{lmodern} % Diese beiden packages sorgen für echte
    \usepackage[T1]{fontenc} % Umlaute.
    \usepackage[utf8]{inputenc} % Direkte Eingabe von deutschen Zeichen.
     
  5. MAVERICK_

    MAVERICK_ Thread Starter MacUser Mitglied

    Beiträge:
    1.203
    Zustimmungen:
    11
    Registriert seit:
    05.05.2005
    Danke für die Rückmeldungen. Ich habe jetzt echt den ganzen Vormittag rumprobiert und bin echt zermürbt!

    Ich habe jetzt alle Dateien von meinem Projekt neu gemacht. Sonst hätte es nicht geklappt. Es kam anscheinend zu den Problemen wegen dem Dateiaustausch zwischen TexShop und Textmate.

    In der Präambel steht bei mir nun:

    Code:
    \usepackage[utf8]{inputenc}
    
    % Silbentrennung von Wörtern mit Umlauten
    \usepackage[T1]{fontenc}
    \usepackage{lmodern}
    Und in den Preferences habe ich auf "UTF8" und "LF" gestellt. Nun klappt es. Ich musste aber alle Dateien neu erstellen?!

    Könnte es sein, dass es daran lag: Ich habe zuerst alle Dateien in TexShop erstellt. Und dann in TextMate übernommen. In TextMate habe ich sie dann neu abgespeichert. Trotz neuer Speicherung in der richtigen Codierung kam ich nicht umhin, die Dateien neu zu erstellen.

    DANKE NOCHMALS!
     
    Zuletzt bearbeitet: 26.12.2006
Die Seite wird geladen...
Ähnliche Themen - LaTeX Problem Umlauten Forum Datum
LaTeX Problem mit [utf8]{inputenc}, [T1]{fontenc}, fomsdt-Template und Umlauten Office Software 23.02.2014
Texlipse/BibTex Problem Office Software 10.08.2011
LaTeX: apacite funktioniert nicht - endgroup problem Office Software 16.05.2010
LaTeX Problem mit \tableofcontents Office Software 14.02.2010
Latex Problem mit Umlauten in Kapiteln Office Software 30.07.2007

Diese Seite empfehlen

Benutzerdefinierte Suche