LaTeX: i-Installer bietet keine Pakete an

Dieses Thema im Forum "Office Software" wurde erstellt von Crian, 03.05.2006.

  1. Crian

    Crian Thread Starter MacUser Mitglied

    Beiträge:
    555
    Zustimmungen:
    7
    MacUser seit:
    25.05.2005
    i-Installer und LaTeX:

    Ich wollte nun auch mal LaTeX auf mein iBook installieren, um das nicht nur am PC benutzen zu können. Leider ist der Weg dahin steiniger als unter Linux oder Windows.

    Wenn ich den i-Installer starte, sagt er:

    "i-Installer was not able to create the receipts directory /Library/i-Installer. You need to run i-Installer at least once from an account with administrator rights for tis directory to be created. i-Installer will not be able to track info on installed packages without this directory."

    Wenn ich das ignoriere und auf i-Package/Known Package i-Directory klicke, kommt

    "Empty i-Directory. Downloading ended with an empty directory, the site may be offline or your URL in Preferences may be wrong."

    Beim "reload" der URL sagt er, die Verbindung wäre gestört oder der Server down, in Safari kann ich mir das Dokument (http://tug.org/i-packages/iid/gwrelative.iid) aber ansehen.

    Das Problem könnte sein, dass ich keine Admin-Rechte habe, da ich diese, wie hier vorgeschlagen, auf einen zweiten Account ausgelagert habe. Ich hab versucht, in einem Terminalfenster nach "su adminaccount" mit open den i-Installer zu öffnen, dann kommt aber die gleiche Meldung.

    Weiß jemand Rat?

    Seiten zum Thema die ich gefunden habe, die mir aber zu diesem Punkt nicht weiterhelfen (vielleicht weil ich nicht gut suchen kann):

    Ich habe auch die Forensuche nach latex und i-Installer versucht, aber nichts zu diesem Problem gefunden.
     
  2. tasha

    tasha MacUser Mitglied

    Beiträge:
    3.694
    Zustimmungen:
    38
    MacUser seit:
    06.08.2002
    Hi,

    was passiert denn, wenn Du Dich als Administrator einloggst und Du die Installations so probierst?

    Grüße,

    tasha
     
  3. Crian

    Crian Thread Starter MacUser Mitglied

    Beiträge:
    555
    Zustimmungen:
    7
    MacUser seit:
    25.05.2005
    Dann kommt die erste Meldung nicht, aber die zweite mit "Empty i-Directory".
     
  4. daz

    daz MacUser Mitglied

    Beiträge:
    819
    Zustimmungen:
    12
    MacUser seit:
    17.05.2005
    Muss es nicht erst "su adminaccount" und dann "sudo wasauchimmer" heißen?
     
  5. Crian

    Crian Thread Starter MacUser Mitglied

    Beiträge:
    555
    Zustimmungen:
    7
    MacUser seit:
    25.05.2005
    Die erste Meldung kommt ja nicht, wenn ich den i-Installer als Administrator starte. Das Hauptproblem ist, dass keine Pakete gefunden werden.

    Ich hatte mir die LaTeX-Installation irgendwie mactypischer vorgestellt :rolleyes:
     
  6. Jim Panse

    Jim Panse MacUser Mitglied

    Beiträge:
    1.266
    Zustimmungen:
    23
    MacUser seit:
    13.10.2004
    Schmeiß am besten noch mal alles runter von der Platte unnd geht Schritt für Schritt nach diesem Tutorial vor, dann muss es klappen. Auch das Laden der Pakete aus dem iInstaller. Ich habe als absoluter Totalanfänger ohne Ahnung von Nichts es geschafft, es schnell, stabil zum Laufen zu bringen, auch wenn Du schon alles kannst, einen Versuch genau nach dieser Anleitung ist es Wert:

    [DLMURL]http://unimac.switch.ch/students/latex.de.html[/DLMURL]

    Viel Erfolg!!! :)

    Ach ja, Admin solltest Du schon sein bzuw. mit den entsprechenden Rechten ausgestattet sein.... :cool:
     
  7. tasha

    tasha MacUser Mitglied

    Beiträge:
    3.694
    Zustimmungen:
    38
    MacUser seit:
    06.08.2002
    Hi,

    normal ist das in der Tat nicht, an sich geht das problemlos.

    Du könntest auch noch mal ein anderes i-Directory auswählen.

    Grüße,

    tasha
     
  8. Crian

    Crian Thread Starter MacUser Mitglied

    Beiträge:
    555
    Zustimmungen:
    7
    MacUser seit:
    25.05.2005
    Es scheitert ja daran, dass im i-Directory nichts ist, ich hab also von LaTeX noch nichts auf der Platte, was ich runterschmeißen könnte.
    Die Anleitung die ich verwendet hab ist ganz ähnlich, siehe oben.

    Welches denn? Bzw. woher bekomm ich eine Liste solcher i-Directories?


    Edit: Könnte das vielleicht daran liegen, dass ich hier hinter einem Proxyserver sitze? Ich schau gerade mal in die Preferences, vielleicht gibt es da ja eine Einstellung dafür.

    Edit2: Hmm gibts nicht oder ich finde sie nicht...
     
  9. tasha

    tasha MacUser Mitglied

    Beiträge:
    3.694
    Zustimmungen:
    38
    MacUser seit:
    06.08.2002
    i-Package -> Known Packages i-Directory, der Rest sollte selbsterklärend sein.

    Das letzte Mal, als ich den i-Installer hinter einem Proxy benutzt habe (vor ca. 3,5 Jahren[/quote] war das kein Problem.

    Grüße,

    tasha
     
  10. Crian

    Crian Thread Starter MacUser Mitglied

    Beiträge:
    555
    Zustimmungen:
    7
    MacUser seit:
    25.05.2005
    Genau da kommt doch die Meldung, dass das Verzeichnis leer wäre. Hmm... ich probiere es heute Abend mal ohne Proxy.


    Gibt es denn sonst vielleicht irgendwo einfach ein LaTeX-Package, dass man wie alles andere beim Mac auch einfach installieren kann?
     
Die Seite wird geladen...