java - sehr langsam

Dieses Thema im Forum "Internet- und Netzwerk-Software" wurde erstellt von slackfr, 20.02.2006.

  1. slackfr

    slackfr Thread Starter MacUser Mitglied

    Beiträge:
    425
    Zustimmungen:
    1
    MacUser seit:
    20.02.2006
    hallo,
    ich habe folgendes problem, und zwar stratet bei mir java extrem lange. wenn ich z.b. im terminal "jav" eintippe so läuft der lüfter zuerst mal erst richtig an, bis eta 2minuten vorbei sind, dann gibt mir erst das terminal die verschiedenen "befehls" formen die ich bei java dranhängen kann aus (wie es normal auch sein soll"... starte ich java dann erneut, so kommt die ausgabe sofort...

    das gleiche problem mit java habe ich auch bei firefox bzw safari, wenn ich dort z.b. auf map24.de gehe, meine route eingegeben habe, es dann zur karte wechseln will, so bekomme ich zuerts die fehler meldung, das bei mir java angeblich nicht "automatisch" gefunden wurde, ignoriere ich diese fehler meldung, so kan ich die interaktvie karte (java-basiert) ohne probleme nutzen...die fehler meldung taucht ebenfalls erst etwa nach 2min auf...

    habe auch die aktuelle java version installiert, hilft auch nicht (hab aber eh die vermutung das es durch ein update, entweder durchs tiger update, oder java-update zu diesem problem kamm)...

    hatt einer eine idee,
    wie kann ich java komplett deinstallieren, um es neu aufzuspielen,

    danke im vorraus,
    anton (slackfr)
     
  2. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.810
    Zustimmungen:
    3.633
    MacUser seit:
    23.11.2004
    ich würde mal eher die platte checken...
    hast du denn unter dienstprogramme/java mit dem j2se 5.0 voreinstellungen überhaupt eingestellt, dass safari java 1.5 benutzt?
    firefox braucht dafür ein extra plug-in...
     
  3. slackfr

    slackfr Thread Starter MacUser Mitglied

    Beiträge:
    425
    Zustimmungen:
    1
    MacUser seit:
    20.02.2006
    ich kann diese programm nicht einmal starten.. es fängt an sich zu laden, zu lüfter läuft auch auf einmal hoch, und dann kann ich das programm nur noch per rechtsklick auf das symbol "sofort beenden"..

    wie soll ich die platte checken?mit dem festplatten diesntaprogramm, habe ich gemacht: bei der volume-prüfung ist alles ok, bei der rechte-prüfung gibt er mir sowas aus (auch nach der reparatur):
    Es wird spezielle Zugriffsrechte für die Datei oder das Verzeichnis „./Applications/DVD Player.app/Contents/Resources/English.lproj/AboutBox.nib/objects.xib“ verwendet. Neue Zugriffsrechte: 33204....... und davon ziemlich viele meldungen

    übrigens, aheb ich jetzt versucht den ordner java einfach von ordner "dienstprogramme" zu entfernen, und nochmal draufspieen, dabei sagt er mir jetzt, das ich eine neuere version habe, und die installation deshalb abgebrochen werden muss (version 1.50 release 1)
     
  4. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.810
    Zustimmungen:
    3.633
    MacUser seit:
    23.11.2004
    das java liegt nicht in dienstprogramme...
    aber um es wieder neu zu installieren, musst du in /Library/Receipts das Java15Release1.pkg rausnehmen, dann sollte der wieder installieren können...
     
  5. Aronnax

    Aronnax MacUser Mitglied

    Beiträge:
    1.558
    Zustimmungen:
    139
    MacUser seit:
    08.01.2005
    @slackfr
    zum einen, welche Java Version benutzt du denn
    normalerweise hat man 1.4.2_09 - wenn man einfach das OS installiert und die Updates laufen lässt - hier mal zum testen: http://www.java.com/en/download/help/testvm.xml
    und wenn du das nicht hast solltest du mal nach einen Update schauen

    Es gibt noch das hier:
    Standard Edition (J2SE) 5.0 Release 3 http://docs.info.apple.com/article.html?artnum=302412
    wird aber nicht automatisch installiert - ist eben (noch) nicht für normalen Benutzer gedacht.
    -----
    Das map24.de es nicht richtig erkennt, ist ein bekannter Bug der Seite - und nur der Seite, hat nichts mit Fehlern im System zu tun

    -----
    @oneOeight
    das was da schreibst, ist nur relevant wenn man die Edition (J2SE) 5.0 Release 3 benutzen will - wie gesagt, ist sowieso nicht für normale Benutzer gedacht
    und das mit Firefox stimmt so einfach nicht mehr
     
  6. slackfr

    slackfr Thread Starter MacUser Mitglied

    Beiträge:
    425
    Zustimmungen:
    1
    MacUser seit:
    20.02.2006
    habs rausgenommen, geht trotzdem nicht
     
  7. slackfr

    slackfr Thread Starter MacUser Mitglied

    Beiträge:
    425
    Zustimmungen:
    1
    MacUser seit:
    20.02.2006
    da ich das release 1 nicht installieren konnte, hab ich release 3 erfolgreich installiert, das system neugestartet (damit auch java komplet runtergefahren ist) anschließend habe ich versucht deine seite aufzumachen wo java getestet wird, dabei hab ich als fehlermeldung diese bekommen:

    "java.lang.UnsatisfiedLinkError: getProxyConfigURL
    at sun.plugin.net.proxy.MacOSXProxyConfig.getProxyConfigURL(Native Method)
    at sun.plugin.net.proxy.MacOSXProxyConfig.getBrowserProxyInfo(MacOSXProxyConfig.java:30)
    at sun.plugin.net.proxy.PluginProxyManager.reset(PluginProxyManager.java:108)
    at sun.plugin.AppletViewer.initEnvironment(AppletViewer.java:566)
    at jep.MyJavaRunTime.initJavaRunTime(MyJavaRunTime.java:23)
    at jep.AppletHolderFactory.initProperties(AppletHolderFactory.java:323)
    "
    zuvor hatte er bei mir 1.4.2_09 angezeigt,

    gleichzeitig hatte ich auch das java-konfigurations-programm gestartet...zuesrt wie immer, sehr langeswarten, dann tauchte aber doch noch das programchen auf, (gleichzeitig mit der oben beschriebenen fehlermeldung,diese kamm aber seitens firefox)...hab dort jetzt auf 1.50 als erstes in der priorität eijngestellt....starte mal firefox neu...bsi gleich
     
  8. slackfr

    slackfr Thread Starter MacUser Mitglied

    Beiträge:
    425
    Zustimmungen:
    1
    MacUser seit:
    20.02.2006
    nach einem neustart von firefox war die selbe fehlermeldung erneut (in normaler zeit)..nach einem neustart des systems kam diese fehlermeldung nach 2min wieder...hab dann safari gestartet, deine seite http://www.java.com/en/download/help/testvm.xml eingegeben, und dann gab mir safari folgendes wieder:

    "Die Seite „Test Java Virtual Machine - 1.4.2_xx, 1.5.0, 1.3.0_xx, 1.3.1_xx, 1.4.0_xx, 1.4.1_xx“ hat versucht Java-Inhalt zu laden, aber Java ist nicht verfügbar oder nicht installiert."

    was soll das heißen

    wenn ich im terminal java-version eintppe bekomme ich folgendes:
    "java version "1.4.2_09"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_09-232)
    Java HotSpot(TM) Client VM (build 1.4.2-54, mixed mode)"

    eine idee?
     
  9. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.810
    Zustimmungen:
    3.633
    MacUser seit:
    23.11.2004
    beim ADC kann man Release 4 runter laden, ab der version wird 1.5 systemweit standard...

    dann haben die inzwischen das neuere MRJ plugin für 1.5 mit integriert?
     
  10. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.810
    Zustimmungen:
    3.633
    MacUser seit:
    23.11.2004
    irgendwas hast du extrem in deinem system vermurkst...

    du könntest mal versuchen die framework links auf 1.5 umzubiegen...

    aber ich glaub bei dir wäre eher ein clean install angebracht...
     
Die Seite wird geladen...

Diese Seite empfehlen