iWeb Fragen zum Upload

Diskutiere mit über: iWeb Fragen zum Upload im Web-Editoren Forum

  1. Machilden

    Machilden Thread Starter MacUser Mitglied

    Beiträge:
    44
    Zustimmungen:
    1
    Registriert seit:
    27.08.2005
    Ich nutze iweb und erstelle erste Seiten, die auf meinem Rechner fehlerfrei aussehen. Da ich jedoch nicht bei mac angemeldet bin und einen anderen Server nutze ((pytalhost,com), kann ich nur über den Umweg "Speichern in einem eigenen Ordnern und anschließendem Upload mit Cyberduck" die Seiten in Netz stellen. Wenn ich diese dann aufrufe mit Safari oder Opera, erscheinen immer Fehler: Buchstaben/Umlaute an Stellen an denen kein Text steht. Mit Probieren hab ich es bisher nicht geschafft den Fehler einzukreisen,
    weil es mir an Wissen fehlt.

    Wer hat ähnliche Erfahrungen?
    Wer hat eine Vorstellung, wo der Fehler gesucht werden muss?
    Über eine Antwort würde ich mich freuen.
    Hat Mac eine Sperre eingebaut?
    :moin:
    Gruß,
    machilden
     
  2. vielnutzer

    vielnutzer MacUser Mitglied

    Beiträge:
    85
    Zustimmungen:
    1
    Registriert seit:
    03.07.2006
    da muss man eine Datei einfügen .htaccess die das Problem löst
    mit folgendem Inhalt

    AddCharset UTF-8 .html

    damit sollte es laufen
     
  3. Machilden

    Machilden Thread Starter MacUser Mitglied

    Beiträge:
    44
    Zustimmungen:
    1
    Registriert seit:
    27.08.2005
    DANKE für die sehr schnelle Antwort!
    Aber ich bin zu dumm? Was ist gemeint? Eine Textdatei
    mit Namen htaccess
    oder Angabe von AddCharset UTF-8 .html in die indexdatei?
    Gruß
     
  4. vielnutzer

    vielnutzer MacUser Mitglied

    Beiträge:
    85
    Zustimmungen:
    1
    Registriert seit:
    03.07.2006
    ich hoffe ich kanns plausibel erklären

    die .htaccess Datei ist eine Textdatei mit dem genanntem Inhalt
    AddCharset UTF-8 .html

    und wird in das Serververzeichnis geladen, indem die index.html liegt, damit der Browser beim Zugriff auf Unicode umschaltet, da dies offensichtlich der Webserver nicht macht. Klarer? Wenn nicht noch mal melden. Gruss
     
  5. Machilden

    Machilden Thread Starter MacUser Mitglied

    Beiträge:
    44
    Zustimmungen:
    1
    Registriert seit:
    27.08.2005
    Ich übe jetzt erst mal!
    Danke!


    NACHTRAG AM 22.10.06: DER HINWEIS VON vielnutzer IST GOLDRICHTIG!!
     
    Zuletzt bearbeitet: 22.10.2006
  6. Machilden

    Machilden Thread Starter MacUser Mitglied

    Beiträge:
    44
    Zustimmungen:
    1
    Registriert seit:
    27.08.2005
    .htaccess ist eine unsichtbare Datei (.punkt-Datei)
    Diese heißt im Netz plötzlich .htaccess.webarchive.
    ich habe jetzt nur wenig Erfolg vgl. www.sudmann.eu
    Liegt es nur am uniode?
    Gruß
     
  7. vielnutzer

    vielnutzer MacUser Mitglied

    Beiträge:
    85
    Zustimmungen:
    1
    Registriert seit:
    03.07.2006
    die Datei ist als .datei unsichtbar, aber sie muss auf den Server so wie beschrieben, ich habe die Datei in einem Editor - Bsp.: Textwrangler erstellt und erstmal als htaccess benannt und dann als .htacces auf den Server kopiert - man könnte auch auf dem Server umbenennen, dann hat man auf dem System kein Problem. Gruss
     
  8. Machilden

    Machilden Thread Starter MacUser Mitglied

    Beiträge:
    44
    Zustimmungen:
    1
    Registriert seit:
    27.08.2005
    Danke für die Hilfen!
    Mit Umbenennen habe ich eine entsprechende Datei erstellt und hochgeladen.
    Ist die Befehlszeile richtig und vollständig? Leerzeichen?
    Ich kenne den Befehl nicht.
    Gruss
     
  9. Machilden

    Machilden Thread Starter MacUser Mitglied

    Beiträge:
    44
    Zustimmungen:
    1
    Registriert seit:
    27.08.2005
    Nach viele, Probieren bin ich für mich zu folgendem Ergebnis gekommen:
    1. Die iwebseiten sind okay.
    2. Die Befehlszeile - vgl. oben - wird nicht benötigt.
    3. Cyberduck verändert den Quelltext!
    Also: Ich suche mir ein neues FTP-Programm!
    Gruss
     
  10. Mackie1957

    Mackie1957 MacUser Mitglied

    Beiträge:
    309
    Zustimmungen:
    1
    Registriert seit:
    31.10.2004
    Mein iWeb-Seite lade ich auch mit Cyberduck hoch und habe keine Probleme damit.
     
Die Seite wird geladen...
Ähnliche Themen - iWeb Fragen zum Forum Datum
Apple Menüleiste (Design) in iWeb einfügen Web-Editoren 24.08.2014
EverWeb vs Freeway Pro AS - als iWeb Alternative Web-Editoren 10.01.2014
Iweb 3.01: Fragen zu Videos und Fotots Web-Editoren 29.04.2009
Fragen zu iWeb Web-Editoren 20.03.2008
Paar Fragen zu iweb und Danke vorab Web-Editoren 25.10.2007

Diese Seite empfehlen

Benutzerdefinierte Suche