Internet sharing Problem

Dieses Thema im Forum "Internet- und Netzwerk-Hardware" wurde erstellt von goetznet, 27.08.2004.

  1. goetznet

    goetznet Thread Starter MacUser Mitglied

    Beiträge:
    89
    Zustimmungen:
    0
    Registriert seit:
    06.06.2003
    Hallo Zusammen,

    leider konnte die Suche mir nicht so recht weiterhelfen, deshalb wende ich mich erwartungsvoll an euch.

    Ich habe folgendes Problem:

    Mein iBook (10.3.5) ist mit Airport an meinem Zyxel-Router angeschlossen und funktioniert wunderbar. Ich wollte jetzt mit einer Dose (XP Prof.) ebenfalls über mein iBook ins Internet. Dazu habe ich mit einem Crossover-Kabel die Dose mit meinem iBook verbunden und InternetSharing Aktiviert. Und zwar habe ich bei Verbindung gemeinsam nutzen Airport ausgewählt und bei "mit Computern, die folgendes verwenden" habe ich ethernet ausgewählt.

    Folgende Konfiguration habe ich durchgeführt:

    XP:
    IP: 192.168.1.4
    Subnetz: 255.255.255.0
    Router: 192.168.1.5 (IP-Mac)
    DNS: (DNS des Providers)

    MAC (ethernet):
    IP: 192.168.1.5
    Subnetz: 255.255.255.0
    Router: (nix)
    DNS: (nix)

    MAC (airport):
    IP: 192.168.1.2
    Subnetz: 255.255.255.0
    Router: 192.168.1.1

    Wenn ich dass jetzt so aktiviere, kann ich die Dose zwar anpingen und umgekehrt, doch komme ich weder mit dem MAC noch mit der DOSe ins Internet. Muss ich am Router auch noch was ändern? Oder habe ich eine Einstellung falsch vorgenommen?
    Ach ja, Windows Sharing habe ich am MAc auch aktiviert.
    Ich habe echt keine Ahnung mehr was ich noch ändern kann.

    Vielen Dank schon mal im voraus
     
  2. Dr. Snuggles

    Dr. Snuggles MacUser Mitglied

    Beiträge:
    4.727
    Zustimmungen:
    0
    Registriert seit:
    22.07.2003
    Hm ich habe wenig Ahnung aber schalte mal deine Firewalls an den MAschinen aus, vielleicht hilfts. Also beim Internetsharing lag es bei mir daran.
     
  3. Adrenalinpur

    Adrenalinpur MacUser Mitglied

    Beiträge:
    667
    Zustimmungen:
    0
    Registriert seit:
    07.07.2004
    Ich denke mal du mußt mit einem Patchkabel an den Router?
    Was ist das für ein Zyxel?
     
  4. Stefan

    Stefan MacUser Mitglied

    Beiträge:
    412
    Zustimmungen:
    3
    Registriert seit:
    15.12.2002
    Das Problem hatt ich auch, und ich hab auch ewig gebraucht, und es ist wirklich die Firewall des iBooks. Gib da mal den Port 80 frei, und Du wirst auf der DOSe surfen können. Und halt die entsprechenden Ports der Dienste, die auf der DOSe laufen sollen.

    Ciao,
    Stefan
     
  5. glotis

    glotis MacUser Mitglied

    Beiträge:
    553
    Zustimmungen:
    7
    Registriert seit:
    18.05.2004
    Hi
    Port 80? ist doch der webserver.
    Ich würde die Firewall ganz ausschalten du bist doch eh hinter nem Router.
    Ausserdem würde ich direkt mit der DoSe an den Router.
    Kannst du denn den mit dem iBook den Router noch anpingen?
     
  6. Adrenalinpur

    Adrenalinpur MacUser Mitglied

    Beiträge:
    667
    Zustimmungen:
    0
    Registriert seit:
    07.07.2004
    sage ich doch daß er mit der Dose und einem Patch - keinem Crosskabel an die Zyxel soll!
    Bloß mir glaubt ja keiner
     
  7. cla

    cla MacUser Mitglied

    Beiträge:
    2.958
    Zustimmungen:
    128
    Registriert seit:
    24.10.2003
    Dein Netzwerk ist komisch :)

    Du konfigurierst deinen Mac mit Internetsharing als Router, hast aber beide Netzwerkdevices in den selben Subnetz...das kann nur Probleme geben.
    Ohne jetzt näher darauf eingehen zu wollen...warum machst du es nicht folgendermaßen:

    Internet
    |
    Zyxel-Router (WLAN und Ethernet?)-----------iBook über Kabel oder Wlan192.168.1.5
    192.168.1.1
    |
    |
    Dose über Kabel
    192.168.1.4

    Beide Rechner kriegen den Router als DNS & Gateway eingetragen, Subnet darf 255.255.255.0 bleiben.

    Oder du sagst deinem Zyxel, das er DHCP machen soll, und du sagst den beiden Rechnern, das sie ihre Netzwerkkonfig über DHCP beziehen sollen. Dann musst du nicht immer alles per Hand ändern.

    Das funktioniert dann auch, und ist ordentlich.

    Am Kabel liegts wahrscheinlich nicht; du schreibst zwar nicht welches iBook du hast, aber die neueren haben Auto-Sensing...die drehen das Kabel von der Belegung schon so hin, das es passt. Ausserdem kannst du ja Pingen.
    Wenn du aber mit der Dose an den Router gehst, dann brauchste ein normales Patchkabel; oder du steckst das Crosslink-Kabel in den Uplink-Port deines Routers, wenn er denn einen hat.

    Firewalls können dann aktiviert bleiben (müssen aber nicht unbedingt (wg. NAT vom Router)), und Ports musst du NICHT freischalten (bei der OS-X FW und bei der WinXP eingebauten FW auch nicht.)

    cla
     
    Zuletzt bearbeitet: 28.08.2004
  8. goetznet

    goetznet Thread Starter MacUser Mitglied

    Beiträge:
    89
    Zustimmungen:
    0
    Registriert seit:
    06.06.2003
    Hallo,

    erst mal vielen Dank für die Tipps.

    Die Firewalls sind an beiden Rechner ausgeschaltet.

    Die Empfehlung, den PC mittels Kabel direkt am Router anzuschließen scheidet aber aus. Zum einen, da es sich hierbei ume eine Temporäre Lösung handelt und zum anderen weil ich einfach wenig Motivation habe, eine wilde Kabelverleg-Aktion mir durchbruchbohren etc. zu starten.

    Es soll sich daher so gestallten:

    PC (via Kabel) --------> iBook (via Airport) ..........> Router **> WWW

    Es muss doch irgendwie möglich sein, am iBook diese Internet Sharing Sache so hinzu basteln, dass ich mit dem PC über das iBook( via Airport) ins Internet komme. Ich bekomme das aber leider nicht hin. Wenn ich meine oben beschriebene Einstellung verwende, dann kann ich zwar mir dem PC kommunizieren, aber weder das iBook, noch der PC kommt ins Internet.

    Deshalb noch mal die Frage: Welche Einstellung (Router,PC, iBook) könnte den noch probieren, damit ich mit dem PC über die iBook Airport-Verbindung ins Internet komme?

    Falls es was hilft: Es handelt sich um einen Zyxel Prestige HW 640 Router. Mein iBook ist ein G3 900MHz und die Dose hat halt XP Prof drauf.
     
  9. goetznet

    goetznet Thread Starter MacUser Mitglied

    Beiträge:
    89
    Zustimmungen:
    0
    Registriert seit:
    06.06.2003
    Es klappt

    Hallo zusammen, ich habe es doch noch hinbekommen.

    Und zwar so: PC bezieht seine IP-Adresse automatisch und benutz den DNS meines ISP. Beim MAC habe ich die Ethernet(integriert) Schnittstelle kopiert und habe dort eine Manuelle IP eingetragen(192.168.1.5). Router und Gateway habe ich freigelassen. Und siehe da, es klappt pepp

    Jetzt mal zu einem ganz anderen Problem: Ich wollte mich mit einem Freund per VideoChat unterhalten. Er hat leider nur ne Dose mit Netmeeting. Und da ich jetzt auch eine Dose mit Netmeeting dran habe, wollte ich mal fragen, wie ich mein iBook dazu bringe, dass es ankommende TCP/UDP-Pakete fürs Netmeeting an die Dose weiterleitet. Am Router habe ich die entsprechenden Port schon auf Weiterleitung zu meinem iBook gestellt. Jetzt fehlt mir nur noch die letzte Strecke. Für Tipps bin ich sehr dankbar.

    Eins bitte ich noch zu beachten: Ich weiß, dass es andere Programme als Netmeeting gibt, aber ich habe keine WebCam die unter OS X funktioniert.
     
  10. zab71

    zab71 MacUser Mitglied

    Beiträge:
    12
    Zustimmungen:
    0
    Registriert seit:
    23.07.2003
    hi, kannst du mal Bildschirmphotos Deiner Konfig einstellen? Ich hab zwar alles so gemacht, wie Du es beschrieben hast, aber irgendwie wills bei mir nicht funktionieren...
    Gruß Jörn
     
Die Seite wird geladen...

Diese Seite empfehlen