Htaccess Probleme

Diskutiere mit über: Htaccess Probleme im Web-Programmierung Forum

  1. rosa89

    rosa89 Thread Starter MacUser Mitglied

    Beiträge:
    700
    Zustimmungen:
    9
    Registriert seit:
    11.10.2005
    Huhu
    Ich hab ein problem mit htaccess. ich weiss nicht worans liegt. ich bekomme immer folgenden fehler ausm log:

    "/Library/WebServer/Documents/Privat/.htaccess: AuthUserFile takes 1-2 arguments, text file containing user IDs and passwords"

    die hataccess datei sieht folgendermaßen aus:

    "AuthUserFile /Library/WebServer/Documents/.htpasswd
    AuthType Basic
    AuthName "Geschuetzt"
    require valid-user"

    kann mir jmd. sagen was ich falsch mache?
     
  2. catvarlog

    catvarlog MacUser Mitglied

    Beiträge:
    1.468
    Zustimmungen:
    1
    Registriert seit:
    30.01.2005
    Der Fehler bezieht sich auf die Datei "/Library/WebServer/Documents/.htpasswd".
    Schau dort mal rein.
     
  3. rosa89

    rosa89 Thread Starter MacUser Mitglied

    Beiträge:
    700
    Zustimmungen:
    9
    Registriert seit:
    11.10.2005
    hmmm dadrin ist auch alles in ordnung. bloß username:passwort.
    o_O komisch
     
  4. catvarlog

    catvarlog MacUser Mitglied

    Beiträge:
    1.468
    Zustimmungen:
    1
    Registriert seit:
    30.01.2005
    vielleicht hilft dir das weiter: http://forums.macosxhints.com/showthread.php?t=6160
     
  5. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.773
    Zustimmungen:
    3.629
    Registriert seit:
    23.11.2004
    hast du deine .htpasswd auch mittels das htpasswd kommandos angelegt?
    die passwörter müssen verschlüsselt sein, plaintext geht nicht...
     
  6. rosa89

    rosa89 Thread Starter MacUser Mitglied

    Beiträge:
    700
    Zustimmungen:
    9
    Registriert seit:
    11.10.2005
    Ja die Passwörter sind auch verschlüsselt... ich weiss gar nicht wieso es jetzt nimmer geht vorher klappte es immer einwandtfrei...
     
  7. MacMännchen

    MacMännchen MacUser Mitglied

    Beiträge:
    2.877
    Zustimmungen:
    213
    Registriert seit:
    03.10.2006
    der Fehlermeldung nach aus deiner Log lautet der Pfad:
    /Library/WebServer/Documents/Privat/.htaccess

    hast du schon ausprobiert, die .htaccess anzupassen? also:
    AuthUserFile /Library/WebServer/Documents/Privat/.htpasswd

    Grüße
     
    Zuletzt bearbeitet: 05.11.2006
  8. rosa89

    rosa89 Thread Starter MacUser Mitglied

    Beiträge:
    700
    Zustimmungen:
    9
    Registriert seit:
    11.10.2005
    So also erstmal bedanke ich mich für die schnelle Hilfe (wie immer =)). es lag wohl dran das ich nen falschen editor genommen habe beim bearbeiten der htaccess. wirklich sowas doofes ^^
    aber vielen vielen dank
     
Die Seite wird geladen...
Ähnliche Themen - Htaccess Probleme Forum Datum
.htaccess Anpassung Web-Programmierung 27.10.2015
verzeichnis faken mit htaccess Web-Programmierung 29.10.2014
mit gesamter webseite in unterordner umziehen (htaccess) Web-Programmierung 30.01.2013
Weiterleitung auf pseudoordner per htaccess Web-Programmierung 17.12.2010
Probleme mit HTACCESS Web-Programmierung 31.08.2010

Diese Seite empfehlen

Benutzerdefinierte Suche