gcc4 und gcc3 parallel nutzen (ports)

Dieses Thema im Forum "Mac OS X Entwickler, Programmierer" wurde erstellt von srmcore, 09.06.2006.

  1. srmcore

    srmcore Thread Starter MacUser Mitglied

    Beiträge:
    136
    Zustimmungen:
    0
    MacUser seit:
    03.05.2006
    zwischen gcc4 und gcc3 umschalten

    Hi,
    einige pakete aus dem darwin-ports-tree verlangen kompilierung mit gcc3.x
    Ich habe über XCode allerdings 4.0 installiert.
    Wie kann ich den 3er nun parallel mitinstallieren und welche env-variablen sind jeweils zu setzen um dem system mitzuteilen welcher compiler genutzt werden soll?
    Über die Install CDs kann ich den 3er nicht mehr auswählen.
    Ich hätte gedacht ihn per ports nachzuinstallieren.
    Hints anyone?
     
    Zuletzt bearbeitet: 09.06.2006
  2. s2b

    s2b MacUser Mitglied

    Beiträge:
    411
    Zustimmungen:
    19
    MacUser seit:
    27.11.2003
    sudo gcc_select 3.3

    Die 3er kann man, wenn ich es recht im Kopf habe bei der Xcode Installation auch auswählen
     
    Zuletzt bearbeitet: 09.06.2006
  3. srmcore

    srmcore Thread Starter MacUser Mitglied

    Beiträge:
    136
    Zustimmungen:
    0
    MacUser seit:
    03.05.2006
    yiepieh

    Thaaaaaaaank yooouuuuuuuu!

    :freu:


    edit:
    ich habe die tiger upgrade dvd eingeworfen, und der 3er war da deaktiviert. k.a. warum.
    und die OSX.3 geht schon mal gar nicht....
    aber, gcc_select geht wunderbar :)
     
  4. below

    below MacUser Mitglied

    Beiträge:
    13.882
    Zustimmungen:
    1.086
    MacUser seit:
    15.03.2004
    Öööööh, weil Dein System auf den neuesten Stand gebracht wurde?

    Alex
     
  5. srmcore

    srmcore Thread Starter MacUser Mitglied

    Beiträge:
    136
    Zustimmungen:
    0
    MacUser seit:
    03.05.2006
    nun, das würde ich als punkt für die verweigerung von 10.3 gelten lassen :) (wie gesagt)
    aber warum mir 10.4 xcode tools install die markierung von gcc3.x verweigert verstehe ich in diesem zusammenhang nicht.
    Ich bin mir eigentlich auch deutlich sicher beide versionen bei der installation ausgewählt zu haben (sind ja auch beide auf meinem system vorhanden). gcc4.x kann ich immer noch auswählen aber das menü liefert mir überhaupt keinen anhaltspunkt darüber ob die version 3 installiert ist oder nicht :)
    Was soll das mit der Aktualität meines Systems zu tun haben?

    Stephan
     
Die Seite wird geladen...