ftp auf G4 / Os 10.4.6 einrichten

Dieses Thema im Forum "Internet- und Netzwerk-Software" wurde erstellt von ChrisEs, 14.04.2006.

  1. ChrisEs

    ChrisEs Thread Starter MacUser Mitglied

    Beiträge:
    142
    Zustimmungen:
    0
    MacUser seit:
    19.11.2003
    hallo,

    ich möchte auf meinem Quicksilver G4 unter MacOs 10.4.6 einen Bereich einrichten auf dem ich Daten für den dowwnload bereitstellen möchte als auch die möglichkeit des upload übers internet geben möchte. Das möchte ich über FTP ermöglichen. Dafür5 habe ich mir die Donationware PureFTPd instaliert und über den PureFTP Manager FTP gestartet.

    Wenn ich die aber in einem anderen Browser eingebe, bekomme ich die Meldung "Firefox kann keine Verbindung zu dem Server unter ... aufbauen."eine verbindung kommt nicht zustande. Die Adresse die ich im Browser angebe ist <meine server ip> Meine Server ID zeigt mir der pureFTP Manager an.

    Was mache ich nur falsch, übersehe ich irgendwo etwas? Wer hat hier schonmal erfolgreich einen FTP server auf seinem Rechner mit pureFTP eingerichtet. Bin dankbar für jeden Tip...
     
  2. schmuchal

    schmuchal MacUser Mitglied

    Beiträge:
    270
    Zustimmungen:
    6
    MacUser seit:
    28.08.2002
    falls dein g4 an einem router hängt, wegen dem internetzugriff, musst du ggf. noch die ftp-ports im router weiterleiten auf die lokale IP des g4.

    oder kannst du schon direkt auf dem g4 nicht auf den ftp-server zugreifen?
     
  3. schmuchal

    schmuchal MacUser Mitglied

    Beiträge:
    270
    Zustimmungen:
    6
    MacUser seit:
    28.08.2002
    gib mal folgendes im browser des g4 ein: localhost, damit solltest du in das verzeichnis "incoming" wechseln.

    achtung: der ftp-dienst unter "sharing" muss deaktiviert werden, da sonst der eingebaute ftp-server von mac os x läuft. ggf. kommen die sich dann ins gehege...
     
  4. ChrisEs

    ChrisEs Thread Starter MacUser Mitglied

    Beiträge:
    142
    Zustimmungen:
    0
    MacUser seit:
    19.11.2003
    dem router habe ich in der Portfreigabe die g4 IP Adresse freigegeben, aber leider kann ich mich immer noch nicht einwählen.

    In den Systemeinstellungen/Sharing habe ich unter Dienste den FTP Zugriff aktiviert. In den Firewall Einstellungen ist Firewall und FTP Zugriff aktiviert.

    Da ist aber auch noch die Einstellung Internet. Wenn ich da Ethernet aktivieren will bekomme ich ein Warnmeldung:
    "Falls SSie diesen Anschluss aktivieren, kann ihr Internet Anbieter Ihre Verbindung trennen, um eine Netzwerkstörung zu verhindern"
    das hört sich beängstigend an und ich trau mich nicht das zu aktivieren, oder ist das garnicht notwenig?
     
  5. schmuchal

    schmuchal MacUser Mitglied

    Beiträge:
    270
    Zustimmungen:
    6
    MacUser seit:
    28.08.2002
    1. FTP-Zugriff unter "Sharing" deaktivieren (s.o.)
    2. Internetzugriff unter "Sharing" deaktivieren. Du brauchst diese Einstellung nur, wenn der G4 als Router fungieren und somit seine Internetverbindung anderen Rechnern im LAN zur Verfügung stellen soll
    3. Erst probieren, ob du mit localhost in den "incoming" Ordner kommst
    4. Nun versuchen, ob dein FTP-Server unter der öffentlichen IP erreichbar ist
     
  6. ChrisEs

    ChrisEs Thread Starter MacUser Mitglied

    Beiträge:
    142
    Zustimmungen:
    0
    MacUser seit:
    19.11.2003
    localhost funktioniert... was sagt mir das?

    meinst Du den "FTP-Zugriff" unter Sharing/Dienste deaktivieren? aber der wird doch auch von pureftp eigeschaltet.
     
  7. schmuchal

    schmuchal MacUser Mitglied

    Beiträge:
    270
    Zustimmungen:
    6
    MacUser seit:
    28.08.2002
    du hast recht, dass bezog sich wohl nur auf die installation.

    wenn der server unter localhost erreichbar ist, dann ist erst mal alles i.O., und es liegt dann wohl an der weiterleitung von router zum server. versuch mal serverip:21.
     
  8. ChrisEs

    ChrisEs Thread Starter MacUser Mitglied

    Beiträge:
    142
    Zustimmungen:
    0
    MacUser seit:
    19.11.2003
    funktioniert nicht.
    serverip:21
    der browser lädt aber zeigt leider keine Seite ... aber auch keine Fehlermeldung
     
  9. schmuchal

    schmuchal MacUser Mitglied

    Beiträge:
    270
    Zustimmungen:
    6
    MacUser seit:
    28.08.2002
    du musst im router die tcp/ip ports 20 und 21 weiterleiten auf die LAN-IP Adresse des routers. hast du dass gemacht? oder welchen router verwendest du denn?
     
  10. ChrisEs

    ChrisEs Thread Starter MacUser Mitglied

    Beiträge:
    142
    Zustimmungen:
    0
    MacUser seit:
    19.11.2003
    eine fritz box. Provider ist 1und1.

    die entragungen da sind:
    FTP Server
    Protokoll: TCP
    Port: 21
    an IP Adresse: (Adresse die in Systemeinstellungen/Netzwerk angegeben ist)
    an Port: 21
     
Die Seite wird geladen...